1. Are you ready for the Galaxy S20? Here is everything we know so far!

Error building Froyo AOSP

Discussion in 'Android Devices' started by gdanko619, Oct 22, 2010.

  1. gdanko619

    gdanko619 Lurker
    Thread Starter

    Hi all, I am posting across multiple forums to try and gather as much help as possible. I am taking on the task of building 2.2.1 AOSP on a Samsung Captivate. I've got the vendor files set up and I think I have what I need. The build completes successfully but I have this nagging error in logcat:

    Code (Text):
    1. I/SurfaceFlinger( 2249): SurfaceFlinger is starting
    2. I/SurfaceFlinger( 2249): SurfaceFlinger's main thread ready to run. Initializing graphics H/W...
    3. E/SurfaceFlinger( 2249): Couldn't open /sys/power/wait_for_fb_sleep or /sys/power/wait_for_fb_wake
    4. E/IMGSRV  ( 2249): [PVRSRVConnect fail] PVRSRVEnumerateDevices failed!
    5. E/IMGSRV  ( 2249): [PVRSRVConnect fail] PVRSRVEnumerateDevices failed!
    6. E/FramebufferNativeWindow( 2249): couldn't open framebuffer HAL (No such device)
    7. D/libEGL  ( 2249): loaded /system/lib/egl/libEGL_POWERVR_SGX540_120.so
    8. D/libEGL  ( 2249): loaded /system/lib/egl/libGLESv1_CM_POWERVR_SGX540_120.so
    9. D/libEGL  ( 2249): loaded /system/lib/egl/libGLESv2_POWERVR_SGX540_120.so
    10. E/IMGSRV  ( 2249): [PVRSRVConnect fail] PVRSRVEnumerateDevices failed!
    11. E/IMGSRV  ( 2249): [SRV_SGXServicesInit fail] PVRSRVConnect failed!
    12. E/IMGSRV  ( 2249): [eglInitialize fail] 0 attempt to initialize!
    13. E/IMGSRV  ( 2249): [PVRSRVConnect fail] PVRSRVEnumerateDevices failed!
    14. E/IMGSRV  ( 2249): [SRV_SGXServicesInit fail] PVRSRVConnect failed!
    15. E/IMGSRV  ( 2249): [eglInitialize fail] 1 attempt to initialize!
    16. E/IMGSRV  ( 2249): [PVRSRVConnect fail] PVRSRVEnumerateDevices failed!
    17. E/IMGSRV  ( 2249): [SRV_SGXServicesInit fail] PVRSRVConnect failed!
    18. E/IMGSRV  ( 2249): [eglInitialize fail] SRV_ServicesInit failed!
    19. W/libEGL  ( 2249): 0: eglInitialize(0x1) failed (EGL_BAD_ALLOC)
    20. E/libEGL  ( 2249): eglInitialize:740 error 3001 (EGL_NOT_INITIALIZED)
    First of all, I see a couple of files in /sys/power that I need. How do I put them into my build?

    Next, it looks like the graphics system isn't wanting to fire up. Perhaps I am missing something very specific. At this point I am stumped.

    Is IMGSRV the graphics system? Perhaps EGL cannot init because of the IMGSRV errors?

    Any help is appreciated. :)
     



    1. Download the Forums for Android™ app!


      Download

       
  2. BitVenom

    BitVenom Lurker

    Did you get anywhere with this? I am on a similar path, though this is a month-old message - any chance you have an update?
     

Samsung Galaxy S Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...