1. Download our Official Android App: Forums for Android!

Error Gradle project sync failed

Discussion in 'Android Development' started by Breno Roriz, Sep 10, 2018.

  1. Breno Roriz

    Breno Roriz Newbie
    Thread Starter
    Rank:
     #600
    Points:
    25
    Posts:
    11
    Joined:
    May 1, 2018

    May 1, 2018
    11
    0
    25
    Hello, today I opened my project and it asked to update, I updated and at the end it gave this error. Can someone help me?

    Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
    It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html


    Configuration 'debugCompile' is obsolete and has been replaced with 'debugImplementation' and 'debugApi'.
    It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html


    Configuration 'releaseCompile' is obsolete and has been replaced with 'releaseImplementation' and 'releaseApi'.
    It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html


    Unable to resolve dependency for ':mad:debug/compileClasspath': Could not resolve project :CordovaLib.
    Open File
    Show Details


    Unable to resolve dependency for ':mad:debugAndroidTest/compileClasspath': Could not resolve project :CordovaLib.
    Open File
    Show Details


    Unable to resolve dependency for ':mad:debugUnitTest/compileClasspath': Could not resolve project :CordovaLib.
    Open File
    Show Details


    Unable to resolve dependency for ':mad:release/compileClasspath': Could not resolve project :CordovaLib.
    Open File
    Show Details


    Unable to resolve dependency for ':mad:releaseUnitTest/compileClasspath': Could not resolve project :CordovaLib.
    Open File
    Show Details
     

    Advertisement

  2. mobileapplication

    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Sep 14, 2018

    Hey, I have faced same issue recently then someone suggested me to clean the gradle and rebuild it.
     

Share This Page

Loading...