1. Check out our companion app, Forums for Android! Download from Google Play

General error: insuffient storage

Discussion in 'Android Devices' started by GamingForever, Jul 11, 2012.

  1. GamingForever

    GamingForever Well-Known Member
    Thread Starter

    Sep 1, 2011
    Has anything got this error and how do I fix it.. I deleted some files and i have over 400 mb.I get this error when I download from the play store..

    I am rooted if that matters.. I dont want to factory reset...


  2. Ascaris

    Ascaris Member

    Jan 7, 2013

    I am new here... just signed up in part so I can answer this question. You probably resolved it by now, given that the post was six months ago, but I wanted to have the answer out there in case someone else has the same issue.

    I have a Galaxy Tab 2 7.0 (rooted 4.0.4 ICS), and I had the same issue. I searched extensively for a solution online, but nothing worked. I trimmed my /sdcard (which is what Samsung oddly calls the internal storage) down to 500mb, leaving several gb available, and it still refused to install most apps from Google play (a few did work).

    I tried formatting the /cache partition and wiping the Dalvik cache, restoring permissions... none of that helped.

    I saw some web pages that described a procedure for setting the preferred install location from external back to internal memory in to fix this issue, using the command shell, but I had not ever used the shell to set the option in the first place. Then it hit me... maybe one of the root apps I had downloaded had.

    That was it. I looked at the Options in the Link2SD app, and sure enough, it did show "external" for the install-to location. I must have seen that option and changed it to External in my efforts to save space on /sdcard. I changed it back to Automatic, and app installs worked again.

    ICS does not support moving apps to the external storage, but apps still have a flag set for "allow move to SD" or "disallow move to SD" because Android 2.x is still in use and does have this ability. The combination of setting the pref to use external memory and ICS not permitting this made the install fail with either the apps that had the flag set or those that did not.

    Hope this helps someone!

Share This Page