1. Download our Official Android App: Forums for Android!

ES file explorer cannot find server

Discussion in 'Android Apps & Games' started by tescoid, Dec 20, 2013.

  1. tescoid

    tescoid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    5
    0
    5
    Hi there. I'm tearing my hair out with this.

    As the threat title suggests, I cannot find the server via as file explorer. What makes this frustrating is that the server is the default gateway as I have a USB device plugged into my router, and my nexus 10 uses this gateway to access the internet.

    File explorer can see other devices on the network, and other devices on the network can see the server files, so I don't know where I'm going wrong. Also, this is a new problem. I used to be able to see the files fine up until a few days ago. The timing was similar to the upgrading of android 4.2.2 but I don't know if this is related.

    Any help would be much appreciated.

    Thanks!
     

    Advertisement

  2. Old_Bull

    Old_Bull Newbie
    Rank:
    None
    Points:
    15
    Posts:
    11
    Joined:
    Feb 4, 2013

    Feb 4, 2013
    11
    0
    15
    Did you tell it to scan? I use the same app on all my devices and I click on the left side and choose LAN, then scan.
     
  3. tescoid

    tescoid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    5
    0
    5
    Yes, but I'm afraid that comes to nothing.
     
  4. Old_Bull

    Old_Bull Newbie
    Rank:
    None
    Points:
    15
    Posts:
    11
    Joined:
    Feb 4, 2013

    Feb 4, 2013
    11
    0
    15
    I would reinstall it and restart your router and storage device. If that fails, I don't know what else to suggest.
     
  5. Phil42

    Phil42 Member
    Rank:
    None
    Points:
    23
    Posts:
    94
    Joined:
    Jul 19, 2011

    Jul 19, 2011
    94
    29
    23
    Is your phone rooted and are you comfortable with using the Terminal?

    If so, you can send a ping command to your router's IP address and see whether or not it replies.
     
  6. tescoid

    tescoid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    5
    0
    5
    Phil, I won't lie: I don't know what a lot of that means. But surely if the tablet can access the internet via the router then there is no problem in communication between the two, no?
     
  7. Phil42

    Phil42 Member
    Rank:
    None
    Points:
    23
    Posts:
    94
    Joined:
    Jul 19, 2011

    Jul 19, 2011
    94
    29
    23
    In *theory* if your tablet can access the Internet through your router then the tablet and router have a two-way connection. But there are a lot of different networking parameters which have to be set up properly and it's possible you can end up with a situation where some things work and others don't.

    Download Ping & DNS from the Playstore (I don't think it requires root) and see if you can Ping your router. (Typically the router's address is 192.168.2.1, although there are other IP addresses commonly used.)

    If you're on Windows download and install Wireless Network Watcher. It will show all of the wired and wireless devices on your network. Your Tablet should show up as one of the devices on your network.

    Then the hard part - Google, Google, Google. You almost are certainly not the first person with this problem and there's probably a solution somewhere online.
     
    tescoid and dustwun77 like this.
  8. tescoid

    tescoid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    5
    0
    5
    Thanks Phil for your reply.

    I'm afraid I'm getting nowhere with this.

    I downloaded the app you recommended and pinged the router with out any trouble. And I have looked as hard as I can on the internet to see whet the problem is, without luck.

    I've tried to access the router's USB drive on other devices, and have found I am able to do so on my iPad, but not my nexus 4 or 10. I am able to see other network devices from my nexus and I have the same trouble using the nexus using other network apps. This has led me to conclude the problem is with the nexus, not the router, apps, or USB drive. This would make sense as the problem started when I updated system software to android 4.2.2.

    Do you have any idea how this can be remedied?

    Thanks again.
     
  9. tescoid

    tescoid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    5
    0
    5
    @Phil42,

    I have done a bit more work on this.

    I plugged in a USB stick instead of the drive to see if this was the problem and still nothing. Other devices on the network were able to see the files on the stick, however. This has led me to conclude that the problem is definitely with Android and these devices accessing samba servers.

    I installed AmdSMB and tried to access this way. Again, no luck, but the error I'm getting from this app is:

    smb://yourserver:445/ java.net.UnknownHostException: yourserver
    PWD
    smb://yourserver:445/ java.net.UnknownHostException: yourserver

    Does anyone know what this means?

    Also, I have tried static IP and this does nothing.

    Any help would be HUGELY appreciated.

    Thanks, all. And happy new year!
     

Share This Page

Loading...