1. Are you ready for the Galaxy S20? Here is everything we know so far!

ES File Explorer help needed

Discussion in 'Android Apps & Games' started by andolini411, Dec 1, 2009.

  1. andolini411

    andolini411 Newbie
    Thread Starter

    Whenever i try to do the remote access to my computer from my phone i get an error saying "smb://[my IP address]/ network path not found or time out, please try again". When i set it up for location i put "smb://[my ip]" and i put in my user name and password for my comp. it seems to work fine when i made it, icon showed up an all like it should have, but when i try clicking on it to get the files and see/access them, i get that error. What am i doing wrong?

     


  2. Best Answer:
    Post #80 by ZeRoseDev, May 26, 2013 (2 points)

    1. Download the Forums for Android™ app!


      Download

       
  3. andolini411

    andolini411 Newbie
    Thread Starter

  4. andolini411

    andolini411 Newbie
    Thread Starter

  5. andolini411

    andolini411 Newbie
    Thread Starter

    come on guys, Help me out here
     
  6. Herodroid

    Herodroid Well-Known Member

  7. andolini411

    andolini411 Newbie
    Thread Starter

    Awesome! thanks alot for that website, i have wifi on but have never been able to connect to my wifi from my phone, i know i have the password right, but i think theres a setting my mom put on the router itself thats stopping me. even when i had my TouchPro and there was no password on our router i still couldnt connect to my wifi....so idk whats up with that. but all my PCs in the house connect to the router just fine. i even PMed Estrongs like 2-3 days ago and i never heard anything from him. again, thanks alot!!
     
  8. estrongs

    estrongs Lurker

    Sorry for late reply.
    Those days we're busy working for last version, and don't notice your question, sorry.
    In most case the communication might be blocked by the firewall, on router or on the PC.
    You can send mails to contact <at> estrongs.com if any more question.

     
  9. andolini411

    andolini411 Newbie
    Thread Starter

    i've already opened port 137(i think thats the one it was) on my pc's firewall. and i've added my phone to our router, and i can connect to the internet via the wifi. So i dont think its the router firewall stopping me, i could be wrong though, maybe its still stopping me from doing it even though i can connect to it for wifi. i'm running out of ideas. i've already turned on all file/media sharing on my pc. everything i could think of.
     
  10. ElAguila

    ElAguila Well-Known Member

    Are you trying to get to a shared folder on your pc?
     
  11. andolini411

    andolini411 Newbie
    Thread Starter

    Yes, i'm trying to get to a shared folder. Can i not access all of my files? or is it only the files that are in the "shared" folders?
     
  12. mjschmidt

    mjschmidt Android Expert

    Has anyone found an answer to this yet? I am having the same trouble, I get error messages when trying to connect to my PC with Estrong. I contacted the Dev via his/her web site about a week ago and haven't heard back. I see lots of people saying they can do it successfully, but I am stumped.

    I am running Windows 7 Pro 64-bit (Dev says it was tested with this ver and worked).

    I have WiFi on. I have shared folders on my PC. I have file sharing on. I've also opened Port 137 in Windows Firewall.

    I am using dynamic IP addresses, is this a problem? I get my current IP address from IPCONFIG each time I try to connect.

    I am using the built in Windows 7 Firewall. Is there a setting a need to change? Win7 Firewall does not give any notices when I am trying to connect with Estrong.

    After I create the server icon in Estrong using my IP address (with my username and password) when I press the icon to connect I get the error message "Network path not found, or time out, please try again".

    If I try to create the server using the IP address and direct path to the shared folder like "192.168.1.100\\MYCOMPUTER\test" or "192.168.1.100\\c:\test" I get the error message "Error, can not find the server."
     
  13. troyboytn

    troyboytn Well-Known Member

    Same problem here. I have Googled til I'm bkue in the face. Bottom line, this will not work with Win 7. Uninstalled.....not near as good as Astro without PC feature working.
     
  14. momoceio

    momoceio Android Expert

    It's working fine for me...took me all of 3 minutes to set it up. I turned off the firewall for the Home/Private network. I'm running Win 7 Ultimate x86. Streaming music off my laptop as we speak.
     
  15. Herodroid

    Herodroid Well-Known Member

    I'm running Windows 7 64 Premium and it works just fine.
     
  16. troyboytn

    troyboytn Well-Known Member

    Windows 64 ultimate here. Is there any specific thing you guys did to get this working...aside from disabling the firewall(tried that)? I really want this to work.
     
  17. momoceio

    momoceio Android Expert

    Here's my steps for sharing my music:

    On my PC
    1) Right click My Music -> Properties -> Sharing tab -> Share button
    2) Selected my username (not the Homegroup account)
    3) Also click Advanced Sharing, check "Share this Folder"
    3) Control Panel -> Windows Firewall -> Turn Windows Firewall On or Off -> turn off private network firewall (Public is on with "Notify me when Windows Firewall blocks an incoming connection" checked)

    On my phone:
    1) Open ES File Explorer -> Lan tab
    2) Add new server
    3) Server <ip of computer>/share name ex: 192.168.1.10/music
    4) Your user name on the PC
    5) Your password on the PC

    This will not work if you aren't on your local WiFi. Unless you know what you're doing and setup a dyndns account and do some port forwarding...but then you've just opened up a big security hole :)
     
  18. Herodroid

    Herodroid Well-Known Member

    I didn't disable my firewall.

    Select LAN tab, then menu and new server

    [​IMG]

    When you see the menu, input your IP with username and password and hit ok

    [​IMG]

    You should get an icon like this

    [​IMG]

    After clicking the icon, you should be able to access your files

    [​IMG]
     
    stevegunn likes this.
  19. momoceio

    momoceio Android Expert

    or add /sharename after the IP to map directly to a share
     
  20. mjschmidt

    mjschmidt Android Expert

    @HeroDroid: I did everything you did, and I still get those error messages.

    For the record, my HDD is also partitioned, but I tried this with a shared folder on my C drive.

    Does it have anything to do with the type of encryption used on the Router? I am using WPA-TKIP. Should that matter?

    I will try again with the firewall off for private network (although I'd prefer not to).

    Also, I have advanced file sharing set up so that to have access to my files you must have an account on the computer (thus the need to use the user name and PW to connect) so, for example, any of my family members trying to access my files from another computer in the house would either need to know my username and pw, or would have to be logged in to an account on the other computer with the same credentials. Could this be the problem?
     
  21. momoceio

    momoceio Android Expert

    No, that's how mine is setup as well.
     
  22. mjschmidt

    mjschmidt Android Expert

    Then there must be something else I'm missing, something about my network, my file sharing set up, or a bug with the version of ES File EX I DLed from the market. Perhaps I will try uninstalling and reinstalling.
     
  23. ADJackson171

    ADJackson171 Lurker

    I was having trouble with this as well as only some of my files were coming up but I followed momoceio's instructions and now have complete access. Thanks!!! This is a great program.
     
  24. troyboytn

    troyboytn Well-Known Member

    Thanks for the tips momoceio, unfortunately there is nothing I can seem to do to get it to work.:thinking:
     
  25. Hangdog42

    Hangdog42 Well-Known Member

    I'm running into a similar, but not exact problem, and I'm starting to wonder if there is a problem with how Estrongs is handling usernames and passwords. I'm running a Samba server on Linux with shares that are generally available and some that need a username and password to access. The generally available shares I can connect to without a problem, but if I try to access the /home share, I keep getting the "Error, cannot find server" message. I'm thinking this is an Estrongs problem since every other device I've tried can connect without any issue. Does anyone have any experience with Samba homes shares and Estrongs?
     
  26. Hangdog42

    Hangdog42 Well-Known Member

    I just thought I'd update my post to say I've discovered what I think is a bug in File Explorer. I ran Wireshark on my Samba server to see if packets from File Explorer were actually reaching the server. When I logged into one of the shared accounts, it was clear packets were reaching the server. However, when I tried to log into my private account, absolutely no packets were seen. I created a different private account and found that I could log into that new account. A little bit more fiddling revealed that that presence of a question mark in the password of the original private account was causing Fex to not send any packets. If I eliminated the ? from the password, communication between Fex and the Samba server happened. So the upshot appears to be that non alphanumeric characters (or at least a ?) in passwords prevents File Explorer from making a connection.
     
  27. ZeRoseDev

    ZeRoseDev Android Enthusiast

    Okay, so after HOURS of tinkering, I finally found a solution that works. I did this in XP, but I know for a fact there are similar settings in Windows 7(not sure if they will accomplish this goal though).

    The scenario:

    I could access my PC via ES File explorer, but when I clicked on MOST of the folders inside, i got "Account has no permissions" error. The only folder I did have access to was the default "Shared Documents" folder, and that pointed me to my solution.

    Here is what I did:

    1. Right clicked the Shared Documents folder on my PC.
    -- The one that let me in via ES File Explorer.

    2. Clicked Properties, then the Security Tab.

    3. I Right clicked the folder I wanted to be able to access via ES File Explorer.

    4. Clicked Properties, then the Security Tab.
    -- I noticed huge discrepancies between the two.

    5. In the Security tab of the folder I was wanting to share, I added all the users that were in the already accessible "Shared Documents" Folder
    They were:
    -Administrator
    -Everyone
    -Power Users
    -SYSTEM
    -Users


    **To add them, click Add, then begin typing the name of the user/group you would like to add, then click "Check Names" and it will enter the correct, exact name, that is required.**

    6. After you have entered all the names, click "OK" on that window, then "Apply" on the next one(the properties window)

    7. Wait for the permissions to be applied (I shared my entire 300GB 2nd HD so it took about 4 minutes, and gave me a not responding error, just be paitent)

    8. Back in ES File Explorer, simply press "Refresh" or exit the appllication, and start it back up.

    9. Hopefully you're browsing your PC files via your phone.


    :D Let me know if this worked for you.​


    ***Update***
    I can confirm this works with Windows 7 too.
     
    Deleted User and insec like this.
Loading...

Share This Page

Loading...