1. Are you ready for the Galaxy S20? Here is everything we know so far!

Evo 4g Camera App APK

Discussion in 'Android Devices' started by TheCowGod, Aug 28, 2010.

  1. incredibler

    incredibler Lurker

    can someone post a version that does not need the permissions changed? or post the apk at a link that will allow my phone to download it unchanged?

    1. Download the Forums for Android™ app!


  2. CatsTide

    CatsTide Android Expert

    if ur rooting and romming root explorer is a must buy app...you won't regret it.
  3. incredibler

    incredibler Lurker

    ok bought root explorer, I can see the apk in my sd card and open it and change permissions, then try to install it and it fails...any ideas?
  4. Spart

    Spart Well-Known Member

    Are you moving the original to a different folder, then moving the new one to the apps folder, then changing permissions and rebooting?
  5. incredibler

    incredibler Lurker

    i think i messed up pretty bad...i used titanium to remove the original camera app and then downloaded root explorer, changed the permissions and am having trouble getting it to install...i have s-off running fourth wave with hboot .92, and adryn's kernal
  6. Spart

    Spart Well-Known Member

    You just have to copy/paste, or move the new file to the right folder, then fix permissions. I changed permissions then moved it and it didn't work until I did it again within the right folder.
  7. yojoe600

    yojoe600 Android Expert

    just put it into system>app folder and reboot and make sure the permissions are right then reboot
  8. incredibler

    incredibler Lurker

    thanks for all the help, the file is like 862k right? I moved it to the app folder and the permissions are read write read read, there whenever i try to install it, it just says intsall failed.
  9. incredibler

    incredibler Lurker

    sorry guys...i got it...didn't realize that once the .apk file is in the system app folder I don't have to actually install it. The camera file is working properly....thanks, pretty new to these kinds of changes
  10. roninld

    roninld Member

    Also works for me with no issues. Ran the chmod commands from adb shell, and everything is great!

    Thanks again.
  11. TheCowGod

    TheCowGod Member
    Thread Starter

    I updated the first post with a zip file that can be installed through clockwork.
    roninld and fliptwister like this.
  12. j-money

    j-money Well-Known Member

    Damn you CowGod, that would of saved me a few bucks i spent on Root Explorer!!! haha, but i do love that program now, i know ill use it again,

    Thx for the zip tho, it will make it easier next time i have to do this lol.
  13. Yup, the permissions fixed it for me as well. Thanks for the tips everyone. It's nice having the onscreen shutter...
  14. fliptwister

    fliptwister Well-Known Member

    Wow, thanks so much for this TheCowGod! I cannot tell you how many blurry pictures I had (or how many pictures I missed by pressed power button) when having to press optical joystick. On screen shutter is so much better. I'm liking the new face detection and other improvements as well.
  15. TheCowGod

    TheCowGod Member
    Thread Starter

    Your welcome! I thought that the stock 2.2 had face detection, I might be wrong though. I only used it a couple times before I switched to the evo camera.
  16. gilee

    gilee Newbie

    I am using CM6.0.1.
    And whenever I go into recovery, and install the EVOcamera.zip.
    After I reboot, I will keep getting forced close whenever I open camera.
    Any ideas?
  17. fliptwister

    fliptwister Well-Known Member

    I don't think so. I have been running Froyo for nearly a week and I do not believe I got the face detection while in camera...could be wrong.
  18. fliptwister

    fliptwister Well-Known Member

    Did you change the permissions with root explorer to:
    User: Read, Write
    Group: Read
    Other: Read
  19. pkmn760

    pkmn760 Well-Known Member

    Thanks, ima installit now lol i like it
  20. gilee

    gilee Newbie

    What Root Explorer you guys using?
    I am using Root Explorer 2.8.1. It is a purple icon.
    I just installed it, and it keep force close whenever I open the Root Explorer after I ask me for SU permission. Any ideas?

    I really cannot stand the CM6.0.1 Camera. It sucks.
  21. ethon

    ethon Member

    Couldn't get it working with CM 6.0.1 either. Tried changing permissions with adb and with Root Explorer. Continued to Force Close everytime. Gave up and went to a different ROM
  22. Mean Sixteen

    Mean Sixteen Newbie

    just loaded with your zip file.

    you are awesome.

    This is a nice improvement on the stock Camera.

    I am on skyraider 3.0 with bf#2 king kernel.
  23. xintensex

    xintensex Well-Known Member

    Ok I installed with UD8 Force Closes?? Damn I really wanted to this one to work, I love the HTC camera!!
  24. TheCowGod

    TheCowGod Member
    Thread Starter

    Yeah, there is no way this is going to work with any vanilla roms. The camera drivers are different and the sense framework that the camera requires is missing as well. You will have to stay with one of the sense based roms if you want to use this...
  25. Contempt

    Contempt Well-Known Member

    I have downloaded it on 3 machines one being right to the phone and I am getting that the zip file is invalid or unsuccessful download.

    What size is the file and does anyone have a working zip file they can post?


    EDIT: 4th time was the charm. That file hosting site is hinky. 3 empty zip folder and the 4th downloaded fine.

    Camera is awesome. Thanks for posting this. I love it.

    BTW the file size is 565 KB.

HTC Droid Incredible Forum

The HTC Droid Incredible release date was April 2010. Features and Specs include a 3.7" inch screen, 8MP camera, Snapdragon S1 processor, and 1300mAh battery.

April 2010
Release Date

Share This Page