1. Are you ready for the Galaxy S20? Here is everything we know so far!

Evo 4G to Boost Mobile Guide/Evo 3D

Discussion in 'Android Devices' started by solbadguy89, Dec 9, 2011.

  1. OverByter

    OverByter Resident Slide Rule Guru

    Even if it finally was able to work, you would have spent probably 20+ hours, taken 2 perfectly good phones and you would be able to make calls, sms, maybe have 3G data, mms, definitely won't have 4G data. It just doesn't make sense. :rolleyes:

    ocnbrze likes this.

    1. Download the Forums for Android™ app!


  2. jons1976gp

    jons1976gp Lurker

    So I am in step 4 of the guide using QXDM. I have my doner incognito hooked up to com 6. I activated the port in QXDM and ran the commands in the guide. I do not see the HA Shared password in the results generated. I am also a bit confused, in this guide I am assuming he means to have the doner phone hooked up. But in the PDF guide at this steps he mentions to choose the HTC EVO port at this step. Which is correct?

    Thank you in advance for any help you can provide. I can't yet attach images. so here are the results I am getting.

    13:33:59.778 Password 01f2030f5f678ff9
    13:33:59.778 RequestItem "Send Security Password Request" 0x01 0xf2 0x03 0x0f 0x5f 0x67 0x8f 0xf9
    13:33:59.887 DIAG TX item:
    13:33:59.887 Password[0] = 0x01
    13:33:59.887 Password[1] = 0xF2
    13:33:59.887 Password[2] = 0x03
    13:33:59.887 Password[3] = 0x0F
    13:33:59.887 Password[4] = 0x5F
    13:33:59.887 Password[5] = 0x67
    13:33:59.887 Password[6] = 0x8F
    13:33:59.887 Password[7] = 0xF9
    13:33:59.887 DIAG RX item:
    13:33:59.887 Password Result = Correct
    13:34:34.137 Requestnvitemread ds_mip_ss_user_prof
    13:34:34.137 DIAG TX item:
    13:34:34.137 index = 0
    13:34:34.137 mn_ha_shared_secret_length = 0x00
    13:34:34.137 mn_ha_shared_secret[0] = 0x00
    13:34:34.137 mn_ha_shared_secret[1] = 0x00
    13:34:34.137 mn_ha_shared_secret[2] = 0x00
    13:34:34.137 mn_ha_shared_secret[3] = 0x00
    13:34:34.137 mn_ha_shared_secret[4] = 0x00
    13:34:34.137 mn_ha_shared_secret[5] = 0x00
    13:34:34.137 mn_ha_shared_secret[6] = 0x00
    13:34:34.137 mn_ha_shared_secret[7] = 0x00
    13:34:34.137 mn_ha_shared_secret[8] = 0x00
    13:34:34.137 mn_ha_shared_secret[9] = 0x00
    13:34:34.137 mn_ha_shared_secret[10] = 0x00
    13:34:34.137 mn_ha_shared_secret[11] = 0x00
    13:34:34.137 mn_ha_shared_secret[12] = 0x00
    13:34:34.137 mn_ha_shared_secret[13] = 0x00
    13:34:34.137 mn_ha_shared_secret[14] = 0x00
    13:34:34.137 mn_ha_shared_secret[15] = 0x00
    13:34:34.137 mn_aaa_shared_secret_length = 0x00
    13:34:34.137 mn_aaa_shared_secret[0] = 0x00
    13:34:34.137 mn_aaa_shared_secret[1] = 0x00
    13:34:34.137 mn_aaa_shared_secret[2] = 0x00
    13:34:34.137 mn_aaa_shared_secret[3] = 0x00
    13:34:34.137 mn_aaa_shared_secret[4] = 0x00
    13:34:34.137 mn_aaa_shared_secret[5] = 0x00
    13:34:34.137 mn_aaa_shared_secret[6] = 0x00
    13:34:34.137 mn_aaa_shared_secret[7] = 0x00
    13:34:34.137 mn_aaa_shared_secret[8] = 0x00
    13:34:34.137 mn_aaa_shared_secret[9] = 0x00
    13:34:34.137 mn_aaa_shared_secret[10] = 0x00
    13:34:34.137 mn_aaa_shared_secret[11] = 0x00
    13:34:34.137 mn_aaa_shared_secret[12] = 0x00
    13:34:34.137 mn_aaa_shared_secret[13] = 0x00
    13:34:34.137 mn_aaa_shared_secret[14] = 0x00
    13:34:34.137 mn_aaa_shared_secret[15] = 0x00

    Attached Files:

  3. new optimus

    new optimus Android Expert

    To get the donor password the donor needs to be connected, might be a typo in the guide.
    it would appear the nv items are not unlocked I see it says password correct though.
    If you want some real time help with that pm me with your chat client, yahoo, gchat, or facebook
  4. jons1976gp

    jons1976gp Lurker

    Thank you for the reply. I'm usually pretty technically sufficient, so this has been driving me crazy! I'll check on the nv items, I'll get back to you if I am unsuccessful.

    Thanks again
  5. jons1976gp

    jons1976gp Lurker

    So the weird thing is that I was able to gather all 4 Nv items from the Incognito w/o issue and saved those 4 files. I was also able to gather the NAM1/2 info and save that as well in the prior steps, so i know my phone had to be unlocked successfully with the spc code i had entered in CDMA prior to all that. So basically I am unsure as to why i can't get this password, I believe I have the AAA password, as the guide says its in the NV 466 file I saved. So I think i am only missing the HA shared pw
  6. new optimus

    new optimus Android Expert

    the aaa is a 32 digit alphanumeric number.

    the ha is the same on all sprint network phones, it will be 736563726574
    ocnbrze likes this.
  7. kolosus

    kolosus Android Expert

    Not to split hairs with you optimus, you know your stuff but...

    The aaa is a 32 character alphanumeric string.

    Just rubbing it in, pun intended.
    ocnbrze likes this.
  8. new optimus

    new optimus Android Expert

    ocnbrze likes this.
  9. spcturner

    spcturner Lurker

    where should I start my spc scan for the prevail the incognito is 0363 not sure for prevail?
  10. new optimus

    new optimus Android Expert

    For the prevail you just need to use the default samsung password in cdma ws then the spc should show up in the box.
    If that does not work you should be able to get it if your phone is rooted using one of the many methods in the play store.
    There should not be a need to scan memory.

    If nothing else works for you there is another easy way, if you have a second boost mobile phone esn available you can sign into boost account and click update handset, then put in a different esn then what your currently using set it, and then after its listed and activated a screen will come up telling you the msl of the phone, then just put your phone esn back in and it will tell you the msl of the prevail, your current phone, the spc an msl are the same number.
  11. cjhickey12

    cjhickey12 Lurker

    New guy here flashed from sprint to boost... last night everything worked for a second then i got error 67 and got authentication code could not be verified when making data call.

    the NV items have been written the NAMs have been written ESN and meid is good. NAIs look good. the only thing i can think of is when i write the NAMS and i get an error NV_UE_IMEI_I status: NV_READONLY_S

    Anyone know what that means?

    i would really like to get this working any help is appreciated
  12. new optimus

    new optimus Android Expert

    That is normal, happens with every write to phone I have done on the evo.

    2 questions, 1 did you make sure the meid was correct. and 2 did you make sure the donor phone was not turned on.
    You can never have both phones on and trying to get signal at the same time.
    ocnbrze likes this.
  13. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    ok so i moved you to the boost guide thread, where you can get better help.
    thanx optimus for responding. rock on guys!!!!!:)
  14. aatayyab

    aatayyab Lurker

    great info:congrats:
  15. esthernrob

    esthernrob Android Enthusiast

    i have been at this for a week now... everything goes as planned but no luck... am i missing something in clearing the meid and esn? i have tried the list provided, the search method provided and this guide.... my esn and meid never change... my phone number and current username change to my donor phone but mied stays the same... don't know if i'm clearing everything correctly or not.... i am about ready to throw in the towel....

    *edit - if i can convince the wife, (yeah right), i'm going to spend the money outright for the GS3 and have boost activate that
  16. new optimus

    new optimus Android Expert

    You dont want to follow the old method of clearing the memory locations.

    use the evo 3d method, start with QPST build 366 open the efs file explorer it is listed in the guide on the first page, just under evo 3d.
    esthernrob and ocnbrze like this.
  17. esthernrob

    esthernrob Android Enthusiast

    i have been successful in clearing esn, i will follow the 3d directions and attempt the meid...

    * edit - so far so good except i have no file "0" or "1943". going to pull each file and scan for meid...
  18. new optimus

    new optimus Android Expert

    You need nuild 366 of qpst
    esthernrob likes this.
  19. esthernrob

    esthernrob Android Enthusiast

    yes, figured that out eventually... rackin' my brain on this darn thing... finally got everything zeroed out and written but something is not sticking.... phone doesn't "reboot" after final write... hook back up and check settings, profile is back to 1, not zero... everything else looks fine, meid, esn, phone #.... gonna try again tomorrow...
  20. new optimus

    new optimus Android Expert

    Try this, dialer menu ##786# reset, phone will go back to basic factory settings, it will try to activate, dont let it, put the phone in diag mode connect up to qpst service programing profile 0 the nai will be the phones original meid@sprintxxxxx what ever right, change the meid to the donor meid@ and everything behind the @ leave the same

    then write the HA and the AAA for the donor profile 0 then click on write to phone it will reboot it may try to activate, or it may not as it will still be in diag mode. take it out of diag mode reboot, if activation does not try.

    when it comes up it will try to activate
    let it. then it will write the profile 1 for you as well as redo all nam info.
    esthernrob likes this.
  21. esthernrob

    esthernrob Android Enthusiast

    ok, done that, now get "error code 1012" during hands free activation. is that due to my phone not getting a signal? said to try update profile, same thing.... UGH

    *edit - what if i try the whole thing over with a different radio? i downgraded as the guide suggested. maybe if i flash to the newest it might help? i dunno... the "flashevotoboost.com" guide says nothing about downgrading... i guess it couldn't hurt now that my esn and meid have been changed already.
  22. new optimus

    new optimus Android Expert

    Could help can't hurt
  23. esthernrob

    esthernrob Android Enthusiast

    if it ain't one thing, it's another. now i come up with "error code 67. registration failure. pcs vision username/password may be incorrect". what is this referring to? ha and aaa passwords?
  24. new optimus

    new optimus Android Expert

    Yes, that is usually from the AAA wrong, but I have seen that from the stupidest things

    Try doing profile update if it does not work, go through the entire ##768# reset through re-entering the proper profile 0 nai meid and ha and aaa then allow it to activate.

    I once got the error 67 just because those steps were not followed in order.

    REMEMBER TO CHECK THE PROFILE 0 NAI. Which is the donor phone meidnumber@hcm.sprintpcs.com

  25. Digital404

    Digital404 Member

    Hey all!

    I need some help here, I have a htc evo 4g (sprint) trying to get boost mobile on it. I have a doner phone for it but don't have the data to switch over. Can someone help me here.


HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date

Share This Page