1. Are you ready for the Galaxy S20? Here is everything we know so far!

Evo boot failure due to exchange sync

Discussion in 'Android Devices' started by jsanjose, May 30, 2010.

  1. jsanjose

    jsanjose Lurker
    Thread Starter

    I ran into this with my corporate e-mail this week on a Google I/O Evo. The setup of my exchange account was painless. Just need to plug-in my e-mail, password and a device password. Exchange syncing works fine until you turn off your phone.

    When you power the phone back on, it boots up to the point where the Sprint intro video plays. At that point, according to Sprint tech support, the Exchange syncing hits a snag and causes the phone to restart indefinitely...playing that same loud, annoying intro video over and over.

    The only workaround was to open up the bootloader (power+volume down on power up) and erase all my data. I went through a simple setup and a simple setup + exchange again to confirm that it was indeed the Exchange account that introduced the problem.

    Hopefully HTC can get this fixed soon.

    1. Download the Forums for Android™ app!


  2. Slacker4Life

    Slacker4Life Member

    What version of Exhange does your company use? This is rather disconcerning as I have a number of Evos on order for my environment and this would be a huge deal.
  3. alillowr

    alillowr Newbie

    I am sorry I don't have a solution, but I was wondering what exchange features (when its working) syncs? I am coming from an iphone and will be using my google voice number on the evo, so I am not quite sure which route I will take with the google contacts and exhchange contacts.

    I was wondering which parts of exchange syncs because on the iphone, only contacts, mail and calendar syncs. It would be pretty nice if I could get notes, tasks, and any other function that I might not know about yet sync nicely with the evo.
  4. Bek

    Bek Android Expert

    Interesting. What version of Exchange does your corporation run? I've been set up on mine all week without issue.
  5. stroths

    stroths Well-Known Member

    Can't speak for the EVO, but I was running Android on my TP2 for a while when I had my own Exchange server (Exchange 2007). I didn't run into any issues, but maybe I was just lucky. I have since moved to Google Apps solely for email due to the ease of administration.
  6. donnyb

    donnyb Member

    I'm having the same problem. I believe it may have something to do with the security setting on the phone when you have an exchange account setup. I will just use Touchdown until the bug is fixed.
  7. jsanjose

    jsanjose Lurker
    Thread Starter

    We're on 2007.
  8. ahahn

    ahahn Lurker

    donnyb, did you switch to Touchdown, and did the problem go away?
  9. rich04

    rich04 Lurker

    I have 2010, will report back on Friday. Heavily dependent on email, hope this isn't an issue.

    Also, will Android let you sync to 2 different exchange organization accounts? For those IT admins out there that admin exchange, how does the phone appear in the ECP under device provisioning if it isn't 'really' using activesync?
  10. donnyb

    donnyb Member

    I'm not having any problems with touchdown. It a good alternative until HTC fixes the OEM exchange.
    ahahn likes this.
  11. pokerjv

    pokerjv Newbie

    crap, i ran into this too. just an endless loop. do I select recovery when in bootloader mode?
  12. asaberan

    asaberan Well-Known Member

    I believe this is an intentional limitation of Activesync. No device that I have come across (Apple, Versamail, Windows Mobile, Android, etc.) will allow you to setup more than one Exchange account, even in the same organization. I have Exchange 2007, so maybe it is different in 2010, but I doubt it.
  13. sloanthebone

    sloanthebone Lurker

    Same thing happened to me, but it happened to happen when I installed the update from Sprint. Guess it was activesync that did it and not the update.... interesting.

    P.S. The people on my floor asked me to leave because my phone was so loud from the dumb thing constantly rebooting =)

    Here are the steps to hard reset if you need to:

    How to hard reset the HTC EVO 4G

    We show you how to factory reset the HTC EVO 4G to clear all data and restore its original settings

    The HTC EVO 4G is highly customizable and you have been hard at work tweaking it to your liking, but now the fun is over and you want to return it to its factory settings again. Here, we show you how to hard reset the HTC EVO 4G with step by step instructions.

    Please note that all data will be deleted from the HTC EVO 4G as a result of this procedure. This process does NOT delete data stored on the microSD card. We recommend backing up all of your personal data before proceeding.

    Turn the power off.

    If your HTC EVO 4G is frozen, pull the battery out and reinsert it

    Hold the Volume Down button

    Press and release the Power button

    You are now presented with a menu that allows for Fastbook, Recovery, Clear Storage, and Simlock

    Select Clear Storage by pressing the Volume Down button

    Press and release the Power button

    Now simply confirm your decision: Volume Up for YES and Volume Down for NO

    If you selected YES, all data including third-party applications will be deleted from the HTC EVO 4G. Once the wipe is complete, the phone will reboot to its factory fresh state.
  14. jsanjose

    jsanjose Lurker
    Thread Starter

    Looks like pokerjv got his answer.

    Did anyone try this again after today's OTA software update?
  15. sloanthebone

    sloanthebone Lurker

    Just to add an update to this, I added my activesync setup back in and powered off the phone and now its stuck rebooting over and over again. If you set up activesynce with Exchange, don't power off you device or you have to do a hard reset. This is awesome!
  16. SARC

    SARC Newbie

    So, I picked up my Evo from RS at 4pm..... got everything working on it (including Exchange Activesync)..... was quite pleased with myself.... then switched the phone off and on again...... and it's stuck in the welcome video loop.... so looks like I get the joy of resetting it and having to set everything up again.

    Wonderful. How to really take the shine off something
  17. messier

    messier Lurker

    Hey all-
    First off, THANK YOU for the great wisdom on this page/thread, as my new EVO is in the start-loop as well (arghhh!!). I've tried to follow what i think was described for hard reset, but it's not working. I've held the power button down, and hit the down-volume button as well, but nothing happened. I then held the power button down and quickly tapped both the volume up and volume down button (essentially simultaneously), and that got the loop to stop, vibrate, and then go to the white "HTC EVO 4G" screen for about 5 seconds...only to then default to the musical intro loop again!! (Arghhh!)...could one of you wise people type out the error of my sequence. At this point, I'd LOVE to be able to even get to the hard reset screen and have an erased-data phone...i just want this loop to stop!! THANKS for your help!
  18. SARC

    SARC Newbie

    Sorry to hear you have the same issue as I had.

    To perform the hard reset, follow these instructions exactly..

    Hold the Volume Down button (And keep holding it down....)

    Press and release the Power button (while you still have the volume down button held in)

    You are now presented with a menu that allows for Fastbook, Recovery, Clear Storage, and Simlock

    Select Clear Storage by pressing the Volume Down button

    Press and release the Power button

    Now simply confirm your decision: Volume Up for YES

    I downloaded touchdown from the android market and it is working quite nicely, so if there is no quick fix over the air, I'll probably end up buying it.

    Any others having the same problem ? It's weird that it only seems to happen on some exchange servers ?
  19. OmegaSMP

    OmegaSMP Newbie

    For those of you having problems, is your device password all numbers? Change it to put in some letters and it might fix the issue.
    sch8r likes this.
  20. SARC

    SARC Newbie


    Sounds like a great tip.

    Yes, my PW was all numbers...... I'm a little apprehensive to try again though as I haven't got a back up yet.... perhaps someone else on here who has a good data back up would like to give this a try ?
  21. messier

    messier Lurker

    Thanks, SARC! Hard reset worked...just got done resetting stuff. And yes, my password was all numbers --- is there a pattern/clue to the problem??

    I'm not going to re-configure my work email until i learn a bit more...so if it is a number-exclusive password issue (if that's a pattern for others out there), please post your info. Thanks everyone!
  22. donnyb

    donnyb Member

    My password was all numbers. Messier since you already doing a reset can you test out the all numbers theory?
  23. SARC

    SARC Newbie

    I would give it a try but I just did some other experimenting with exchange activesync and I can't get my calendar to sync. It just goes round and round and eventually errors with "socket time out" Mail and Contacts sync really fast. I have calendar set to the minimum data amount, ie 2 weeks, and I don't have any huge appointments with attachments in my calendar, and I've tried syncing across WiFi and 3G and the calendar does not sync :mad:

    So, in summary, moving from a Tytn II running WinMo 6.0, I now have a bigger screen but less functionality.... awesome.
  24. messier

    messier Lurker

    Havent been courageous enough to retry the exchange-sych for y work email...may wait and see what others have experienced first (but i am v.v. intrigued by the all-number password clue...maybe that's the problem after all??). If anyone has any definitive news on the all-number password issue, please let us know!

    Questions: 1) has anyone tried calling Sprint to see what their tech support people have said re: all-number password and the exchange issue?...2) this is my first android, but i have seen some comments about a Touchdown app? Is this app the real deal, could it solve our issue for work email (reviews seem pretty great)?

    Thanks for all the feedback, everyone. Outside of this major work-email/exchange issue, i havent had any big problemsw/EVO (yet).
  25. sloanthebone

    sloanthebone Lurker

    Thanks for this info! I just deleted my Exchange account and set it back up using a alpha-numeric password and then rebooted my device and I no longer have the issue! This does indeed fix the issue! I was having the issue before with the numeric password. Thanks again!
    donnyb likes this.

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
Similar Threads - Evo boot failure
  2. NoteEight
  3. Mandroid038
  4. Miiilowo
  5. Tom Joney
  6. kirann2801
  7. fath3r
  8. jakeburns
  9. ludemon
  10. App Update

Share This Page