1. Download our Official Android App: Forums for Android!

Root EVO Useless After Nandroid Backup

Discussion in 'Android Devices' started by LittleRedDot, Jan 10, 2012.

  1. LittleRedDot

    LittleRedDot Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    605
    Joined:
    Dec 23, 2011

    Dec 23, 2011
    605
    169
    113
    I ran a nandroid backup this morning and when it reboot nothing was working... The background was there, but no widgets... The notification bar was updating, but the softkeys won't work... I can't scroll through my homescreens, or open anything.

    Help!

    I can get into recovery though.... Yay:(?
     

    Advertisement

  2. Rxpert83

    Rxpert83 Dr. Feelgood
    Rank:
     #12
    Points:
    1,953
    Posts:
    17,922
    Joined:
    Aug 30, 2011

    Aug 30, 2011
    17,922
    13,145
    1,953
    Male
    Graduate Student
    MN
    Restart the phone
    If that doesnt fix it wipe dalvik cache & cache in recovery & reboot
    If that doesnt fix it Restore the nandroid
    If that doesnt fix it your gonna have to reflash your ROM

    What recovery are you on?
     
    Granite1 likes this.
  3. LittleRedDot

    LittleRedDot Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    605
    Joined:
    Dec 23, 2011

    Dec 23, 2011
    605
    169
    113
    Amon Ra
    Mik3.0
    Freedom Agressive
     
  4. argedion

    argedion The TechnoFrog
    Rank:
     #28
    Points:
    953
    Posts:
    6,360
    Joined:
    Jun 20, 2011

    Jun 20, 2011
    6,360
    6,292
    953
    The Infernal Swamp
    Which version of amon Ra? A couple of people have had issues with 3.11 restoring I currently am running 3.11 and I had to wipe cache and dalvic to get it restored properly.
     
  5. LittleRedDot

    LittleRedDot Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    605
    Joined:
    Dec 23, 2011

    Dec 23, 2011
    605
    169
    113
    Yeah it is 3.1 and I've had to reflash mik3.0 a couple times in like 3 days.
     
  6. Rxpert83

    Rxpert83 Dr. Feelgood
    Rank:
     #12
    Points:
    1,953
    Posts:
    17,922
    Joined:
    Aug 30, 2011

    Aug 30, 2011
    17,922
    13,145
    1,953
    Male
    Graduate Student
    MN
    I went back to 3.08 within a couple days of 3.11 coming out
     
    dustwun77 and argedion like this.
  7. MizzouBrent

    MizzouBrent Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    2,853
    Joined:
    Feb 13, 2011

    Feb 13, 2011
    2,853
    2,519
    313
    Olathe, KS
    Ugh, I would stick with 2.3. No issues EVER for me, and I flash all the time. I'm rolling with 3.11 for now, but I've had two issues with nandroids and the newer version of RA.

    I would get the 2.3 version of RA and install it, then clean flash of MikG...then make sure to make a backup of it once you get everything set up.
     
    MusicJunkie, dustwun77 and argedion like this.
  8. LittleRedDot

    LittleRedDot Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    605
    Joined:
    Dec 23, 2011

    Dec 23, 2011
    605
    169
    113
    I know how to upgrade my recovery, but how do I downgrade it?
     
  9. dustwun77

    dustwun77 Endeavor to Persevere :)
    Rank:
    None
    Points:
    623
    Posts:
    4,828
    Joined:
    Feb 24, 2010

    Feb 24, 2010
    4,828
    2,847
    623
    Male
    ET
    SC
    I'm going to hang with the 3.08 for a while. No prob with it so far. hope it stays that way.
     
  10. dustwun77

    dustwun77 Endeavor to Persevere :)
    Rank:
    None
    Points:
    623
    Posts:
    4,828
    Joined:
    Feb 24, 2010

    Feb 24, 2010
    4,828
    2,847
    623
    Male
    ET
    SC

    same way, just have to have the right file, named right, in the right place.
     
    ocnbrze likes this.
  11. chazjung

    chazjung Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Dec 27, 2011

    Dec 27, 2011
    5
    0
    5
    Green Bay, WI

    I only skimmed this but...couldn't you just restore the backup you just did in recovery?
     
  12. RCope48

    RCope48 Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    151
    Joined:
    Aug 30, 2010

    Aug 30, 2010
    151
    64
    53
    Boiler Master
    Colorado
    Lot of chatter about this, guess this is not even written by the same dev, it's amon RA "style" recovery, I didn't even take a chance, I made 2 backups with it, didn't try to restore, I'm back to 2.3....it works for me...go with what you know I say!:)
     
    ocnbrze likes this.
  13. argedion

    argedion The TechnoFrog
    Rank:
     #28
    Points:
    953
    Posts:
    6,360
    Joined:
    Jun 20, 2011

    Jun 20, 2011
    6,360
    6,292
    953
    The Infernal Swamp
    I didn't realize it was not actually Amon Ra. I mean yes I've seen "Style" attached to it but never had it really dawn on me that its not the same Developer. I assumed because of the Higher version and the Signature:
    "RA Supersonic v3.11" I thought the old one was basically the same signature except obviously a different version.

    I never had an issue with 3.08 nor 2.3 I was able to recover from my nandroid just had to do a few extra steps (wipe cache and dalvic) after the restore. I actually kept a 3.08 nand on the card remembering what Miz went through. I still have the 308 image on my card as well.
    I also had to reinstall my Quick Boot. The only app that did not restore.
     
  14. LittleRedDot

    LittleRedDot Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    605
    Joined:
    Dec 23, 2011

    Dec 23, 2011
    605
    169
    113
    Ok the restore went fine and my device is once again happy, and I downgraded to 2.3. Thanks for all your help! Seems like the more you need help around here the quicker the troops mobilize!
     
    ocnbrze and dustwun77 like this.
  15. boofer

    boofer Well-Known Member
    Rank:
    None
    Points:
    23
    Posts:
    95
    Joined:
    Jul 1, 2011

    Jul 1, 2011
    95
    44
    23
    bringing back a slightly old thread. i flashed tommy's classic senseless tonight and got everything just the way i like it. i did a nandroid backup, then tooled around with some things (wiped battery stats in amon ra recovery, installed google voice search), but decided i wanted to revert back. nandroid restore did absolutely nothing, and in fact, it wiped all google apps including market, etc. i don't understand what went wrong. i've used nandroid backup at least 8 times in the past two weeks and it has always worked, but now it's not working and i'm going to have to re-do basically everything that i've done in the past two hours.

    anyone have any ideas? i've wiped cache/dalvik, tried nandroid restore 4 times now, but no dice. it just gets me to the stock tommy's classic and google apps cannot be found either.

    am i SOL?
     
  16. boofer

    boofer Well-Known Member
    Rank:
    None
    Points:
    23
    Posts:
    95
    Joined:
    Jul 1, 2011

    Jul 1, 2011
    95
    44
    23
    just to add something curious...i'm looking in settings > applications > manage applications, and i see ALL of the apps that i installed a few hours ago, and they're all named "com.google.android.youtube" and "com.pandora.android" etc. the icons are greyed out and it says SD in the lower right part of the icons.

    so, the apps are all there, but are they all being restored to my SD card but not to my phone's internals in some weird way? i have no idea what's going on here. is my SD card messed up? i'm copying and deleting files from it with no issues.
     
  17. dustwun77

    dustwun77 Endeavor to Persevere :)
    Rank:
    None
    Points:
    623
    Posts:
    4,828
    Joined:
    Feb 24, 2010

    Feb 24, 2010
    4,828
    2,847
    623
    Male
    ET
    SC
    That is too weird. do you have any other nands you can restore to see if THEY work? :thinking:
     
  18. argedion

    argedion The TechnoFrog
    Rank:
     #28
    Points:
    953
    Posts:
    6,360
    Joined:
    Jun 20, 2011

    Jun 20, 2011
    6,360
    6,292
    953
    The Infernal Swamp
    not sure what happend there. I'm using Amon RA 3.11 and never had this kind of issue even with the 2.3 by Amon himself. did you check userdata? as far as google apps they are tied into the system for Sense BASED ROMS so I don't get that either. Unfortunately it sounds like you will have to redo it all over again and do another nandroid I wouldn't be surprised to find out you either inadvertently removed the x from the data option.
     
    dustwun77 likes this.
  19. Rxpert83

    Rxpert83 Dr. Feelgood
    Rank:
     #12
    Points:
    1,953
    Posts:
    17,922
    Joined:
    Aug 30, 2011

    Aug 30, 2011
    17,922
    13,145
    1,953
    Male
    Graduate Student
    MN
    Sometimes nandroid backups go wrong. Its pretty rare but its been known to happen.
     
  20. boofer

    boofer Well-Known Member
    Rank:
    None
    Points:
    23
    Posts:
    95
    Joined:
    Jul 1, 2011

    Jul 1, 2011
    95
    44
    23
    darn it. after being a serial ROM flasher this month, i'm pretty much done with it. i did REALLY like tommy's classic senseless with go launcher too, but now i'm paranoid. i'll be going back to alterom or mikG and probably stop flashing ROMs for awhile now. :(

    btw, just restored my last alterom 0.0.5 and it worked flawlessly. guess that will have to do for now.
     
  21. mikem0269

    mikem0269 Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    1,094
    Joined:
    Aug 15, 2011

    Aug 15, 2011
    1,094
    844
    213
    Male
    Illinois
    One thing i can think of is tommys roms have dt aps2sd enabled. Is your sd partitoned and if it is did you select sd ext in the nandroid backup. If not that might be why it sees the apps but dont know where they are.
    I could be totaly wrong here also.
     
    ocnbrze and Granite1 like this.
  22. Granite1

    Granite1 Zercron Encrusted Tweezer
    Rank:
    None
    Points:
    833
    Posts:
    7,159
    Joined:
    Dec 27, 2010

    Dec 27, 2010
    7,159
    7,180
    833
    Male
    Highway Construction Inspection
    Pittsburgh, PA
    Good call. ;)

    I was thinking the same thing. If you've got the card partitioned, when you wipe prior to flashing anything you need to wipe the sd ext as well. Also when you do a nandroid you need to check the sd extension or the app won't be backed up, and the simlinks will be broken.

    Hopefully thats the culprit, but your card may be effed up also. It might not be a bad idea to backup your sd card to your pc, then reformat the card, which includes partitioning it, if you have that.
     
    ocnbrze likes this.
  23. boofer

    boofer Well-Known Member
    Rank:
    None
    Points:
    23
    Posts:
    95
    Joined:
    Jul 1, 2011

    Jul 1, 2011
    95
    44
    23
    oh dang. yep, i have my SD card partitioned. honestly, i don't really think i need to have it partitioned because i keep my apps at a bare minimum and use mobile sites instead for a lot of stuff.

    soooo i guess i'm screwed because i didn't back up my SD EXT. thanks for your input! lesson learned.
     
    dustwun77, mikem0269 and ocnbrze like this.
  24. brianvillage5

    brianvillage5 Well-Known Member
    Rank:
    None
    Points:
    88
    Posts:
    209
    Joined:
    Mar 16, 2011

    Mar 16, 2011
    209
    150
    88
    That's strange, I've been using 3.11 for a month or more. I never have a problem with it switching from random ice alphas and betas to cm7, savaged zen rc4, myns, switching radios kernels. No problems here.
     
  25. Rxpert83

    Rxpert83 Dr. Feelgood
    Rank:
     #12
    Points:
    1,953
    Posts:
    17,922
    Joined:
    Aug 30, 2011

    Aug 30, 2011
    17,922
    13,145
    1,953
    Male
    Graduate Student
    MN
    I use 3.11 as well, but I still recommend everyone to use 2.3.


    I mainly use 3.11 because they put wiping SD card way down at the bottom so I don't have to worry about wiping that :cool:
     
Tags:

Share This Page

Loading...