1. Are you ready for the Galaxy S20? Here is everything we know so far!

Exchange intermittent connectivity problem

Discussion in 'Android Devices' started by Miront, Dec 14, 2009.

  1. Miront

    Miront Newbie
    Thread Starter

    My Droid will stop receiving emails from Exchange randomly. When this occurs I am still getting gmail emaisl just fine and there are no other issues that I can see. Clicking refresh does not retrieve new emails either. Battery pull yields no new results. All of a sudden after a few hours of no emails they will start coming in again. Another person in my building has a Droid and he does not have any of these issues connecting to the same server.

    My settings:

    Account Type: Exchange
    Email Check Frequency: Automatic (Push)
    Domain\Username: My Domain\My Username
    Password: My Password (this has to be right since it works most of the time)
    Exchange Server: my.exchangeserver.com (this has to be right since it works most of the time)
    Use Secure Connection (SSL): Unchecked

    Sync Contacts: Unchecked.

    Again, 90% of the time I am working just fine, but that 10% of the time that email doesn't get to me is very frustrating.

    Has anyone experienced this?

    1. Download the Forums for Android™ app!


  2. Inphosys

    Inphosys Well-Known Member

    Why are you not using SSL? I'm an Exchange Admin with 5 droids connected to my server now. We use a self-signed/self-created SSL certificate using the Certificate Authority service in Windows. So it's not trusted like a regular, expensive verisign certificate, but it still does the job of securing the data.

    Basically, you're sending all of your data (including your password) across the internet in plain text, no encryption. You might want to look into installing SSL. PM me if your admin needs help.

    Apart from that, all of my people are fine. I'll be adding a droid of my own to the server later this week.

    Best regards,
  3. virtus

    virtus Well-Known Member

    Some people have reported that using using "\username" works better than using "domain\username". It's also been reported that using your root domain name "exchangeserver.com" works as well as as "my.exchangeserver.com". So maybe try those settings.

    Also regarding SSL - prior to the 2.0.1 update SSL would occaisionally break the ability to download attachments. So early droid owners would often disable SSL. This bug has been fixed with the update, so it is safe to enable SSL again.
  4. Miront

    Miront Newbie
    Thread Starter

    That was what my Droid was at during the posting. I have tried many different settings combination none of which gave me any better results. I typically do use SSL. Doesn't make a difference either way in terms of my issue.
  5. Inphosys

    Inphosys Well-Known Member

    Virtus ... Thanks for the info on 2.0.1!

    Also, when people say domain\username ... what they really need is the NetBIOS version of their domain name. Some companies who have upgraded from earlier versions of Windows Server (pre-2000) have a NetBIOS domain name that is different than their actual domain name. For instance, my company uses company.local as it's official Active Directory Domain. But our network has been around for about 12 years and it started back with Windows NT 4.0. The Domain name back then was CompanyDC. So all of my users have to type CompanyDC\Username instead of company.local\Username. Ask your systems admin what your domain NetBIOS name is. He/She should be able to tell you. They might look at you funny for understanding all of this, but they'll appreciate the fact that you know what you're talking about.

    In regards to some users not needing the domain\ ... This has to do with your company's configuration of IIS (Internet Information Services) in Windows Server. Your admin can actually configure IIS to always assume a certain domain\ before each username that is input. We do this for our Outlook Web Access servers, but not for the gateway that controls mobile devices. (We don't do it for that server because iPhones tend to break if we do it). We also never let a device connect without SSL. It's a requirement for us.

    Sorry for all of the additional information. I realize this is slightly off topic and doesn't really help Miront with his question. Hopefully this info will help another Exchange ActiveSync user with their setup in the future.

    Miront ... I had a chance to have a beer with a couple of my Android users this evening and I brought up your problem. One user said they had a problem at first with information not coming down. He hard reset his droid back to factory default, set up the Exchange account again and now it's working fine. His problem was with calendar entries put in via Outlook not downloading to the phone.

    If you find a solution, please post back and let us know.

    Best regards,
  6. Miront

    Miront Newbie
    Thread Starter

    I called Motorola Tech Support. That was a mistake. Worst service I have ever got. They stated, "Well sir it is because your exchange administrator has applied a policy to your account to not allow you to do this"

    I explained to her how that could not possibly be the case as it is an intermittent problem. I could literally hear her throw her hands up in the air and say "FINE! Lets set your phone back to factory defaults."

    I didn't really want to do that at the time and her only other solution was to download a 3rd party app to use as an email client (wasn't free).

    I doubt I will be calling them again. I am going to reset to factory tonight and see if that helps. I'll let you know.

    EDIT: Well it appears to be working properly for the 1st time today. I am going to hold off on the factory data reset. If it acts up again I will do it for sure.
  7. Miront

    Miront Newbie
    Thread Starter

    Worked fine until 1:49 today and then stopped receiving. This time I got "Unable to connect to server". Just before that I noticed that 3g was no longer displayed despite being in a good 3g coverage area. I had to reboot phone for it to switch from 1x to 3g. I will be resetting to factory tonight.

    EDIT: Just did a factory data reset and the issue persists. The only thing I can think of that is left is I stil have a Blackberry on the BES. Blackberry is currently powered off. I have asked our BES admin to remove it from the BES to see if that clears up the issue. If it does not I am going to go to Verizon store and try to exchange my Droid.

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date

Share This Page