1. Check out our companion app, Forums for Android! Download from Google Play

Exchange ruins this phone (unlock code unbearable) ANY FIX?

Discussion in 'Android Devices' started by koldtoft, Jun 4, 2010.

  1. koldtoft

    koldtoft Active Member
    Thread Starter
    16

    Sep 4, 2009
    34
    2
    16
    I have a Motorola Milestone/Droid (well my boss does) and he MUST sync with exchange for his contacts and calendar ect. (plus to send and receive mails) but Jesus lord almighty, that "password" lock thing, is annoying as hell. On my HTC desire, the app "lockpicker" works perfectly, but not on Milestone.

    Does ANYONE know of a workaround for the password lock on milestone running exchange?

    The only fix I have found working, was an app that totally removed the lock screen (even the slide to unlock) but that is not a very good solution, as he will constantly be calling people from his pocket (even a push on the volume button, opens the phone)

    FYI: I am administrator of the exchange sever (SBS 2008 with Exchange 2007) so if there is any server settings that can fix it, that is also a feasible option.


    Any help would be much appreciated.

    Thanks.
     

    Advertisement

  2. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    download "lockpicker" from the market
     
  3. koldtoft

    koldtoft Active Member
    Thread Starter
    16

    Sep 4, 2009
    34
    2
    16
    Thanks for the reply, but try reading the post :)

     
  4. Redflea

    Redflea Well-Known Member
    163

    Oct 6, 2009
    2,623
    289
    163
    If you're the exchange admin, don't you control the requirement for a PIN? You can't turn it off?

    If you can't turn it off, can you set it to a single digit so it's at least very easy?
     
  5. takeshi

    takeshi Well-Known Member
    163

    Dec 6, 2009
    3,354
    282
    163
    I would think so. I'm on Exchange and have no PIN requirement.
     
  6. GorillaTheHutt

    GorillaTheHutt Well-Known Member
    43

    Nov 17, 2009
    227
    40
    43
    SF, CA
    you could also try myLock. it bypasses the lock screen but only with the power button, which IMO is hard to accidentally press.
     
  7. DDG

    DDG Well-Known Member
    16

    Nov 28, 2009
    90
    6
    16
    Insurance/Benefits
    So Cal
    FYI - The only way we got it to work was to sync with the remote server. We have 3 Moto Droids that have no issues doing this. We're happy with how this works.
     
  8. sbursik

    sbursik Well-Known Member
    58

    Feb 4, 2010
    167
    14
    58
    Get Touchdown to manage your Exchange email. It works great and gets around that.
     
  9. koldtoft

    koldtoft Active Member
    Thread Starter
    16

    Sep 4, 2009
    34
    2
    16
    As far as i can see the Exchange server policy have no bearing on the android lock screen code, it seems to be a rule set my Android. I can set the code on the phone for "space space space space" so it's fairly easy to enter, but it's still not a good solution.

    Are you using a milestone/droid? Are you using any applications to skip lockscreen?

    MyLock is not working on the Milestone. There are 3 other MyLock applications, and one of them works on Milestone, but does not remove the code screen. (got some other features)

    Can you elaborate on this? How do you sync it with a “remote” server? All servers are “remote” when you are syncing from a cellular device. Can you give me a hint to what settings you have set and how?

    Only problem with that is, I live in Denmark, and the marketplace is not open for paid applications. :(
     
  10. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    Wow, I don't know how I missed that!?! :(
     
  11. animalunga

    animalunga New Member
    5

    Jan 18, 2012
    3
    0
    5
    I also had your problem and found the cause and solution for those still interested:
    cause - is a policy of exchange for mobile devices which is the default, and since Android is the only one respect it (but do not know which version from, I have Jelly Bean 4.1.1), network administrators leave it so com 'is.

    remedy - ask your network administrator to make the following changes:
    On the Exchange Management Console / Organization Configuration / Client Access create a new policy "Android without password" and leave the previous as Default for safety
    On this new policy to disable the "General / Allow non-provisionable devices" and "Password / Require password" and press OK
    Then on Exchange Management Console / Recipient Configuration / Mailbox / Your account / mailbox features / Exchange ActiveSync, select the new policy in place of the default.

    In this way, you lose the security of access to the device but security of access to the account remains intact, whether personalized with the new policy. For example, if someone steals your phone can see the contents of your mailbox / address book / calendar etc. .. but if someone wants to access your account from a new device he still have corporate credentials (username and password).
     

Share This Page

Loading...