1. Check out our companion app, Forums for Android! Download from Google Play

General exFAT or ext3 Support

Discussion in 'Android Devices' started by WoodburyMan, May 4, 2012.

  1. WoodburyMan

    WoodburyMan Member
    Thread Starter

    Apr 24, 2012
    I have a 32gb Class 10 microSD card I am using with my tablet. I have a few movies that are already in h264/aac format that the tablet can play. However I ran into a issue. These files are 4.5gb in size. The default format for my microSD card is FAT32. FAT32 has a limitation where files cannot be larger than 4gb each.

    I sought out to see if our tablets support any alternative file systems.. and the results are not promising :(

    I used a USB adapter and PartedMagic / gParted to format the card. First I tried ext3, since its linux native and Android is in essence linux so I thought that would work. No luck. After formatting, putting it in the tablet, it states "Preparing SD card for use" then "You may not eject your SD card" messages right after each other and it will not mount.

    I then did the same, except with a Windows box, and formatted the microSD to exFat. (exFAT is a acceptable use as it supports large files as well and works in MacOSX and Windows which I both use on a daily basis). Pop it in the tablet. Same thing.

    Reformatted back to FAT32.. works but but no greater than 4gb support.

    Are we stuck using FAT32 or is there another way around this? I am rooted and if there's something I can try I can give it a shot. Or am I stuck having to recode my movies to a just slightly lower bitrate so they fit?


  2. mrspeedmaster

    mrspeedmaster Well-Known Member

    May 16, 2010
    I tried them all too : exfat, ntfs, hfs, exfat3,exfat2,exfat4,xfs
    You need root and a kernel that supports it or root and try yo fstab manually mount it.
    Kinda sucks.
  3. WoodburyMan

    WoodburyMan Member
    Thread Starter

    Apr 24, 2012
    Yea =/ I have root, tried something.
    I found a program Drive Mounter or something on the App section of Play, needs root and busybox to work. Works, however locks up 3/4 of the time and will not automount the card. Works with NTFS and EXT2/3/4. Rather just recode my videos or chop them into parts.
    Then there's another app ntfs mount of something that someone made specifically for the Galaxy Tab 7.0 Plus, but alas does not work on our devices. Not sure if hardware or the fact its 4.0 vs 3.2.
  4. nightyfly

    nightyfly New Member

    Oct 10, 2012
    the newest Note 10.1 last firmware update, it support exFAT file system.

    require root:
    I have tested ext2 for Note 10.1 with Link2SD app successful.
    format micro SD card with 2 primary partition , 1 Fat 32, 1 ext2 --use Minitool
    install Link2SD, it ask reboot to mount the 2nd partition.
    then the ext2 parttion is mounted in : /data/sdext2
    you can try copy file to it, and leave Link2SD installed .

    another solution --NTFS
    i have tested with TAB 10.1 with USB OTG cable.
    a micro SD card in card reader formarted with NTFS use Minitool.
    install NTFS mounter from google play store.
    also APP USB OTG helper(from xDA) worked too.

    limit 4G file out.

Share This Page