1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root Ext4 problems!!! - GParted - please help

Discussion in 'Android Devices' started by kartnite, Nov 26, 2011.

  1. kartnite

    kartnite Well-Known Member
    Thread Starter

    I have been trying to create an ext4 partition using GParted. I did all necessary steps - will quickly run thru, just so you know:

    1. Burnt ISO and accessed thru boot menu (running XP/SP3, btw)
    2. Selected memory card; Deleted existing allocation.
    3. Created new primary partition as FAT32
    4. Allocated "free space following" as 1024
    5. Specified the unallocated memory (1024) as ext4.

    There was no error in the operation.

    However... When I tried to load stuff to the SD card, Windows prompted me to format the card before using. It made no sense but I couldn't do anything. And by formatting it, I lost everything that GPL had done in the first place.

    I went over the process again, to no avail.

    Does anyone know where I've possibly gone wrong? Please help. :thinking:
     

    Advertisement

  2. 1st_Paladin

    1st_Paladin Well-Known Member

    SURoot has good guide. Did you ensure that your EXT is also Primary partition? Does your ROM support EXT4?
     
  3. SUroot

    SUroot Extreme Android User

    I always format the new partitions as a separate operation afterwards for good measure. Maybe that will help
     
  4. kartnite

    kartnite Well-Known Member
    Thread Starter

    Yes, I did ensure that... And I have a stock rooted rom. I am trying to flash a ROM that needs ext4.

    My SD card is a class 4, 4GB.

    G-Parted shows it perfectly. 2.69 (FAT32) plus 1.0 (940-ish MB, as ext-4)

    But while running from my computer, I don't see any size description. I am forced to format it and voila, back to 3.69 (FAT32).

    When I run G-Parted again, it prompts me to create the partition table (without which, it cannot proceed). So... It creates partition table (msdos, default) and I go through the process again, only for it end up as a vicious cycle! :/

    Will try your approach again.

    Thanks for the replies, fellas...

    Btw - @SUroot: as @Paladin just mentioned, do you have any guide that I can refer to please?
     
  5. Rastaman-FB

    Rastaman-FB Extreme Android User

    use h2testw to test that card. sounds like its borked
     
  6. 1st_Paladin

    1st_Paladin Well-Known Member

    Please see SURoots signature. There will be a link to his guide. Which ROM are you flashing? I've noticed that for some ROMs I had to use Clockworkmod recovery to partition the card. Maybe give that a try? I was able to create three partitions on my SD card using Clockworkmod (FAT32, EXT, Swap). Works very well. When I tried using Gparted it would not recognize the card.

    After you have done the partition, try mounting the SD-EXT from Clockworkmod recovery to check whether it works. If there are not error messages it means that it is ok.
     
  7. kartnite

    kartnite Well-Known Member
    Thread Starter

    Thanks, again, for your kind responses.

    Nope. Working purrrrfeckktly. Beginning to think I am hexed. :/

    I am trying to flash the Runnymede AIO. It needs at least 1024 as ext4. I have never done an ext partition before. All along, was on a stock rooted FroYo and Gingerbread.

    Can I make an ext4 using Clockworkmod recovery? Remember reading somewhere that it isn't possible. My recovery is Revolutionary's, if I am not mistaken. I had used revolutionary.io after installing 2.3.3 on my device.
     
  8. SUroot

    SUroot Extreme Android User

    did you do teh reformat of the partitions as a separate operation in gparted like I said?
     
  9. kartnite

    kartnite Well-Known Member
    Thread Starter

    Yes, dude...

    I did them one at a time - deleted allocation, apply, create primary fat32, apply, create ext4, apply...

    And again... When I load the card in to my system, it asks me to format it.

    Must be doing something wrong somewhere.
     
  10. kartnite

    kartnite Well-Known Member
    Thread Starter

    Problem solved, guys. :) Got so frustrated... I just did a system wipe. Wiped the card again. Started from scratch. Voila...

    Thanks for the prompt responses!

    Flashed the Runnymede ROM, too. Now my question is - how do I know if A2SD+ is actually functioning?

    The storage settings say that 130-ish MB free. I downloaded Quick System Info Pro which says 547MB (out of 900-ish, as shown in G-Parted when I made the ext4 partition) A2SD storage free.

    Am I missing something here?
     
  11. Rastaman-FB

    Rastaman-FB Extreme Android User

    thats correct. you wont see the internal storage increase it will just take a long time to decrease
     
  12. kartnite

    kartnite Well-Known Member
    Thread Starter

    And to think I waited for more than a year to dare myself in to a venture like this (flashing roms, etc). :)
     
  13. Rastaman-FB

    Rastaman-FB Extreme Android User

    aye its not as hard as it seems once you get your head around it
     
  14. kartnite

    kartnite Well-Known Member
    Thread Starter

    Ermmm, may be I still am not getting this A2SD+ philosophy...

    I got a prompt from my phone tht memory is reducing? So... Don't really understand if the A2SD+ is 'actually' operating. :/

    Of course, I did removed some apps, cache, etc. and solved the memory prob for the time being.

    But... Whenever I install an app, I see only the phone storage reducing. How do I make use of the A2SD+? Quick System Info still shows that around 500-odd MB of A2SD+ is still available, yet all installs occur in the phone memory (talking about apps tht cannot be moved to SD card).

    Any ideas?
     
  15. SUroot

    SUroot Extreme Android User

    What Rom are you using? Is the ext partition reducing at all?
     
  16. kartnite

    kartnite Well-Known Member
    Thread Starter

    I am using the Runnymede ROM.

    Sorry for the delayed response... Yeah - did some Googling and checking other forum posts.

    The ext partition is reducing, but not by much.

    I think I should be a bit more patient. I'm getting too excited because I've been experimenting like this for the first time. :/
     
  17. SUroot

    SUroot Extreme Android User

    do you have root explorer? it may bd dalvik is not moved to sd with the a2sd+ script you have. With root explorer you could browse the ext or /data and find out for sure.
     
Loading...
Tags:

Share This Page

Loading...