1. Download our Official Android App: Forums for Android!

Support External SD card always mounted as read only

Discussion in 'Android Help' started by zygd, Sep 19, 2016.

  1. zygd

    zygd Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    24
    Joined:
    Oct 19, 2012

    Oct 19, 2012
    24
    1
    16
    4K android media box with AML812 chip. 2 USB ports, 1 USB OTG port and one SD card slot. Android 4.4.2 (KitKat?)
    USB drive connected with FAT system is mounted as read/write device, all SD card I have tested were mounted as read only.
    At first I wanted to make firefox to download files to SD card. But firefox had no rights to write to SD.
    At second I thought that firefox can't write to SD because new privilages system in KitKat. So I found a solution on the web and have added media_rw entries in permission.xml file in WRITE_EXTERNAL_SD section. But it didn't help.
    Then I have found out, that SD card is always mounted as read only by default (by terminal and mount command) - i tried 3 different SD cards, no success.
    I have checked SD card with fsck_msdos and externally on my desktop PC - SD card had no errors.
    I tried to remount SD as read/write with mount -o remount,rw device from terminal and it worked but apparently only apps with root privilages can write to SD. Firefox still can't write to SD.
    And if I close terminal the SD returns to read only state.
    Don't know what to do, where to find the solution.
    In vold.fstab there is only one command with dev_mount, and this command doesn't have read/write or read only flags (checked dev_mount in the web).
    There is no fstab.device files on the box, which are common? in KitKat (above android 4.3) so I am not so sure that this is KitKat device.
    Please help to unlock SD card write rights.
     

    Advertisement

Share This Page

Loading...