1. Download our Official Android App: Forums for Android!

Support Face unlock lag?

Discussion in 'Android Devices' started by nypcdoc, Dec 19, 2011.

  1. nypcdoc

    nypcdoc Member
    Thread Starter
    Rank:
    None
    Points:
    23
    Posts:
    61
    Joined:
    Oct 14, 2011

    Oct 14, 2011
    61
    29
    23
    NY
    Has anyone noticed a slight lag before the camera feature loads when first unlocking the phone? I could have swore it used to be quicker than the 2-3 second lag I experience.

    ***************************************************
    If you are experiencing this issue, please visit the link below and STAR the complaint (thanks JC13):

     

    Attached Files:


    Advertisement

    KingDillinger likes this.
  2. Dubbin1

    Dubbin1 Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,525
    Joined:
    Aug 5, 2010

    Aug 5, 2010
    1,525
    969
    233
    N/W Ohio
    No lag at all on mine, as a matter of fact I expected some kind of delay but it pops up right away.
     
  3. andyandroid81891

    andyandroid81891 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    120
    Joined:
    May 5, 2010

    May 5, 2010
    120
    8
    36
    I have the same lag. I turned off face unlock because I want to be able to swipe into the camera anyway tho.
     
  4. JC13

    JC13 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    101
    Joined:
    Nov 11, 2011

    Nov 11, 2011
    101
    40
    43
    i was experiencing the same thing. Camera used to pop up instantly in the beginning, but it takes maybe 2 seconds for it to register now. I assume that it would be fixed with a software upgrade.
     
  5. nypcdoc

    nypcdoc Member
    Thread Starter
    Rank:
    None
    Points:
    23
    Posts:
    61
    Joined:
    Oct 14, 2011

    Oct 14, 2011
    61
    29
    23
    NY
    Thanks for the replies. Now I need to figure out what I did/installed that's causing this delay..
     
  6. CAMAN

    CAMAN Member
    Rank:
    None
    Points:
    23
    Posts:
    60
    Joined:
    Dec 19, 2011

    Dec 19, 2011
    60
    27
    23
    Minnesota
    Mine is doing the same thing. The first day it was so fast I didn't even realize it had done it a couple times. Now it takes up to 5 seconds to get the camera to come on, then another few seconds to get it to recognize me. I've since turned it off for now.
     
  7. nypcdoc

    nypcdoc Member
    Thread Starter
    Rank:
    None
    Points:
    23
    Posts:
    61
    Joined:
    Oct 14, 2011

    Oct 14, 2011
    61
    29
    23
    NY
    Question to you guys experiencing this delay: are you rooted, have an unlocked bootloader or anything else unique about your device? I'm just trying to figure out if there is any sort of common factor.
     
  8. ez12a

    ez12a Member
    Rank:
    None
    Points:
    23
    Posts:
    74
    Joined:
    Dec 14, 2011

    Dec 14, 2011
    74
    31
    23
    Mine started to lag a little after a while. My phone is not rooted.

    It might have to do with the amount of training you give it. You can improve the recognition by training it in different situations. I've since switched back to swipe lock.
     
  9. nypcdoc

    nypcdoc Member
    Thread Starter
    Rank:
    None
    Points:
    23
    Posts:
    61
    Joined:
    Oct 14, 2011

    Oct 14, 2011
    61
    29
    23
    NY
    Thanks for the reply. I don't think it has to do with recognition though, since the lag I'm experiencing has to do with the camera "getting started". Once the camera sees my face, the sped is just fine. :)
     
  10. CAMAN

    CAMAN Member
    Rank:
    None
    Points:
    23
    Posts:
    60
    Joined:
    Dec 19, 2011

    Dec 19, 2011
    60
    27
    23
    Minnesota
    Fully stock
     
  11. nypcdoc

    nypcdoc Member
    Thread Starter
    Rank:
    None
    Points:
    23
    Posts:
    61
    Joined:
    Oct 14, 2011

    Oct 14, 2011
    61
    29
    23
    NY
    OK, well I'm rooted with an unlocked BL. Guess that has nothing to do with it. Very strange, I don't even have that many apps installed yet - just Wordfeud, Netflix and some root related apps.
     
  12. JC13

    JC13 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    101
    Joined:
    Nov 11, 2011

    Nov 11, 2011
    101
    40
    43
    stock here. You know what - I added a bunch of "training" pictures in different light, with glasses, etc. Anyone think the delay in starting up the camera could be tied to it pulling all the photos needed to compare for face unlock? I wonder if there is a way to delete face unlock pics, try again with 1 and see if it speeds it up again.
     
  13. nypcdoc

    nypcdoc Member
    Thread Starter
    Rank:
    None
    Points:
    23
    Posts:
    61
    Joined:
    Oct 14, 2011

    Oct 14, 2011
    61
    29
    23
    NY
    That is a good idea, but when I first started experiencing the lag, I only had one pic, so I added more just to compare. No difference. I then went into apps, found face unlock, force stopped it, cleared data, rebooted then set it up form scratch - same issues. I also reset camera settings to default- again, same lag!
     
  14. CAMAN

    CAMAN Member
    Rank:
    None
    Points:
    23
    Posts:
    60
    Joined:
    Dec 19, 2011

    Dec 19, 2011
    60
    27
    23
    Minnesota
    I just turned face rec. back on and went through the whole setup procedure again. It started out working great and experienced no lag. I then turned the phone off then on and got a considerable amount of lag from then on. I only have one picture assigned this time and it didn't lag at all after teh camera got booted up.
     
  15. nypcdoc

    nypcdoc Member
    Thread Starter
    Rank:
    None
    Points:
    23
    Posts:
    61
    Joined:
    Oct 14, 2011

    Oct 14, 2011
    61
    29
    23
    NY
    Oh well, thanks for trying.
     
  16. JC13

    JC13 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    101
    Joined:
    Nov 11, 2011

    Nov 11, 2011
    101
    40
    43
    guess that thought was proven wrong, haha. I sure hope someone finds a fix to this. I love the feature, but feel like I will eventually get annoyed with the delay.
     
  17. ssick92

    ssick92 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    289
    Joined:
    Jan 19, 2010

    Jan 19, 2010
    289
    41
    43
    To get my degree
    Cal Poly San Luis Obispo
    I'm rooted, on Android Revolution 2.1.1 and I too have a tiny bit of camera lag when face unlocking. I didn't think it was a big deal, and I still don't really...
     
  18. JC13

    JC13 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    101
    Joined:
    Nov 11, 2011

    Nov 11, 2011
    101
    40
    43
    KingDillinger and nypcdoc like this.
  19. ssick92

    ssick92 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    289
    Joined:
    Jan 19, 2010

    Jan 19, 2010
    289
    41
    43
    To get my degree
    Cal Poly San Luis Obispo
    JC13 likes this.
  20. JC13

    JC13 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    101
    Joined:
    Nov 11, 2011

    Nov 11, 2011
    101
    40
    43
    Thanks nypcdoc for adding extra info and the screenshot.
     
    nypcdoc likes this.
  21. nypcdoc

    nypcdoc Member
    Thread Starter
    Rank:
    None
    Points:
    23
    Posts:
    61
    Joined:
    Oct 14, 2011

    Oct 14, 2011
    61
    29
    23
    NY
    JC13 likes this.
  22. krouget

    krouget Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    456
    Joined:
    Jan 13, 2010

    Jan 13, 2010
    456
    121
    68
    I'm not sure how we're perceiving lag, here. My face unlock camera takes about 1-1.5 seconds to start, pretty consistently. I've always considered this normal, and I've been running stock 4.0.2 since the day of release.

    Are others saying this 1.5 sec. max wait time is a "delay", based on a faster response? Or is mine the "quick response"?
     
  23. JC13

    JC13 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    101
    Joined:
    Nov 11, 2011

    Nov 11, 2011
    101
    40
    43
    We are saying it has taken longer to start up from when we first received the phone. It can take multiple seconds for the camera to activate. If it took 1 second, I don't think any of us would have a problem.
     
  24. nypcdoc

    nypcdoc Member
    Thread Starter
    Rank:
    None
    Points:
    23
    Posts:
    61
    Joined:
    Oct 14, 2011

    Oct 14, 2011
    61
    29
    23
    NY
    Anyone from the night crew experience this issue?
     
  25. nypcdoc

    nypcdoc Member
    Thread Starter
    Rank:
    None
    Points:
    23
    Posts:
    61
    Joined:
    Oct 14, 2011

    Oct 14, 2011
    61
    29
    23
    NY
    Anyone have any luck with troubleshooting this lag?
     
Tags:

Share This Page

Loading...