1. Are you ready for the Galaxy S20? Here is everything we know so far!

Facebook notifications not silenced

Discussion in 'Wear Os' started by KathyJM, Sep 22, 2020.

  1. KathyJM

    KathyJM Member
    Thread Starter

    I have the setting 'silence phone when wearing watch' switched on for apps. However Facebook notifications still sound. All other apps seem to obey the setting. Can anyone suggest a remedy?

    Phone is Samsung J5 running Android version 9
    Watch is Fossil Gen4.
     


  2. Best Answer:
    Post #2 by lunatic59, Sep 22, 2020 (3 points)
  3. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Burn Facebook with fire! ;)

    Seriously, the Facebook app is notoriously intrusive and doesn't play by the rules most of the time (no surprises there). You must control notifications within the app itself as often times it will override phone settings.
     
    puppykickr and bcrichster like this.
  4. KathyJM

    KathyJM Member
    Thread Starter

    I took it as read that I need to change a setting in Facebook. But which ones/s?
     
  5. KathyJM

    KathyJM Member
    Thread Starter

    I took it as read that I need to change a setting in Facebook. But which ones/s?
     
  6. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    I guess the question then becomes how do you want Facebook to behave?
     
  7. KathyJM

    KathyJM Member
    Thread Starter

    Sorry if I'm being unclear. I want Facebook to not sound on my phone when my smartwatch is connected.
     
  8. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    It may not be possible, however, I would suggest you first look at the WearOS app and check settings for individual apps allowed to send notifications to your watch. I might think that if Facebook is turned off then the mute while wearing watch setting wouldn't effect it. If Facebook is enabled, then go into facebook settings and locate the notifications section .... it's buried deep at the end of a long list which makes me think they don't want you to find it. :eek: In any case, under the push notifications, you might have to turn things on and off until you find a combination that works exactly as you want.

    If that can't manage it, and it means that much to you to have it behave in exactly this way, then you may need the help of an app like tasker to set up some custom rules.
     
    puppykickr likes this.
  9. bcrichster

    bcrichster ROMinator
    Moderator

    Indeed, Fbook is VERY intrusive.. in fact, my GF actually shut down her account due to these constant notifs. I've truly never been able to silence any of them. Ever. They somehow have admin control over the whole phone system no matter which options you select
     
    lunatic59 likes this.
  10. puppykickr

    puppykickr Android Expert

    Just turn off all Facebook notifications for the Facebook app.
    Do you really need those notifications when you are not in the app?
    I mean, really.
    All of your notifications are stored right under the bell icon anyway.
    Just get to them when you open the app.

    Your device may differ, but the general gist is...

    Settings
    Apps
    All apps
    Facebook
    Notifications
    (turn them off, or select the lowest priority, usually 0)

    And yes, do the same thing for Messenger.

    To eliminate the problem if this doesn't work (it should), uninstall/disable the Facebook app and just use your browser to access Facebook instead.

    This can also save a large amount of space on your device.
     
    #9 puppykickr, Sep 23, 2020
    Last edited: Sep 24, 2020
    bcrichster and lunatic59 like this.
  11. sullencab

    sullencab Member

    Have you tried going to phone settings - apps, I think you have to turn off notification there.
     
Loading...

Share This Page

Loading...