1. Are you ready for the Galaxy S20? Here is everything we know so far!

Facebook sync problems with 2.0.1

Discussion in 'Android Devices' started by scheng12, Dec 9, 2009.

  1. scheng12

    scheng12 Well-Known Member
    Thread Starter

    Before the update my contacts list would show all my Facebook friends with phone numbers, even if they weren't in my contacts list before. This saved a lot of time when switching phones because I didn't have to transfer all my contacts. However, with the new update it seems to only list the contacts that I manually inputted numbers for. Is this supposed to be happening?

    1. Download the Forums for Android™ app!


  2. jduke882

    jduke882 Lurker

    This has to do with when you first sign in to Facebook. There's an option to sync "Everyone" or "Friends in my Contacts" or something along those lines. If you want to change it, Open up the Facebook app to the main page (it has the icons for News feed, Friends, Photos, etc.) and press the Menu Button, then go to Settings. Scroll down to "Sync Contacts" and change the setting. Hope this helps :)
  3. scheng12

    scheng12 Well-Known Member
    Thread Starter

    I don't think this fixes the problem. thank you though. All my facebook contacts are synced, but I only display those contacts that have phone numbers. Before the update, it would have the contacts that had numbers on facebook under this label. Now it only has contacts that I manually input numbers for. When I uncheck that filter, it has all of my facebook friends as contacts
  4. vincentp

    vincentp Android Expert

    I know this is going to sound stupid, but did you re-log into the Facebook app after you updated?
  5. scheng12

    scheng12 Well-Known Member
    Thread Starter

    lol yes I did. It was working correctly for like an hour after I updated but then it stopped
  6. baddriver

    baddriver Well-Known Member

    sheng, I'm having the exact same issue. facebook contacts folder and contact syncing was working normally for about an hour or two this morning after the 2.0.1 update, then after lunch nothing. I've restarted twice, logged in to facebook on the phone countless times, deleted the facebook widgets and folders, even gone into accounts & sync, facebook sync, and toggled the checkbox which makes the little sync arrow circle spin. Still nothing.

    I'm hoping it just fixes itself because I don't know what else to do. I really don't want to factory reset again, as it wipes out my call list and sms messages, and all app settings.
  7. scheng12

    scheng12 Well-Known Member
    Thread Starter

    Yea I really hope they fix this soon. I'm glad I'm not the only one with this problem.
  8. DroidDid

    DroidDid Newbie

    I have the same problem.
  9. user53

    user53 Newbie

    Open your contacts on your phone and press the menu button. I think there is an option that for accounts and to only show contacts with numbers. Is that whdt you are looking for?
  10. user53

    user53 Newbie

    Correction, open contacts, then hit menu, then display options, and then there is an option for only those with phones
  11. DroidDid

    DroidDid Newbie

    Yes, and when you check that box, it only shows people that you entered in manually.
  12. baddriver

    baddriver Well-Known Member

    To follow up, I've been checking and unchecking every box today. I've uninstalled and reinstalled programs. I've even re-installed the 2.0.1 update (nothing changed). Nothing seems to be able to force it to sync. Home++ crashed and force closed a few hours ago and when it restarted my facebook contacts were back. Then about an hour later they were gone again. And now a few hours later they are back... and I just checked now and they're gone again. This is fracking annoying. Especially since there are a few people who are ONLY facebook contacts. Not to mention the contact photos and even name changes that it does which I would just like to work like they're supposed to.

    someone mentioned that it might be another app that's not updated for 2.0.1 causing problems. not sure where to start on that one, but I do have about 40 apps. Don't really want to factory reset or uninstall a bunch of stuff to figure this out :(
  13. iclickjohn

    iclickjohn Member

    I've been posting all over the various forums about this. and it seems like only a handful of people are having the problem. (well, maybe not many were syncing in the first place) This problem doesn't seem to generate to many "me too"s. But I have the same problem as you've stated and also pretty savy with moving around tech. I've tried all ways front and back and I never even had them sync'd at all. I'm going to post a question if anyone has recieved the officail update after manual 2.0.1 and re-loaded 2.0.1 officiall (over manual 2.0.1) Lastly, I wonder if Verizon or Motorola tech could help in a situation like this. lol we probably know more than they do.
  14. iclickjohn

    iclickjohn Member

    And now I have them (hopefully more than an hour). Without doing anything. Whut the?
  15. meijerbrantm

    meijerbrantm Newbie

    yeah, i'm having the only display contacts with phone numbers not work properly either after updating... huh..
  16. ryano

    ryano Lurker

    It took a little while but I got it. In order to get work I had to go into the accounts tab in contacts app, delete my facebook account, re-enter it. Then go to display options press facebook account and click all contacts. Works right again. Hope it helps.
  17. Wordsmith9091

    Wordsmith9091 Lurker

    Is it possible that the problem isn't actually the new Facebook app itself, but related to the changes FaceBook has been making in how privacy settings work this week?

    Could this just be bad coincidental timing?
  18. caliwagon

    caliwagon Lurker

    Same problem here! I only show the contacts I've manually entered, but I'll try the suggestion in post 16.

    EDIT: tried the suggestions in 16 and it didn't change anything.
  19. Reddog DL

    Reddog DL Lurker

    Bump! Happening to me as well.
  20. caliwagon

    caliwagon Lurker

    OK, here's what brought my missing contacts back: Go to contacts > settings > import/export > import from SD card. This restored my contacts, and was followed by a fresh facebook and google sync. All's well now.
  21. jennyfur

    jennyfur Newbie

    I'm having the same problem. Was syncing just fine before the update. I had to redo the sync setup in the facebook app, then had to go to data & syncronization in device settings and uncheck sync contacts, then recheck it. That forced it to sync. It took awhile, but finally kicked back in.
  22. bsems1000

    bsems1000 Android Enthusiast

    I had the same problem.. "facebook has error syncing with device, should be fixed soon".. or something close to that.. i had the upgrade this morning.. i just noticed fb was not syncing. BUT i had yet to open facebook since the os update.. i did not open the app, i clicked on one of my contacts and opened there fb page from there. it then took me to the end user agreement from facebook, then had me login. (as if i am initially setting up fb on the phone i guess). after that it connected me to the profile of whom i selected.

    from there i went to my home page - settings - sync- and the facebook app still said error syncing. So i unchecked the box for facebook sync.. waited a few seconds - checked it again. and BOOOOM no more error...

    hope this helps anyone else w/ similar issues as mine.
  23. bsems1000

    bsems1000 Android Enthusiast

    *not home page, but home menu screen* from paragraph 2
  24. Reddog DL

    Reddog DL Lurker

    Ahhh this is pissin me off! I tried everything that has been said, but I'm still having big issues with my contacts being there one minute, then the next minute gone.

    Droid doesn't I guess!
  25. radikal

    radikal Android Expert

    oh droid doesnt, update doesnt haha!

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date

Share This Page