1. Are you ready for the Galaxy S20? Here is everything we know so far!

Factory Reset Havoc!

Discussion in 'Android Devices' started by tweak4, Oct 13, 2014.

  1. tweak4

    tweak4 Well-Known Member
    Thread Starter

    My phone has been acting kind of strange lately- some apps running slowly, the camera taking 2-3 minutes to come up after I do the "camera shake" from my home screen, wifi tethering wouldn't turn on, etc. So I decided to go ahead and do a factory reset to clean things up.
    The weird thing is that the reset fixed the issues I was having, but it somehow broke a variety of things that were working before! I can't get the Motorola Connect Chrome extension to connect to my phone from either of the two computers I use regularly, the phone has stopped automatically connecting to the BT adapter in my car (I have to force it to connect manually now), and a number of other little things like that.
    I'm doing another reset to see if any of these issues clear up, but has anyone else had any experience where a reset broke something that wasn't broken before?
    :mad:
     



    1. Download the Forums for Android™ app!


      Download

       
  2. What did you do after the Factory Data Reset? Did you install anything? Are you root-ed?

    I assume you are running 4.4.4 so the Wipe Cache Partition is done when you do the Factory Data Reset. If you are on 4.4 do a Wipe Cache Partition.

    Running an un-root-ed phone in Safe Mode would verify that problems are not being caused by an app that you added.

    ... Thom
     
  3. doogald

    doogald Extreme Android User

    To be honest, no. It was always the reverse: I started noticing problems maintaining BT connections to my cars after the first KitKat update, and a reset fixed it. I noticed apps starting to force close a lot, wiping cache and uninstalling/reinstalling didn't help, a reset fixed it.

    I've done four resets so far, and it's always worked better post-reset.

    I'd think about doing it one more time to see if the problems go away. If they recur, I'd consider doing a factory reset *without* restoring data from old backups, reinstall the apps that you need manually (you can do so from a PC web browser), and see if that works out better.

    As for the Motorola Connect service - I've never used it myself.

    Good luck, and hopefully you'll have everything back up and running normally after the next reset.
     
  4. tweak4

    tweak4 Well-Known Member
    Thread Starter

    I had a little extra time this morning at work, so I decided to reset again- so far so good! Connect fired right up, and I just went out to my car to pair and while I was there I turned the car off and back on, and the phone reconnected just like it used to. I guess something weird must have happened in the first reset, but whatever it was seems to be cleared up now (or at least for now).

    And for the record, I am not rooted and running 4.4.4
     
    Thom and doogald like this.
  5. Did you install ANY apps after you did either reset before trying it?

    ... Thom
     
  6. tweak4

    tweak4 Well-Known Member
    Thread Starter

    Yes. Both times, I allowed Google to automatically start installing the apps that were tied to my account. In fact, the only real difference between what I did the first time and the second was that the first time I entered credentials for both of my google accounts (my personal and our shared family account) at the same time, and the second time I entered just my personal account, let it restore completely and then added the family account afterward. The first time, it seems only apps from the first account I entered were actually restored, so I wonder if there was something else in that restoration process that may have gone wrong due to having to accounts entered before the original restore was complete...
     
  7. I suggest that you go slow.

    There are a lot of different entities and one of them is apparently causing the problems.

    On all recent versions of Android you can invoke Safe Me that disables all apps that you added without uninstalling them. This can help to zero in on an app(s) that is causing a problem.

    I don't see how multiple Factory Data Resets achieves anything. A Factory Data Reset followed by not installing anything more and testing to see if there a problems makes sense to me. Then install other apps from Play Store a few at a time.

    Are you reinstalling from Play Store or from some backup? The advantage of doing it from Play Store is that some apps might not be compatible with a newer version of the system and they would be weeded out in the process. Just restoring them can bring incompatible apps into the new environment.

    ... Thom
     
  8. tweak4

    tweak4 Well-Known Member
    Thread Starter

    Normally I would agree, except that it appears to have solved the problem. Granted, it was a slash & burn approach, but it did indeed solve the problem. Likewise, when I had my Galaxy Nexus and was running custom roms, it wasn't all too uncommon for a new version to act funny after initially installing it, but after wiping and installing it again, everything would work great. (And for the record, I'm a software engineer, I don't work in Android, but the basic principles are the same regardless of the language. I know there is little reason why resetting again should make a difference, but for some reason in my experience, it frequently does in Android).

    Since I'm not rooted (this is the first Android phone I've owned that I haven't rooted), I'm restoring apps from the Play store and then importing settings for each app that allows it from backups I made previously.

    Aside from the difference in when I added each account to the phone, I followed the same procedure both times. The first time left me with lots of little things that didn't work. The second time, everything I've checked so far works just fine...
     

Motorola Droid Maxx Forum

The Motorola Droid Maxx release date was August 2013. Features and Specs include a 5.0" inch screen, 10MP camera, 2GB RAM, Snapdragon S4 Pro processor, and 3500mAh battery.

August 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...