1. Check out our companion app, Forums for Android! Download from Google Play

Failure [INSTALL_PARSE_FAILED_INCONSISTENT_CERTIFICATES]

Discussion in 'Application Development' started by pramod.deore, Jan 13, 2010.

  1. pramod.deore

    pramod.deore Member
    Thread Starter
    35

    Jan 10, 2010
    22
    0
    35
    J2ME developer
    mumbai(India)
    Hello everybody,
    I had tried to run my application on mobile but it gives me error as "Failure [INSTALL_FAILED_ALREADY_EXISTS]".
    but actually i had not installed the application before.
    I also tried to uninstall by command


    "adb uninstall InfoTest.apk" then it givesme error as "Failure".

    I also tried to installl application using
    "adb install -r InfoTest.apk" but it gives error as "Failure [INSTALL_PARSE_FAILED_INCONSISTENT_CERTIFICATES]"

    Thanks
     

    Advertisement

  2. kamasheto

    kamasheto New Member
    5

    Dec 14, 2011
    1
    0
    5
    I know this is quite old but I'm posting a solution in case someone comes across this in the future:

    This is because the version you're building and the version already on the machine are not signed with the same certificate. A possible workaround (not aware of other ways) is to uninstall then re-install.

    To uninstall, you need to use your application's package name not the apk name. For example:

    $ adb uninstall com.example.mypackage

    Then you can proceed with:

    $ ant debug install # or build and install separately, whichever you prefer
     

Share This Page

Loading...