1. Are you ready for the Galaxy S20? Here is everything we know so far!

Finally Custom Recovery for 2.2.1 stock phones !!!!!!

Discussion in 'Android Devices' started by joneidy, Mar 18, 2011.

  1. joneidy

    joneidy Android Enthusiast
    Thread Starter

    Wow almost unbelievable right? But trust me here is the custom recovery for phones that came with 2.2.1 when they were bought.

    This is a adapted or modified version of getitnowmarketing custom recovery for the Optimus M. Fixed by me to make it work on 2.2.1 phones.


    To flash the recovery follow these steps:

    Download the recovery image and flash_image here extract it and copy it to your sdcard

    Connect your phone to the computer and enable usb debugging (settings > aplications > development and click on usb debugging) *Make sure that USB STORAGE is disabled*

    Open up cmd and get adb shell to work
    After the adb shell command type: su to get root priviledges (the # symbol)

    After the # symbol type:

    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system

    # cat /sdcard/flash_image > /system/bin/flash_image

    # chmod 755 /system/bin/flash_image

    # mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak

    # mount -o remount,ro -t yaffs2 /dev/block/mtdblock5 /system

    # flash_image recovery /sdcard/recovery-2.2.1-joneidy.img

    Do not type the # symbol it`s just for reference

    If there is an error after mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak just ignore it. It will not make a difference or give a problem.

    If you get an out of memory error; reboot your phone and try it again.

    After all those commands recovery is installed.

    To access recovery shut your phone off,
    When it`s completely off press these buttons to go to recovery: Vol down+ Home +Power until recovery appears.
    Or on adb type: adb reboot recovery
    Also you can download anreboot from market to get to recovery

    To move on recovery use the vol-up and down to navigate in the menu
    Menu button is used to select something or as an OK button
    The back button is used to go back.

    Every time you enter recovery you will see a boot error ignore it, it`s just normal.

    *Do not flash any roms from 2.2; they will not work on your phone. New custom rom by teamchickeneater for 2.2.1 stock phones here*

    Very special thanks to asadullah for all his time and effort he putted into this.
    Also for all his knowledge.

  2. hav0kk

    hav0kk Member

    Will be trying in the near future!!! thanks again Joneidy and asadullah
  3. hav0kk

    hav0kk Member

    SWEET!! Worked on first try.

    The only error I got was already mentioned and looks like this for others who are worried they are doing something wrong.

    once you enter:
    # mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak

    you might get:
    failed on '/system/etc/install-recovery.sh' - No such file or directory (don't worry and keep moving your almost there!!!)

    now that I'm finally capable or accessing the customer recovery. I assume this link will finally apply:

    ROM Zero is for 2.2 and currently there is no custom rom for 2.2.1 ver, correct?
  4. DoodleDroid

    DoodleDroid Lurker

    Great post! Unfortunately this is'nt working for me. I've succesfully rooted my 2.2.1 using your guide, now when im in android sdk entering cat /sdcard/flash_image > /systeI/bin/flash_image
    I get an error message saying cannot locate file or something to that effect. I am absolutely positive that I've extracted the flash image and recovery image to my sd card. Please Help!!
  5. hav0kk

    hav0kk Member

    Here's a funny question. My Android system recovery menu has at the bottom

    Build : RA-thuderc-metro-v1.2.0-GNM
    E:Bad boot message
    My question is.... should I see that build name below? I still had that from the original customer recovery I listed above from previously trying.
  6. hav0kk

    hav0kk Member

    Check your typing.. I know I flipped a couple characters and currently see system mispelled. you'll get that if you didn't type the path correctly. And double check spacing
  7. DoodleDroid

    DoodleDroid Lurker

    @Hav0kk Thanks but I finally figured it out after about an hour of trial and error. It looks like the flash and recovery images should NOT be extracted to get sd root, instead the .ZIP should be copied to sd root. This is the only way vista recognized the flash image.
  8. alexxseven

    alexxseven Well-Known Member

    well you seemed to get it kernel ported. but my issue when in it is i try to do a NAND backup and it errors out :O

    figured out i needed to use adb shell >.> lol
  9. hav0kk

    hav0kk Member

    Wierd, I am pretty sure I extracted both files to my sd card main directory and it worked...
  10. hav0kk

    hav0kk Member

    When I run custom recovery I attempt to create

    - Nand backup + ext backup + .android_secure

    it starts to perform backup and errors out to:

    Run 'nandroid-mobile.sh' via adb!

    any ideas on why I get this error?
  11. joneidy

    joneidy Android Enthusiast
    Thread Starter

    The problem is probably because you dont`t have enough space on your sdcard. I get the same error too when doing it. I think it`s the space on the sdcard. All others options to backup work. I say that because I already tried all of them and the only error was with - Nand backup + ext backup + .android_secure
  12. dorianx

    dorianx Lurker

    I rooted my optimus M 2.2 with z4root

    then did a stupid thing to Install ROM manager

    long story short. after days of reading i managed to unbrick my phone

    thanks to Andyo posts

    I am still on android 2.2 its now rooted.

    but i cannot use the radio signal from metro pcs

    when i go to settings>status> my phone number is 000-000-0000
    my MIN is 0000000000 my MEID HEX is A00000000000

    I also installed 2.2.1 doing custom recovery but no matter what i do:
    factory reset
    downgrade to 2.2
    upgrade to 2.2.1

    I still cannot get data working.

    I also followed the "Root 2.2.1 and get Data WORKING!!" but no luck for me.

    I try to follow LG automatic update I go to recovery it detects my phone it passes the s/w check up but when it reaches "phone number" it cannot see my phone number and it gives me an error saying there is no update for my phone no matter if I have 2.2 or 2.2.1

    please help.
  13. asadullah

    asadullah Android Enthusiast

    @dorianx I had a similar thing happen to me the other day when I flashed rom zero to my phone (an optimus v) I lost my min and msid. Fortunately I keep photo backups of qpst settings so after about an hour with a hindu guy on the phone I finally got it fixed. Somehow your mdn, min and meid hex got lost. There's no way to get them back unless you talk metro into giving you them or have them written down. Then you use cdma workshop and qpst to fix your settings.

    P.S. I take no responsibility for what you do.
  14. joneidy

    joneidy Android Enthusiast
    Thread Starter

    To all who have download the recovery already,
    I recommend to download and flash the new one.

    It has a new fix. Is like in the image shown above.
  15. asadullah

    asadullah Android Enthusiast

    P.S that background is kinda ugly too ;)
  16. joneidy

    joneidy Android Enthusiast
    Thread Starter

    I might change it to a new one. LOL
  17. dorianx

    dorianx Lurker

    Thank you very much. for your promp answer. And in No way will i blame or make any sort of bad remark towards you guys. on the contrary i am grateful

    you guys are truly helpful.

    I followed all guides to root 2.2.1 and they work
    I also used the downgrader guide and they all work for me.

    no matter what i do my phone number is 000-000-0000
    my MIN is 0000000000 my MEID HEX is A00000000000

    WHat i will do is go to metro pcs store and deal with them directly

    in hopes that i might help somebody let me tell you what happened

    I had 2.2 firm ware. rooted using z4root

    then tried to create a back up with ROM manager then my phone turned off and got a screen when
    I plugged the phone into the computer
    Fastboot mode started

    from there i went to hell and back to unbrick my phone.
  18. DoodleDroid

    DoodleDroid Lurker

    Awesome job with the recovery gents! Do we have a custom Rom compatible with 2.2.1 yet?
  19. hav0kk

    hav0kk Member

    I don't believe thats the issue with 4 gigs of free space on the sd card... I'm really feeling as if it has to do with having two img's on my sd card and it pulls the thunder image first. once I get home... i'll remove the img from my card and attempt the process one more time.

    I'm confident thats the issue happening. Lesson of the day is remove any old image you may have placed in your phone from previous posts. make sure the only image you have on your phone is the one provided above.

    Will update later tonight.
  20. hav0kk

    hav0kk Member

    The MEID can be converted using a MEID to Hex calculator look around online. The MEID is located under the battery on the sticker (18 digits). You have all the information you need to recover the missing data provided you know your phone number already. The only time your MIN and your phone number don't match is when there is a port occuring. Other than that they generally are the same number. Thats how it was done back in the day when porting was still a new thing
  21. alexxseven

    alexxseven Well-Known Member

    The reason you got this error is because you have to use ADB shell from a computer to run the nand backup, I had the same issue.
  22. hav0kk

    hav0kk Member

    ah hah! I did it directly from my phone...

    I still need to remove the other image. So, what i'll do is try it with the thunder.img removed from the phone. if I get it again... i'll attempt again from pc.

    more curiousity than concern at this point
  23. h4x0rj3ff

    h4x0rj3ff Chemist

    will this allow us to use overclocking programs like setcpu? ive been pissed that i couldnt use it on my phone because it has stock 2.2.1
  24. alexxseven

    alexxseven Well-Known Member

    lol well if it works for you let me know, i kept trying to run it right off the phone but it wouldn't work so i used adb shell to run it, make sure you have about 500mb free space tho, :D

    well you have always been able to USE the program, its up to someone to make an overclocking kernel for us 2.2.1 people though, iv'e thought about it but i don't even know where to begin on trying to make one lol xD!
  25. hav0kk

    hav0kk Member

    Well that was uneventful. I plugged my phone up... enabled usb and went to my sd card directory and deleted the thunder image originally d/l'ed but never deleted (thunder image is part of the customer recovery for stock 2.2's)
    Placed phone back into debug mode. Went through the full process to recover in joneidy's recovery image and everything went through like clockwork and powered the phone off.

    So when I turned the phone on via POWER + HOME + Volume DOWN
    My customer recovery comes up and was hoping I'd see joneidy's customer recovery labeled in the build info below... and what do I see? IT STILL SAYS THUNDER-BLAHBLAHBLAHBLAH.

    Any ideas? I'm sure if I can remove the image entirely I'd be able to enter joneidy recovery image and complete my nandroid backup.

Share This Page