1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root Finally Rooted but...

Discussion in 'Android Devices' started by BigPapaBang, Feb 11, 2011.

  1. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    Hey guys. I was on the fence for a long time about Rooting and once i finally decided to do it, I ran across a small problem I wanted to fix so I could start out with a clean slate. My front camera stopped working. To make a long story short, the sprint tech says he hooked it up to a laptop and it told him there was a 3rd party app conflict? Anyways, a factory reset, which they always seem to default to, fixed the problem and all was well. I rooted the minute I got home since i was back to ground zero. I went through the Rooting for Dummies step by step and all went well. I didn't flash any kernels or roms because I was still undecided about which one to go with yet. The only apps I downloaded were the ones I had previously purchased (PicSay pro, SystemPanel App, App 2 SD Pro, PrinterShare Mobile and Printershare Premium), Apps that needed to be updated that i still use (Facebook, Google Maps and GMail) and BusyBox, WiMAX Key Checker, and Wireless Tether. After each download and install, I made sure to check the front camera to see if it worked and it did. All was well, or so I thought, and I went to work last night. I'm not sure what made me do it but while sitting at a light I wanted to check the front camera again. My problem reared it's ugly head again. When switching to the front camera in the camera setting, it says it's switched to the secondary front camera but the view is of the rear main camera and at a lower resolution. I'm assuming 1.3mp. Has anyone had this problem before? I uninstalled all apps and powered down for 10 seconds and then restarted but it still happens. Should I factory reset again? I don't really use the front camera but knowing it doesn't work is pretty annoying. To me anyways. Thanks in advance for any comments you guys may have.
     

    Advertisement

  2. dan330

    dan330 Extreme Android User

    it could be just a setting in the camera...

    like to let you show your caller what you are seeing in front of you....
    Look for a setting in the camera.. or app you use to face chat.
    also.. you can go into the camera.. and reset the defaults..
     
  3. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    I've tried every camera setting there is. I'm stumped...
     
  4. dan330

    dan330 Extreme Android User

    ok...

    do a nandroid backup...
    flash a new ROM...


    maybe the new ROM will have it fixed :)
     
  5. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    Tried both a full wipe/factory reset through recovery and a restore to right after I rooted. It took me to before I even imputed my gmail acct. and still the problem persists...
     
  6. dan330

    dan330 Extreme Android User

    restore???

    did you flash a brand new custom ROM?
     
  7. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    After rooting I never flashed a Rom or kernel because I was still undecided on which one I'd go with. I made a back up point of exactly where I was right after the root process. I made it a point to check to see if the front camera was still working after each thing I did since I was told that my issue was supposedly a 3rd party app conflict by a Sprint tech.
     
  8. dan330

    dan330 Extreme Android User

    what I am suggesting.. is that you go ahead and install a new custom ROM... this will replace a lot of things.. and the camera app too...

    maybe this will correct your issue.



    if anything goes wrong.. you can nandroid restore your old setup
     
    BigPapaBang likes this.
  9. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    Gotcha. I've been reading around and I think I'm gonna go with the mikfroyo Rom with the kernel that everyone seems to like with it. The name escapes me right now. I'm kind of stuck in a food coma right now. Have you tried it yet?
     
  10. dan330

    dan330 Extreme Android User

    no.. i have heard good things..
    i tried a few.. and have settled on Myn Warm.. happy there.
     
  11. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    mikfroyo is awesome! it is super fast. however, the themes in myn's are better. i have been using it for awhile and i love it.

    i am just trying koni elite series 1 which has mikfroyo's framework in it. it seems just as fast as mikfroyo so far. i'm going to give this one a workout and see if it holds up to mikfroyo.
     
    BigPapaBang likes this.
  12. frenchy714

    frenchy714 Android Expert

    I think the kernel you're referring to is this one.
     
    BigPapaBang likes this.
  13. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    I flashed mikfroyo 4.5 and everything went smooth. My camera problem still persists! I wiped everything before flashing. Wiped data/factory reset, wiped cache and wiped davlik cache. I have no idea what's up. I guess I'll have to live without my front camera (which I don't really use anyways) unless some one has any ideas...
     
  14. dan330

    dan330 Extreme Android User

    ok...

    when I got my evo in Dec.. I my new evo would not work with old kernels... the new camera would not work with old kernels.

    i had to wait till HTC released the code for my camera to work.

    try flashing a custom kernel.. one that ROM users suggests.. and a newest one.
     
  15. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    Flashing Netarchy Toastmod 4.3.2 CFS more HAVS nosbc as we speak! I'll let u know how it goess. Thanks for the quick replies by the way Dan!
     
  16. Drew5150

    Drew5150 Android Expert

    but if he is still on the stock kernel, it should just work. but yeah might as well try a new kernel.

    you could also try going into your camera with secondary camera enabled and toggle mirror mode on and off. maybe reset defaults.

    I have no idea, this is the first I have ever heard of it. I even tried downloading picsay and running it. my camera still works ok.

    so since this is your first rom install I'll give you a couple of tips.

    menu-settings software updates - update profile and then reboot your phone. you should do this any time you flash a new rom. also doesn't hurt to try and update PRL.

    now for gps to work after doing the update profile. open google maps and let it locate you, leave open for a minute or 2. exit maps and open google navigation, blue arrow, click on maps and make sure it finds you. I think some people get nav to work without this method, just throwing it out there just in case.

    if you experience market problems do the following, not just after flashing a rom but anytime the market doesn't want to download. menu-settings-applications-running- Google services framework - clear data and then force stop. go into all apps - find mikmarket, clear cache,data and then force stop. reboot phone.

    no idea on whats up with your camera. do you have an insurance plan? may want to consider getting an exchange. I've used my front camera twice to take an actual picture and never for video .. lol. so I'm with ya if you don't find it necessary.
     
    BigPapaBang likes this.
  17. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    Boo. Still no luck. Camera still shows view of rear main camera when it says I'm in secondary mode...
     
  18. dan330

    dan330 Extreme Android User

    so.. if you do a full factory reset.. it will work again??
     
  19. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    The odd thing, like I said earlier, was that I had this problem before root. I got it fixed by a sprint tech. I rooted and everything worked fine for a day then my problem came back. The sprint guys said my problem was with a 3rd party app? I only downloaded a couple things stated in my first post and I double checked to see if the camera was working after each install and it did.
     
  20. BigPapaBang

    BigPapaBang Newbie
    Thread Starter


    That's another weird thing too. Before taking my evo to the sprint store I did the reset with the guy at advanced tech support over the phone and it didn't work. He directed me to just bring it in and they'll give me a new phone. I brought it in and the tech fixes it by doing a factory reset and I get the same phone back, all is good. I wonder what the store tech did different?
     
  21. dan330

    dan330 Extreme Android User

    i say.. it is a bad phone! it just happened to work once .. if you mess with it. go get it replaced.. it is within 30days??? if so.. tell them! I dont care.. replace it
     
  22. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    You're probably right. It's gotta be a bad handset. It's way past the 30 days. I've had an evo since launch but it's actually my 3rd handset because of various "mishaps". Thank god for insurance! Haha. I'll probably ride it out until something else more serious happens then i'll unroot and take it in. Thanks a lot again for your replies Dan.
     
  23. dan330

    dan330 Extreme Android User

    no problem..
    maybe someone will read this that knows more.. and can give you better advice.
     
  24. BigPapaBang

    BigPapaBang Newbie
    Thread Starter

    Funniest thing just happened Dan! Since I'm a pro at this rooting stuff now, I wanted to try out the koni elite rom. After wiping everything and loaloading the rom, the front camera works like it should again! I'll keep an eye on it for sure...
     
  25. dan330

    dan330 Extreme Android User

    hahah :)

    take a pic of it before it runs away.
     
Loading...
Similar Threads - Finally Rooted
  1. Android News
    Replies:
    0
    Views:
    69
  2. Android News
    Replies:
    0
    Views:
    64
  3. Android News
    Replies:
    0
    Views:
    47
  4. Android News
    Replies:
    0
    Views:
    15
  5. Android News
    Replies:
    0
    Views:
    30
  6. notableuser
    Replies:
    1
    Views:
    265
  7. Ushtar Ali
    Replies:
    2
    Views:
    639
  8. Cyberdev
    Replies:
    2
    Views:
    635
  9. MoodyBlues
    Replies:
    4
    Views:
    1,378
  10. tube517
    Replies:
    55
    Views:
    2,303
Tags:

Share This Page

Loading...