1. Are you ready for the Galaxy S20? Here is everything we know so far!

FireBrick Is FireSTUCK

Discussion in 'Amazon Fire TV' started by Papamalo, May 12, 2019.

  1. Papamalo

    Papamalo Android Enthusiast
    Thread Starter

    After a couple of years of happy usage last night, my Firestick 2nd gen, got stuck on the home screen, and is now unresponsive to both the selector button, as well as the restart routine, (Holding down select and Play/Pause at the same time until it restarts).
    I did a couple of hard restarts by unplugging it, and then plugging it back in, and it went through the entire startup routine, including the red "fire TV"" startup logo, and then it opened to the same frozen unresponsive uncooperative (Like my ex wife) screen.
    I tried another remote, and that did not work either.
    Just to see what would happen I blocked it on my network, since wifi blocking will take you to the "home is unavailable" firestick screen, which it did, but once I got there, the "Go to network settings" and "dismiss" options were unresponsive as well.
    I don't mind having to reset it if I have to, but so far I haven't come up with a way to make it work.

    All help appreciated.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Dannydet

    Dannydet Extreme Android User

    Go into the Firestick settings, apps, clear cache. Restart. Are the batteries good in the remote?
     
    Papamalo likes this.
  3. Papamalo

    Papamalo Android Enthusiast
    Thread Starter

    There is no way to access any settings as the screen is frozen on the "home" screen and not responsive to any remote action, and restarting it just brings it back to the frozen "home" screen.
     
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    maybe a newer firer stick in needed. i had ti buy another chromecast for something similar. i probably could have troubleshooted, but i saw that i could upgrade with the newest generation model for the same price i bought the original......sold
     
  5. Dannydet

    Dannydet Extreme Android User

    There's a Firestick remote control app in the play store.
    Maybe using that can get past the frozen screen...
    Not sure of the correct name, but I think it's called Amazon Fire remote.
    I know it worked for me when I tried it out.
     

Share This Page

Loading...