1. Download our Official Android App: Forums for Android!

Support Fix bootloop after updating SuperSU on 5.0 Nexus 5 without data loss

Discussion in 'Android Help' started by Zachary Matson, Dec 29, 2014.

  1. Zachary Matson

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 29, 2014

    Dec 29, 2014
    4
    0
    5
    On my Nexus 5 running Android 5.0 (not 5.0.1) I selected to update SuperSU using the TWRP/CWM option in the SuperSU app (I have CWM). The update installed fine and after CWM asked if I would like to fix root I selected no. Boot was taking several minutes so I assumed I was dealing with a bootloop. I turned off the device mid-boot and wiped /cache and dalvik-cache. The device still will not boot. I have not yet tried anything else. I really do not want to lose my data, mainly music, settings, pictures/videos, and text messages. Any ideas?
     

    Advertisement

  2. BRAINZ2013

    BRAINZ2013 Android Expert
    Rank:
    None
    Points:
    353
    Posts:
    6,420
    Joined:
    Feb 21, 2012

    Feb 21, 2012
    6,420
    1,204
    353
    Male
    MECHANIC OBDII. NOS. FUEL INJECTION. Saving a Life
    Park Ave., HELL
    How was the charge level have you tried to boot into recovery with / without it plugged into a electrical wall outlet
     
  3. Zachary Matson

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 29, 2014

    Dec 29, 2014
    4
    0
    5
    Around 70-80%. I have plugged it into the wall now and it is running through the bootloop. It was not plugged in when I did the wipes, and booting into recovery worked fine.
     
  4. BRAINZ2013

    BRAINZ2013 Android Expert
    Rank:
    None
    Points:
    353
    Posts:
    6,420
    Joined:
    Feb 21, 2012

    Feb 21, 2012
    6,420
    1,204
    353
    Male
    MECHANIC OBDII. NOS. FUEL INJECTION. Saving a Life
    Park Ave., HELL
    If it boots into the recovery I say just do a fix perm. It should fix I reflashed the ROM . but I think the data is good but I had problems with play store apps
     
  5. Zachary Matson

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 29, 2014

    Dec 29, 2014
    4
    0
    5
    Will do
     
  6. Zachary Matson

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Dec 29, 2014

    Dec 29, 2014
    4
    0
    5
    An hour ago or so carried this out. Downloaded stock images from Google for Nexus 5 5.0 and opened command prompt, put the phone in fastboot, and flashed the image for the system partition after extracting it from the ZIP file with all of the images. Thanks for the advice!
     
  7. arahkun

    arahkun Lurker
    Rank:
    None
    Points:
    15
    Posts:
    2
    Joined:
    Feb 26, 2015

    Feb 26, 2015
    2
    0
    15
    I had similar problems.

    What worked for me, was to restore a CWM backup, WITH the charger plugged in.

    (It did not solve the problem without the charger, just keep getting the loop.)
    Go figure... Strange, but this is what worked for me.
     

Share This Page

Loading...