1. Download our Official Android App: Forums for Android!

Tips Fix for anyone have problems with SWYPE after installing 2.2

Discussion in 'Android Devices' started by thaboyz, Aug 3, 2010.

  1. thaboyz

    thaboyz Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    60
    Joined:
    Jun 6, 2010

    Jun 6, 2010
    60
    9
    16
    If your swype is not working correctly after installing 2.2. Try this...


    Go to this link https://beta.swype.com/android/user/


    Click on Resend me the Invite Email!


    On your phone go to setting>applications>manage applications.


    Scroll through and tap on Swype. Click uninstall


    Then click on Swype installer. Uninstall this as well


    Open the email account with the Swype link on your phone.


    Tap on the first link in the email


    Install the Swype Installer


    From the Swype Installer, install Swype then enable it.


    Enjoy


    I think the problem is that the Swype and the Swype Installer that is on most peoples phones after the 2.2 update are configured for Android 2.1. I noticed when I was going to uninstall the Swype for 2.1 the version number was 1.0. After installing the new installer and Swype the version number is now 1.56.30.7625.


    Your weclome :D

    Edit:****Seems to be only a temporary fix****
     

    Advertisement

  2. InstantKarma

    InstantKarma Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,001
    Joined:
    Dec 16, 2009

    Dec 16, 2009
    1,001
    158
    153
    Male
    Houston, Tejas
    My welcome to what? ;)
     
  3. Beradon

    Beradon Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Jun 19, 2010

    Jun 19, 2010
    7
    4
    6
    I had the issue with 2.2 breaking swype like many of you. I even attempted to reinstall and it would work again until I rebooted my phone manually, at which point it would stop recognizing any input. So here's my fix.

    OPTIONAL 1: Consider doing a clear of your phone's storage (aka hard reset), I know its a pain in the ass, but doing this fixed the delays I had with Handcent and Swype as well as a number other odd jittery things after my 2.2 update. Remember, if you do this you will have to re-setup your phone and all apps, including re-downloading swype.


    1: Go re-download the installer app, but be sure you delete the version of the installer you already have (including delete it from your download folder), it seems that the version of Swype that is downloaded is tied to the version of the installer app. Use the link in your email or log into the site with your phone's browser to re-download it. Make sure your browser is set to Mobile view. If not, the Swype site believes you're not on an Android phone. Also, use android's stock browser, the Swype site does not recognize most others. When you install it, be sure your task manager/killer is NOT running.


    2: If you are specifically using the Task Manager by Adao Team (this may go for others as well), it will break your Swype occasionally, even if you have swype in the ignore list. I had to switch to ATK.
     
  4. BetterMost

    Rank:
    None
    Points:
    163
    Posts:
    1,066
    Joined:
    Apr 25, 2010

    Apr 25, 2010
    1,066
    119
    163
    Paramedic
    Northern Illinois
    Im sure they will "fix" it to work better with froyo. Give them time.
     
  5. Beradon

    Beradon Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Jun 19, 2010

    Jun 19, 2010
    7
    4
    6
    It works beautifully after doing the above, no issues at all. And the devs over at Swype's site frequently speak of not using it while having any sort of task killer installed. But also, not to install swype while a task manager/killer is running.
     
  6. InstantKarma

    InstantKarma Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,001
    Joined:
    Dec 16, 2009

    Dec 16, 2009
    1,001
    158
    153
    Male
    Houston, Tejas
    I flashed .6 (rooted) over .3 earlier, and just now breathed a sigh of relief. Actually didn't have to completely reinstall again.
     
  7. jason4

    jason4 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jun 4, 2010

    Jun 4, 2010
    12
    1
    16
    Anyone else having this problem? The keyboard is still there, but i cant get any text to display after swypin.
     
  8. Rob_A

    Rob_A Android Expert
    Rank:
    None
    Points:
    113
    Posts:
    825
    Joined:
    May 28, 2010

    May 28, 2010
    825
    216
    113
    New York
    you need to uninstall/ reinstall it
     
    jason4 likes this.
  9. jason4

    jason4 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    12
    Joined:
    Jun 4, 2010

    Jun 4, 2010
    12
    1
    16
     
  10. jeremysm1

    jeremysm1 Member
    Rank:
    None
    Points:
    16
    Posts:
    31
    Joined:
    Jan 5, 2010

    Jan 5, 2010
    31
    2
    16
    I cannot find Locale & Text in the Setup area of my Evo with Froyo....how do I turn on Swype in the settings area? Please help...thanks,
     
  11. Bic101

    Bic101 Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    86
    Joined:
    Apr 25, 2010

    Apr 25, 2010
    86
    8
    16
    Uninstalling Swype and then reinstalling it worked for me after I lost it with 2.2. Thanks for the tips.
     
  12. InstantKarma

    InstantKarma Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,001
    Joined:
    Dec 16, 2009

    Dec 16, 2009
    1,001
    158
    153
    Male
    Houston, Tejas
    It's "Language & keyboard", now.
     
  13. leruth

    leruth Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Aug 4, 2010

    Aug 4, 2010
    3
    0
    5
    CA
    Uninstall/reinstall didn't work for me on EVO
     
  14. thaboyz

    thaboyz Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    60
    Joined:
    Jun 6, 2010

    Jun 6, 2010
    60
    9
    16
    It seems this fix is only temporary. A couple hours after doing the steps I listed above, I began to experience the same problems. I emailed Swype about the problem I was having. And yes I know Swype is in beta for Android but they cant fix the problem if they dont know about it. I'll post the response I get back from them....if I get one :rolleyes:
     
  15. frankiepapa

    frankiepapa Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    98
    Joined:
    May 15, 2010

    May 15, 2010
    98
    4
    16
    In regards to Swype, is anyone getting a notice that Swype does not recognize the Evo as an android device? It must be that there is a setting or something but I just haven't seen an answer to this nor have i gotten a response from Swype on this either......
     
  16. sboggus

    sboggus Member
    Rank:
     #1,226
    Points:
    16
    Posts:
    55
    Joined:
    Nov 4, 2009

    Nov 4, 2009
    55
    5
    16
    Newby here that just got an EVO and then the 2.2 update within 4 days of each other. Needless to say, I am in heaven! I hear this is the best keyboard, but how do I get it from scratch? Any help would greatly appreciated!
     
  17. jeremysm1

    jeremysm1 Member
    Rank:
    None
    Points:
    16
    Posts:
    31
    Joined:
    Jan 5, 2010

    Jan 5, 2010
    31
    2
    16
    My Swype is back in business. I did the uninstall / reinstall but during the reinstallation portion, I never logged back in to complete it. It seemed strange because I believe it required me to login twice via a browser like interface and I thought the second time was because I hit the button twice.

    So, compound the fact that Locale & Text changed to Location & Keyboard along with not finishing the installation doomed me. After I finished the install, the Swype option showed up in Location & Keyboard and I am now good to go.

    Thanks!
     
  18. Bek

    Bek Android Expert
    Rank:
    None
    Points:
    133
    Posts:
    908
    Joined:
    Apr 1, 2010

    Apr 1, 2010
    908
    485
    133
    Database Developer
    Chicago burbs
    For folks who may still have an issue after uninstalling & reinstalling, tap & hold a text area where the keyboard would normally be invoked. It'll give you a context menu with Input Method as a choice. Select that and see if Swype is or is not selected (probably is not), and select it. That final trick did it for me.
     
    TeamTJ and homeydroid like this.
  19. foosh

    foosh Newbie
    Rank:
    None
    Points:
    18
    Posts:
    15
    Joined:
    May 13, 2010

    May 13, 2010
    15
    13
    18
    i did this but after rebooting my phone, swype broke again :(
     
  20. jariten

    jariten Lurker
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Jun 9, 2010

    Jun 9, 2010
    4
    1
    6
    Swype breaks on me every couple days on both 2.1 and 2.2 (required reinstall). It just stops recognizing dragged input but it still works as a regular touch keyboard. A reboot (sometimes two) will fix it. Turning it off then back on via the 'input method' prompt will give the error message that it does not recognise the device.

    I let swype know and don't consider it a big deal as it's just a part of being in beta. Still beats the hell out of the stock input method.
     
  21. brushrop03

    brushrop03 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    287
    Joined:
    Jul 28, 2010

    Jul 28, 2010
    287
    36
    43
    Student
    Nashville, TN
    I wish I was officially in the beta so I could update...
     
  22. leebo

    leebo Newbie
    Rank:
    None
    Points:
    16
    Posts:
    23
    Joined:
    Jun 19, 2010

    Jun 19, 2010
    23
    1
    16
    SoCal
    Pressing and holding in the text input box and switching to standard keyboard worked for me.
     
    homeydroid likes this.
  23. homeydroid

    homeydroid Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 5, 2010

    Aug 5, 2010
    1
    0
    5
    after i updated my evo to 2.2 my swype stopped "swyping", but allowed me to tap. if only i knew of this solution before reinstalling tons of times
     
  24. ellymay

    ellymay Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jun 20, 2010

    Jun 20, 2010
    4
    0
    5
    Sorry, don't how to delete a post.
     
  25. jbnupe

    jbnupe Lurker
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Jun 9, 2010

    Jun 9, 2010
    9
    0
    5
    Brooklyn, NYC
    I tried to uninstall and Reinstall my Swype, but I am now getting an Swype Installation Failed Message. The ID of this phone does not match tyour registration at beta.swype.com.

    Has anyone else experienced this problem?
     
Tags:

Share This Page

Loading...