1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Fixed]Bootloop again

Discussion in 'Android Devices' started by ryanb876, Jan 5, 2014.

  1. ryanb876

    ryanb876 Newbie
    Thread Starter

    Hey guys. I managed to bootloop my phone again. I know what I need to do but I can't get it to work.

    All I need to do is push 4 files to /system/framework/

    When I try ADB shell I get this:
    PHP:
    1. > adb shell
    2. shell@android:/ $
    Then when I type su this is what I get:
    PHP:
    1. ]> adb shell
    2. shell@android:/ $ su
    3. su
    I'm baffled. It worked before.

    Then I restart cmd and I try adb shell su then nothing happens.

    My last resort is a factory reset which would work but I want to see if I can repair this.
     


  2. stevestone

    stevestone Well-Known Member

    kill adb server.. remove battery... then go to FTM... try again.... I too faced this, on my windows 7, i use to stuck on su, but when i tried on office xp.. it works fine... another weird strange behavior from ZTE.

    try official zte driver.....
     
  3. ryanb876

    ryanb876 Newbie
    Thread Starter

    didn't work. I tried uninstalling the drivers to see if that would do anything. Now the abd interface wont even work. Im going to do factory reset.
     
  4. ryanb876

    ryanb876 Newbie
    Thread Starter

    okay now ive got a problem. Turns out the factory reset in the recovery menu didn't format /system
     
  5. ryanb876

    ryanb876 Newbie
    Thread Starter

    I did a restore of my computer to get the usb drivers back as I could not find them online.

    For some reason adb shell su works now.

    I run these commands:
    PHP:
    1. su
    2.  mount -o rw,remount -t ext4 /system
    3.  adb push services.jar /system/framework
    4.  
    and I get Permission Denied.
     
  6. stevestone

    stevestone Well-Known Member

    Here you go bro,


    PHP:
    1.  
    2. su
    3. mount -o rw,remount -t ext4 /system
    4. chmod 777 /system/framework/
    5. adb push services.jar /system/framework/
    6.  
    works. I personally tried it for you, to check if it works by pushing dummy........

    :D
     
    ryanb876 likes this.
  7. ryanb876

    ryanb876 Newbie
    Thread Starter

    Once again, Steve has done the impossible. I truly thank you steve for all your help. The phone is fixed.

    Steve is the ADB god.
     
  8. stevestone

    stevestone Well-Known Member

    Check the edited one, before i pasted wrong code...
     
  9. stevestone

    stevestone Well-Known Member

    Hahahaha.. no problem.. Wat You were doing with framework files lol?

    Btw, how you did sdcard mounting for pushing services.jar file?
     
  10. ryanb876

    ryanb876 Newbie
    Thread Starter

ZTE Vital Forum

The ZTE Vital release date was June 2013. Features and Specs include a 5.0" inch screen, 13MP camera, 1GB RAM, Snapdragon S4 Plus processor, and 2500mAh battery.

June 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...