1. Download our Official Android App: Forums for Android!

Tips [FIXED in 4.3 OTA] GT-I9505G LTE bug - cause and workaround

Discussion in 'Android Devices' started by Medion, Jul 29, 2013.

  1. Medion

    Medion Android Expert
    Thread Starter
    Rank:
    None
    Points:
    233
    Posts:
    1,851
    Joined:
    Aug 14, 2010

    Aug 14, 2010
    1,851
    957
    233
    Male
    Auburn, WA
    EDIT: This bug has been fixed in the 4.3 OTA. This post is now for informational purposes only.
    ---------------------------------------

    So I've confirmed today that there is in fact an LTE issue with the Galaxy S4 Google Play Edition, and thankfully, it's software based. Hopefully, Google and/or Samsung implement a fix in short order. In the meantime, here's the cause (so that you can prevent the issue), and here's the workaround (so that you can correct the issue if you're affected).

    Background:

    Comparing the Google Play Edition to the Touchwiz Edition, there is a setting that is slightly different on both phones. If you go to Settings --> Wireless & Networks --> More --> Mobile Networks --> , you will see a setting; either "Use only 2G networks/saves battery (GPE)," or "Network Mode (TW)."

    The Network Mode on Touchwiz allows you to toggle between available network modes based on carrier, usually 3 individual settings and a full Automatic setting. The 2G Networks setting on the Google Play Edition is the cause for concern here. It's directly ported from the Nexus 4, and here's where the problem lies.

    Cause:

    While both devices have numerous hidden network modes, the toggle only allows for you to switch between two modes; GSM Only, and WCDMA Preferred. GSM Only occurs when the box is ticked. This sets you on Edge-only for battery savings. WCDMA preferred tells the phone to look for GSM/UMTS (Edge/3G/H), but to prefer the latter if both are available, even if the latter has a weaker signal. Did you see LTE in the equation? If you noticed that it's absent, here's why.

    The S4 has an additional mode; LTE/GSM (Auto PERL). This sells the phone to switch between LTE/H/3G/Edge based on signal strength and T-Mobile's/AT&T's APN settings and roaming list. The S4 GPE comes with this mode on by default. If you tick the 2G box, you'll go to Edge only. If you untick the box, instead of going back to LTE/GSM, you are sent to WCDMA Preferred. Now, you're stuck between 2G/3G/H, or 2G only. LTE is gone. Nice oversight by Google/Samsung :)

    The "Fix":

    Because this is an issue with the firmware, there is no permanent fix. However, there are easy user-facing applications that will allow you to toggle LTE back on. The one I'm using is LTE Setting (Google Play Link). From the main page, go down about 2/3s of the way and you'll see a drop-down menu. Select "LTE/GSM (Auto PERL)" to restore LTE. Now, the next time that you set your phone to 2G Only for the sake of battery savings, you'll need to use this app again to restore LTE compatibility.

    I've enclosed two pictures. The first is the setting as it appears in the Google Play Edition. The second is as it appears in a Touchwiz model, and why the Touchwiz variant does not have this problem.
     

    Attached Files:


    Advertisement

    introvert and Petrah like this.
  2. introvert

    introvert Lurker
    Rank:
    None
    Points:
    8
    Posts:
    8
    Joined:
    Mar 21, 2010

    Mar 21, 2010
    8
    24
    8
    Phoenix, AZ
    Hello Medion,
    Thank you for your informative post! I was wondering if there has been a fix implemented on this issue yet? I'm not sure how quickly Google usually rolls out these fixes.
     
  3. Medion

    Medion Android Expert
    Thread Starter
    Rank:
    None
    Points:
    233
    Posts:
    1,851
    Joined:
    Aug 14, 2010

    Aug 14, 2010
    1,851
    957
    233
    Male
    Auburn, WA
    The fix was rolled into the Android 4.3 update.
     
    introvert likes this.

Share This Page

Loading...