1. Download our Official Android App: Forums for Android!

General Fixed my dialer lag on wake

Discussion in 'Android Devices' started by Zzyzx, May 23, 2010.

  1. Zzyzx

    Zzyzx Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    May 19, 2010

    May 19, 2010
    4
    4
    6
    A few days ago I had a revelation... the default settings cause the Eris to disconnect from wifi when the phone goes to sleep. Then, when the phone wakes up, reconnecting causes a few seconds of major lag. Incidentally, this is exactly the situation you are usually picking up or dialing out from.

    I did this:

    Settings>Wireless & networks>Wi-Fi settings>[menu]>Advanced>Wi-Fi sleep policy>Never

    and so far I've noticed a huge improvement to responsiveness immediately after unlocking the screen. I was a little worried about battery impact, but it doesn't seem like an idle wifi connection is draining much more than an idle 3G.
     

    Advertisement

    hookem likes this.
  2. hookem

    hookem Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    416
    Joined:
    Dec 21, 2009

    Dec 21, 2009
    416
    44
    43
    TEXAS - AUSTIN
    Nice find.
     
  3. Jethro

    Jethro Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    104
    Joined:
    Nov 10, 2009

    Nov 10, 2009
    104
    3
    36
    I tried this setting but found that my phone will randomly drop the connection and give me a communication error after a while. The wi-fi icon still shows as connected though. And it's happened at work & home, so 2 totally different networks. And both give decent signal strength.
     

Share This Page

Loading...