1. Download our Official Android App: Forums for Android!

[FIXED] Phone doesn't boot after failed Xposed installation.

Discussion in 'Android Rooting' started by naahuel, Mar 4, 2016.

  1. naahuel

    naahuel Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Nov 15, 2013

    Nov 15, 2013
    9
    6
    16
    My phone: Moto G 2014, Android 5.0.1

    I was playing with Google Cardboard and noticed that it sucks on this phone. Shakes like hell. So I googled around and came accross Xposed framework and a module that fixes this.

    So, to "fix" the shaky gyro, I rooted my phone and installed xposed, using this tutorial:


    What went ok, was rooting the phone. I then flashed the ZIP using TWRP. Rebooted and it said "updating android". After that, i couldn't install any apps from the Play Store. It downloaded them, started installing and then gave me an error "-504".

    I cleared the apps cache and data. No luck.

    Restarted. Same problem.

    I noticed that the "updating android" box would appear everytime I booted.

    So went to TWRP and this is the stupid step that killed my phone: I flashed the zip again.

    Now it powers on, shows the Motorolla logos, they spin, it loads, and after a minute a get nothing. The screen light is on, but it's all black.

    I don't have a recovery img to restore, since i don't have an sd card and I didn't have enough storage space.

    Is there something I can do? I'm desparate.

    Thank you!

     

    Advertisement

    #1 naahuel, Mar 4, 2016
    Last edited by a moderator: Mar 5, 2016
  2. scary alien

    scary alien not really so scary
    Moderator
    Rank:
     #8
    Points:
    2,138
    Posts:
    22,295
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    22,295
    23,674
    2,138
    Male
    space alien ;)
    Indy
    @naahuel,

    While I don't have a an answer/solution for you, I do have a few quick things:

    1. I edited your post to remove the duplicate text--that should make it easier for folks to see what's going on

    2. That site you linked to is actually very well written--I didn't watch the video but read through all of the installation notes

    3. Did you select (and flash) the proper framework for your device/CPU? If not, I'm guessing that might be the cause of your issues...

    4. When you say you don't have a recovery.img to restore, do you mean that you no longer have a custom recovery installed or you do not have Nandroid backup that you can restore? (restoring a pre-Xposed Nandroid backup would fix you up if you had taken one, of course).

    I don't have a Moto G device and am not familiar with the ins and outs of it's root activities, so the best I can offer is to move your thread to the Moto G 2014 root area for you so the folks that know your device best can help you out:


    Let me know if you'd like me to do this.

    Cheers!
     
    naahuel and El Presidente like this.
  3. naahuel

    naahuel Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Nov 15, 2013

    Nov 15, 2013
    9
    6
    16
    @scary alien,

    I truly appreciate your response.

    1.- Thank you :)

    2.- Yes, that's why I followed those steps. It seemed pretty safe. Like I said, it all seemed to have gone ok. I did however had a problem installing or updating apps from the play store. I noticed this because I wanted to install ES File Explorer to install the APK of Xposed Installer I had saved in the phone. Every time I tried, it would download the files and when it was time to install it nothing happened and after a few minutes it'd throw the error I mentioned.

    3.- I followed the steps in the tutorial to see the architecture of the CPU and Android version. I had Android 5.0.1 and the CPU was ARMv7. I then tried to use the links provided by the tutorial, but they don't work. I should have downloaded Xposed Framework for 5.0.X devices (ARMv7). So what I did was go to the official thread in the XDA-DEVELOPERS forum for Xposed (following a link in the official website). Here: http://forum.xda-developers.com/showthread.php?t=3034811
    So what I did there was download the file called "xposed-v80-sdk21-arm.zip (3.31 MB)" and that's the one I flashed using TWRP. I figured that was the correct sdk for android 5.0.1 and the correct CPU (was I wrong?).
    And again, that *seemed* to have gone ok. Phone booted, worked, but wouldn't allow me to install apps. And also, the "updating android" message box would appear every time I restarted the phone.
    That's when I (stupidly) decided to flash that same zip again. Now, I have no access to the phone.
    * Phone is picked up by Ubuntu when connected to the USB port while in the "black screen", but I can't mount it to see its internal storage or sd card.
    * Phone seems to boot up fine, but shows a black screen after the loading logos.
    * I can boot into custom recovery fine.

    4.- I did not perform a NANDroid backup. I needed like 4Gb that I didn't have.


    Thank you for your time. If you feel that it would help me better to move the thread, please go ahead. I posted it here mainly because it seems a more active area and perhaps this wasn't a Moto G-specific problem.
     
  4. scary alien

    scary alien not really so scary
    Moderator
    Rank:
     #8
    Points:
    2,138
    Posts:
    22,295
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    22,295
    23,674
    2,138
    Male
    space alien ;)
    Indy
    No problem, @naahuel -- happy to help in what little way I can :).

    It does look to me (after perusing the very confusing threads, LOL :p) that you downloaded and installed / flashed the correct .zip framework file. I've not used / installed Xposed, so I'm afraid I can't really give you much guidance on troubleshooting this.

    It's good that you do indeed still have a custom recovery (I just wasn't sure) since that will obviously give you some options for debugging and recovering things.

    It does look like the Xposed installer creates backup files of the files that it messes with (i.e., by appending "_original") to them and that the Xposed uninstaller .zip file (located in the same page/link where you got the framework installer .zip file) should revert things back to how they were prior to the first installation.

    What I don't know is what effect your having flashed the installer twice will be--i.e., will the second flashing have renamed the files (which it would have assumed were stock) with the "_original" suffix (and therefore make using the framework uninstaller not really useful)?

    Dunno...

    You might want to also post in the proper XDA thread and see what the folks over there say...that/they might be your best resource for resolving your issues--otherwise, you might need to (somehow) re-install the stock files that the Xposed installer installed.
     
    naahuel and El Presidente like this.
  5. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,120
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,120
    24,093
    3,118
    Scotland
    naahuel and scary alien like this.
  6. roadkill42

    roadkill42 Android Expert
    Rank:
     #104
    Points:
    183
    Posts:
    2,461
    Joined:
    Jan 22, 2013

    Jan 22, 2013
    2,461
    474
    183
    Male
    kinda jack of trades
    jonesbough tn
    It unstalls it completely I had simuliar problem I would run that then up grade to the latest lp before doing exposed I have it on my wife's moto e 2015 running m nice and smoth
     
    El Presidente and scary alien like this.
  7. roadkill42

    roadkill42 Android Expert
    Rank:
     #104
    Points:
    183
    Posts:
    2,461
    Joined:
    Jan 22, 2013

    Jan 22, 2013
    2,461
    474
    183
    Male
    kinda jack of trades
    jonesbough tn
    One these should work with the unstaller good luck
     

    Attached Files:

  8. naahuel

    naahuel Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Nov 15, 2013

    Nov 15, 2013
    9
    6
    16
    Thanks a lot everyone! :) This is the most help I've ever gotten from any other forum, about anything. Great place!
    After pulling an all-nighter (I became extremely paranoid, so I did a lot of reading and video watching. Phones are expensive here. )

    After a lot of thinking, I went with this one:
    http://forum.xda-developers.com/moto-g-2014/general/official-stock-firmware-5-0-2-lxb22-46-t3019612
    I used this firmware
    XT1068 5.0.2 LXB22.99-16.3 RETDSDS WITH STAGE FRIGHT FIX RETAIL DUAL SIM DUAL STANDBY (EU/INDIAN/GLOBAL) 26/08/2015 BUILD

    I'm from Latin America (Argentina). I chose that one instead of the last one for LA because it's the only one that says Dual Sim.

    I had to get a Windows machine and whatnot. Everything went really smoothly. After installing the firmware, the phone booted up like a champ. However, my Google Account was still there, even though I performed a factory reset from fastboot.

    Now I have a new problem. SIM cards don't work. They are recognized, but they show "no service". If I go to scan networks, it says "there was an error scanning for networks". Here are screenshots (in Spanish, sorry!)
    https://goo.gl/photos/Fi3GArKJSGqzFn8C9
    https://goo.gl/photos/i1aNakd1a9NjxaWt7

    Is this fixable? Should I try another firmware? :(

    I can't thank you enough for all the time and trouble you took doing all this research.

    I did think about giving this a go. It worried me that I had flashed it twice, so I didn't.

    That's what I thought, yeah.

    Yeah, that's what I did... :(

    Thank you for your help :)
     
    roadkill42 and scary alien like this.
  9. roadkill42

    roadkill42 Android Expert
    Rank:
     #104
    Points:
    183
    Posts:
    2,461
    Joined:
    Jan 22, 2013

    Jan 22, 2013
    2,461
    474
    183
    Male
    kinda jack of trades
    jonesbough tn
    Try cleaning Sim card reinsert it turn phone back on
     
    scary alien and naahuel like this.
  10. naahuel

    naahuel Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Nov 15, 2013

    Nov 15, 2013
    9
    6
    16
    Nothing :(

    I believe this is a software problem...
     
  11. roadkill42

    roadkill42 Android Expert
    Rank:
     #104
    Points:
    183
    Posts:
    2,461
    Joined:
    Jan 22, 2013

    Jan 22, 2013
    2,461
    474
    183
    Male
    kinda jack of trades
    jonesbough tn
    That's sucks ur probly right
     
  12. naahuel

    naahuel Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    9
    Joined:
    Nov 15, 2013

    Nov 15, 2013
    9
    6
    16
    Welp. After crying like a little girl, I was able to find the modem files for my location. Flashed them and BOOM. Full signal :D

    Thank you so much for all the help you gave me. This place is the best!
     
  13. roadkill42

    roadkill42 Android Expert
    Rank:
     #104
    Points:
    183
    Posts:
    2,461
    Joined:
    Jan 22, 2013

    Jan 22, 2013
    2,461
    474
    183
    Male
    kinda jack of trades
    jonesbough tn
    That's what people should do is help I'm glad u got it solved
     
    bcrichster, scary alien and naahuel like this.
  14. ALS Mobile

    ALS Mobile Newbie
    Rank:
     #580
    Points:
    25
    Posts:
    13
    Joined:
    Thursday

    Thursday
    13
    0
    25
    Hi
    friends Does any one have Dead boot Repair solution of moto XT1068 ?
    thanks in Advance
     
  15. bcrichster

    bcrichster Android Expert
    Recognized Developer
    Rank:
     #33
    Points:
    713
    Posts:
    6,092
    Joined:
    Jan 23, 2013

    Jan 23, 2013
    6,092
    4,282
    713
    Male
    Electrical, Electronics
    Florida
    Try the xposed uninstaller zip
     
    mikedt likes this.
  16. ALS Mobile

    ALS Mobile Newbie
    Rank:
     #580
    Points:
    25
    Posts:
    13
    Joined:
    Thursday

    Thursday
    13
    0
    25
    Thanks for reply
    Please can u give me the link where can I download ?
     
  17. roadkill42

    roadkill42 Android Expert
    Rank:
     #104
    Points:
    183
    Posts:
    2,461
    Joined:
    Jan 22, 2013

    Jan 22, 2013
    2,461
    474
    183
    Male
    kinda jack of trades
    jonesbough tn
    Google it should find it
     
    bcrichster likes this.
  18. mikedt

    mikedt 你好
    Rank:
     #6
    Points:
    2,238
    Posts:
    24,797
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    24,797
    13,777
    2,238
    Teachaaa
    Jinan, China
    I think all the relevant files and links are already in the thread.
     
    bcrichster likes this.
  19. ALS Mobile

    ALS Mobile Newbie
    Rank:
     #580
    Points:
    25
    Posts:
    13
    Joined:
    Thursday

    Thursday
    13
    0
    25
    Xpose uninstaller can't help
    Because my phone can't even go to fast boot
    Phone is dead and on PC detect as Qdloader 9008
     
  20. roadkill42

    roadkill42 Android Expert
    Rank:
     #104
    Points:
    183
    Posts:
    2,461
    Joined:
    Jan 22, 2013

    Jan 22, 2013
    2,461
    474
    183
    Male
    kinda jack of trades
    jonesbough tn
  21. ALS Mobile

    ALS Mobile Newbie
    Rank:
     #580
    Points:
    25
    Posts:
    13
    Joined:
    Thursday

    Thursday
    13
    0
    25
    If I can get blank flash then may be I can recover this phone back
     
  22. roadkill42

    roadkill42 Android Expert
    Rank:
     #104
    Points:
    183
    Posts:
    2,461
    Joined:
    Jan 22, 2013

    Jan 22, 2013
    2,461
    474
    183
    Male
    kinda jack of trades
    jonesbough tn
    So ur in edl mode what phone is this?
     
  23. ALS Mobile

    ALS Mobile Newbie
    Rank:
     #580
    Points:
    25
    Posts:
    13
    Joined:
    Thursday

    Thursday
    13
    0
    25
    I have to 2 phones
    Motorola X-Play Xt1562
    And Motorola G XT1068
     
  24. ALS Mobile

    ALS Mobile Newbie
    Rank:
     #580
    Points:
    25
    Posts:
    13
    Joined:
    Thursday

    Thursday
    13
    0
    25
    Both of them same problem
     
  25. roadkill42

    roadkill42 Android Expert
    Rank:
     #104
    Points:
    183
    Posts:
    2,461
    Joined:
    Jan 22, 2013

    Jan 22, 2013
    2,461
    474
    183
    Male
    kinda jack of trades
    jonesbough tn
    Can u get into recovery at all
     

Share This Page

Loading...