1. Check out our companion app, Forums for Android! Download from Google Play

Support Flaky Charging Port

Discussion in 'Android Devices' started by breadnatty08, Jan 3, 2013.

  1. breadnatty08

    breadnatty08 pain rustique
    Thread Starter
    1,313

    Nov 8, 2009
    19,890
    6,118
    1,313
    District of Columbia
    Well, I think the charging port on my Gnex (Verizon) is starting to fail. :(
    It goes in and out of charging and sometimes I have to wiggle it a little bit (which I'm sure isn't helping the situation).
    Anyone else having this problem?
    Our OG Droids went two years without any issues. I'm hoping this doesn't get worse as I'm pretty strapped for cash on a new phone.
     

    Advertisement

  2. Caveman419

    Caveman419 Well-Known Member
    98

    Feb 24, 2010
    623
    85
    98
    Male
    Financial Systems Support Specialist
    Last cave on the left
    Would finding a charging dock or a stand along battery charger be an option? I have two of the charging docks that I use. I found them on Swappa. I got lucky and had people break them out of their packages and sell them seperatly for about $45-$50.
     
  3. jhawkkw

    jhawkkw Chinchillin'
    1,333

    Jul 30, 2011
    10,634
    7,397
    1,333
    Washington, DC
    Mine is showing it's age. It's no longer a tight connection and does wiggle around quite a bit, but I haven't seen it stop charging yet.
     
  4. breadnatty08

    breadnatty08 pain rustique
    Thread Starter
    1,313

    Nov 8, 2009
    19,890
    6,118
    1,313
    District of Columbia
    Granted, I could be blaming it on an ancient charging cable that's from our Droids. It's the one causing the most problems. Newer ones I have aren't so bad.
     
  5. Caveman419

    Caveman419 Well-Known Member
    98

    Feb 24, 2010
    623
    85
    98
    Male
    Financial Systems Support Specialist
    Last cave on the left
    Might be time to update that cable....from the OG Droid!?!?!?
     
  6. breadnatty08

    breadnatty08 pain rustique
    Thread Starter
    1,313

    Nov 8, 2009
    19,890
    6,118
    1,313
    District of Columbia
    Haha! Yep. :)
    Just the one I use at work. I have the one that came with my Gnex here at home and it works just fine.
     
  7. Caveman419

    Caveman419 Well-Known Member
    98

    Feb 24, 2010
    623
    85
    98
    Male
    Financial Systems Support Specialist
    Last cave on the left
    Whew....starting to scare me there....
     
  8. breadnatty08

    breadnatty08 pain rustique
    Thread Starter
    1,313

    Nov 8, 2009
    19,890
    6,118
    1,313
    District of Columbia
    The charging block on it doesn't even work anymore. I need to plug it into my computer to charge. :eek:
    Okay, maybe time for a new cable. :)
     
  9. Caveman419

    Caveman419 Well-Known Member
    98

    Feb 24, 2010
    623
    85
    98
    Male
    Financial Systems Support Specialist
    Last cave on the left
    That might be a sign. I ordered one a long time ago to keep one at work and one at home, now they both power my docks. I think you can find them pretty cheap on amazon.
     
  10. ganj_420

    ganj_420 Well-Known Member
    38

    Jun 29, 2011
    101
    22
    38
    Yeah definitely go for a new cable. My port started going wonky on me recently also, and it is starting to get loose like yours. I just cleaned it really good with some sharp needle-nose tweezers and blew out all the gunk that has collected over the past year from going in and out and in and out of pockets and what not. Works much better now, I bet that would help you out a bit
     
    breadnatty08 likes this.
  11. breadnatty08

    breadnatty08 pain rustique
    Thread Starter
    1,313

    Nov 8, 2009
    19,890
    6,118
    1,313
    District of Columbia
    Yeah, I'll look look into a new cable. Hoping the next phone has wireless charging, just a little paranoid here. :eek:
     
  12. Tim K

    Tim K Well-Known Member
    183

    Nov 2, 2009
    1,649
    471
    183
    Male
    Phila, PA
    Yeah, I've found mine often shows "USB Charging" when its plugged in. I've come to check it when I plug it in to make sure. If its USB I unplug and re-plug to make it come up "AC Charging". Its the original GN cable and block. I don't know if its the cable or the port.
     
  13. breadnatty08

    breadnatty08 pain rustique
    Thread Starter
    1,313

    Nov 8, 2009
    19,890
    6,118
    1,313
    District of Columbia
    Is it the original or another?
     
  14. AnotherFatalEpic

    AnotherFatalEpic Well-Known Member
    38

    Jan 30, 2010
    484
    22
    38
    Male
    Los Angeles, CA
    Where do you see if it is USB or AC Charging? On the Lockscreen it just says charging...

    EDIT: NM found it when I went into the settings for battery, it has (USB) next to charging, I could have sworn this was not here before.
     
  15. Englimnex

    Englimnex New Member
    5

    Dec 4, 2012
    3
    0
    5
    If one of the USB data lines isn't making a good connection then the phone will report it is USB charging even when plugged into a AC charger. I suspect that we are wearing out the USB ports because we have to plug in the GNEX so frequently to keep it charged.
    I recently had the problem of the Gnex charging/USB port going bad. It wasn't the cable. It was the port itself. I tried cleaning it but that didn't help. Bending the port casing got it back to at least working intermittently. I ended up replacing the port. Instructions are on iFixit.com. I bought the new part on Ebay from "gadgetfix". The description for CDMA version is:"OEM Samsung Galaxy Nexus CDMA i515 Dock Flex Charger Port Charging USB Connector". Make sure you get the right part since the CDMA version is different from the GSM version. The GSM PC board has is noticeably longer. Total cost ~$10. Changing it out was a little scary. Itty bitty parts and you have to be real careful to get everything back exactly right. I did this myself because the local phone fixit shops have horrible reputations. It works fine now.
     
Tags:

Share This Page

Loading...