1. Download our Official Android App: Forums for Android!

Root Flash 10.1 Final Release for Froyo

Discussion in 'Android Devices' started by Frisco, Aug 23, 2010.

  1. Frisco

    Frisco =Luceat Lux Vestra=
    Thread Starter
    Rank:
    None
    Points:
    1,343
    Posts:
    22,479
    Joined:
    Jan 19, 2010


    Advertisement

  2. Toolanddiemaker

    Toolanddiemaker Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    149
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    149
    20
    38
    I think you might know.
    Michigan
    So does this work for the Eris Frisco? I heard the processor was not strong enough?
     
  3. Frisco

    Frisco =Luceat Lux Vestra=
    Thread Starter
    Rank:
    None
    Points:
    1,343
    Posts:
    22,479
    Joined:
    Jan 19, 2010

    It's installing now on mine.. will post results.
     
    Toolanddiemaker likes this.
  4. Frisco

    Frisco =Luceat Lux Vestra=
    Thread Starter
    Rank:
    None
    Points:
    1,343
    Posts:
    22,479
    Joined:
    Jan 19, 2010

    I put the apk on my sd card, used Root Explorer to find then install the file, watched the install progress bar go to the end, then received an error message, "not installed," with a "done" button at the bottom.

    I tried again with the same results.

    I'll look around other forums for a bit.
     
  5. IzelTokatl

    IzelTokatl Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    580
    Joined:
    Dec 11, 2009

    Dec 11, 2009
    580
    90
    78
    a lifehacker
    Southern California
    This may not be installable.... it may be like the Corpcal.apk file where you just have to put it in the sysdir and reboot, then it just works.. lets test!
     
  6. IzelTokatl

    IzelTokatl Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    580
    Joined:
    Dec 11, 2009

    Dec 11, 2009
    580
    90
    78
    a lifehacker
    Southern California
    Doesn't seem to want to install, or work from just copying into sysdir. fun..

    Doesn't work on any browser so far (using dolphin, or browser, or Opera). Guess it may be an issue with eris froyo (since it does work on Sense but that is because of the Flashlite bypass it uses.
     
  7. emerica243

    emerica243 Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    199
    Joined:
    Feb 21, 2010

    Feb 21, 2010
    199
    11
    38
    my flash 10 works on xtrROM right out of the box, if that means anything
     
  8. Frisco

    Frisco =Luceat Lux Vestra=
    Thread Starter
    Rank:
    None
    Points:
    1,343
    Posts:
    22,479
    Joined:
    Jan 19, 2010

    Mine, too. We're trying the Froyo version.
     
  9. Batbriel

    Batbriel Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    299
    Joined:
    Apr 21, 2010

    Apr 21, 2010
    299
    32
    43
    IdaWhoooo?
    Running Cyanogen Tazz 1.0 and didn't work :(
     
  10. Frisco

    Frisco =Luceat Lux Vestra=
    Thread Starter
    Rank:
    None
    Points:
    1,343
    Posts:
    22,479
    Joined:
    Jan 19, 2010

    Yeah, I hate this.. I'm failing.

    It appears our little ole Erises weren't in the Froyo lineup for this version of Flashplayer.

    I don't need it much, but others do and I was hoping to get it going, etc.
     
  11. luodanli

    luodanli Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Apr 20, 2010

    Apr 20, 2010
    3
    0
    5
    This is the debug log from my install attempt.

    08-23 15:48:06.943: DEBUG/PackageManager(87): Scanning package com.adobe.flashplayer
    08-23 15:48:06.983: ERROR/PackageManager(87): Package com.adobe.flashplayer has mismatched uid: 10082 on disk, 10084 in settings
    08-23 15:48:06.983: INFO/PackageManager(87): /data/app/com.adobe.flashplayer-1.apk changed; unpacking
    08-23 15:48:07.003: WARN/PackageManager(87): Native ABI mismatch from package file
    08-23 15:48:07.003: WARN/PackageManager(87): Package couldn't be installed in /data/app/com.adobe.flashplayer-1.apk

    The following excerpt from Android NDK | Android Developers may explain our difficulty.

    To ensure that your applications are available to users only if their devices are capable of running them, Android Market now filters applications based on the instruction set information included in your application
     
  12. Frisco

    Frisco =Luceat Lux Vestra=
    Thread Starter
    Rank:
    None
    Points:
    1,343
    Posts:
    22,479
    Joined:
    Jan 19, 2010

    Welcome to the forums, and thank you for an informative first post, luodanli. :)
     
  13. luodanli

    luodanli Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Apr 20, 2010

    Apr 20, 2010
    3
    0
    5
    Thanks for the welcome. I've been lurking for a little too long.

    So how are they using flash 10.1 on Android 2.1 ROMs? Beta flash build that runs on lower ARM versions? Spoof CPU version? Emulation? I'm curious, but will have to wait to look until I get back from work in the morning.
     
  14. alprazolam

    alprazolam Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,722
    Joined:
    Dec 31, 2009

    Dec 31, 2009
    1,722
    194
    143
    I'm sure that a skilled dev will have this working soon enough.
     
  15. andrizoid

    andrizoid Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,266
    Joined:
    Mar 25, 2010

    Mar 25, 2010
    2,266
    358
    163
     
  16. luodanli

    luodanli Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Apr 20, 2010

    Apr 20, 2010
    3
    0
    5
    Tried the Amon UID utility and no dice on the fixing the mismatched UID.

    08-24 06:48:46.240: DEBUG/PackageManager(87): Scanning package com.adobe.flashplayer
    08-24 06:48:46.270: ERROR/PackageManager(87): Package com.adobe.flashplayer has mismatched uid: 10082 on disk, 10083 in settings
    08-24 06:48:46.270: INFO/PackageManager(87): /data/app/com.adobe.flashplayer-1.apk changed; unpacking
    08-24 06:48:46.290: WARN/PackageManager(87): Native ABI mismatch from package file
    08-24 06:48:46.290: WARN/PackageManager(87): Package couldn't be installed in /data/app/com.adobe.flashplayer-1.apk

    I suspect that if the UID was the issue, it wouldn't have made it to the unpacking and ABI mismatch stages.
     

Share This Page

Loading...