1. Are you ready for the Galaxy S20? Here is everything we know so far!

Flashing ROMs

Discussion in 'Android Devices' started by Mr User, Dec 29, 2011.

  1. Mr User

    Mr User Member
    Thread Starter

    Hi, I'm not actually a total noob here, flashed 3 different phones so far, a few flashes in 1 day sometimes.
    But I've a problem with the HTC Desire CDMA that I don't understand. So I used revolutionary, got S-Off, pink Revolutionary words in hboot. This part is fine, and I succeeded in flashing 2 AOSP ROMs, which is CM 7 and Oxygen, both latest versions. But I decided I want Sense, since I think the eye candy fits the phone better than AOSP. But the stock (2.2 with Sense from Cox-I don't care about service though using this like an MP3/MP4 player with WiFi) has too many problems for me, major one being storage (147 Mb...and app 2 SD by Froyo is not enough), so I'm looking for newer Sense versions, best one being 3.5 :)
    So I tried Cool3D RunnyMede, but every single time I'm stuck at the white HTC booting screen for ~5 min. I'm gonna give what I did so as to make sure i didn't do a step wrong(I found no instructions at the site, and this is my 1st time with an HTC and CDMA):
    1. Got the requirements down:
    -Stock Boot, 250 Mb sys/ 40 Mb cache/ 147 Mb Data.
    -SD card partitioned with MiniTool Partition Wizard, got ~1 Gb of EXT4, the rest is FAT32. All clean after this.
    Align the EXT4 partition: I couldn't get the file from the site, Cool3D RunnyMede v5 Bravo | Cool Devs, but I googled myself and got a similarly named file, attached, saw the inside, looks alright.
    Assume A2SD is already in the ROM.
    2.-Boot into hboot(from off Vol Down + , then go to Recovery. Recovery is ClockWorkMod 5 (latest I got from Cyanogenmod website)
    Wiped from Recovery in this order:
    -Wipe data/Factory Reset
    -Wipe cache
    -wipe Dalvik cache
    I wiped data/factory again after a few failed times.
    3.-Flashed from zip. I flashed in this order:
    -Flashed the alignment zip.
    -Flashed the main ROM zip.
    -Flashed the GSM-to-CDMA zip.
    -Finally flashed Stock_hboot zip.
    Reboot.
    4. WAIT FOREVER and always stuck at the white screen. After waiting about 5 min every time, I pop the battery out, try booting up again to no avail, and admit failure :(

    BUT when I wiped and tried AOSP ROMs, which is Cyanogenmod 7 and Oxygen, both latest version, I only flashed 1 zip and it worked 1st time for both. Even went back and forth after failing with RunnyMede.
    Please someone tell me what I did wrong here? Or should I wait longer for the boot? 15 minutes waiting maybe?
    Imma go back and try flashing again :}

    UPDATE: Other ROMs (ones with [blahblah]Mod007 and BlissyMede) gave me "assert failed ...etc..." errors....
    Cool3d AceS (Sense 3.0) gave same results as Cool3d Runnymede...white boot screen forever....I'm really frustrated now...please help :p
     

    Attached Files:




    1. Download the Forums for Android™ app!


      Download

       
  2. SUroot

    SUroot Extreme Android User

    I can't get beyond step 1. Mini tool is a big pile of shite. I recommend redoing that with Gparted before we go ANY FURTHER.


    It's pointless looking at any other solution until this as minitool us known by us here to look like the partitioning has worked when infact it has not.

    If anyone else posts things to try, please IGNORE THEM until you have flattened and partitioned with Gparted. It's a bit long but its the best solution by a long way.

    I recommend going the VMWare virtual machine route. Follow my step by step guide for this (linked via signature) then follow the links to an actual partition guide (one video, one step by step by me)
     
    Mr User likes this.
  3. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Just to reinforce what SUroot has written, the AOSP ROMs you've successfully flashed will work without an ext partition, while the ROMs that fail are all new Sense ROMs which require an ext partition to boot (not just for app storage, part of the ROM is on sd-ext). So a bad ext partition would fit the symptoms.
     
  4. Mr User

    Mr User Member
    Thread Starter

    Oh wow no wonder was trying to be a smartass and cut corners there (cause minitool is, well, mini compared to a ~100 MB download :)
    Will try and see. Didn't thought it was the ext partition since AOSP ROMs Quick System Info tells me I've 1 GB A2SD, PC also said that :p
     
  5. Mr User

    Mr User Member
    Thread Starter

    K this is weird....my PC can't seem to recognize the mounted sd card by my phone...the sd card is alright, could be mounted using other devices...and I don't think this a USB brick, as the USB connects fairly well as usual, both charging and to the pc. The PC recognizes my phone, says Android Phone in Devices and Printers, but in computer the Removable Storage won't show up. Tried 2 different sd cards, same failure. omg :((
     
  6. SUroot

    SUroot Extreme Android User

    Can you nandroid to your previous Rom?
     
  7. Mr User

    Mr User Member
    Thread Starter

    Nvm sorry stupid me tried to fix USB brick while a simple reinstall of HTC Sync fixed it...
    So, now I'm going back to step 1, but using Gparted this time.

    Set up GParted. In the screen now. But after selecting my phone's SD Card, the file system says unallocated and I can't resize it (option is greyed out, not click-able)
    What now?
     
  8. Mr User

    Mr User Member
    Thread Starter

    K, solved the unallocated space issue. Reformatted using my pc's disk management tool. so now i've a clean, FAT32 8 GB SD Card

    Did all the GParted. Select all new Unallocated space > New > chosed 1024 MB for my free space, FAT32 for the ~6.5 GB, primary partition > Selected 1024 MB unallocated > New > EXT4 > All done > exit out.
     
  9. Mr User

    Mr User Member
    Thread Starter

    Fck Clockworkmod cant mount SD Card...eventhough when I try to mount USB Mass Storage, it works....

    Should I try reformatting it?
     
  10. Mr User

    Mr User Member
    Thread Starter

    K reformatted the card using recovery, Clockworkmod 5, now it mounts the sd card again. But now GParted only detects 6.5 GB. This is normal. But then, I don't know if Recovery's formatting could fit with the Sense ROMs. Ironically, the GParted partitioning, the one that is proved to work with the ROMs, doesn't work with the recovery. I'm stuck now.
    Basically, when I use GParted, the Recovery couldn't mount it, it put "error mounting /sdcard" simply that, nothing else.
    I tried partitioning with the recovery. Mounts now, but as I experienced before, this wouldn't work for Sense ROMs.
    Help me pls I'm so confused.
    I'm going to flash an AOSP ROM just to be safe, and do this all over again tomorrow. It's late for me, and I've work to do.
    Thanks in advance.

    PS:SUroot aren't you the developer of the SU app in market? Nice man.
     
  11. Mr User

    Mr User Member
    Thread Starter

    So far, I
    Got a nandroid (clockwork recovery) backup ROM, clean Oxygen.
    SD Card currently partitioned by Clcokworkmod 5. Chose the 1024 MB, 0 swap.
    Gonna do this again tomorrow, but pls refer to my upper question about Clockworkmod not mounting my sd card if partitioned by GParted...and I'm kinda stuck here cos my SD Card only shows 6.5 GB of space, even on GParted, so how do I get the 1 GB partitioned part back? maybe try formatting it with another device?
     
  12. SUroot

    SUroot Extreme Android User

    you are using "mount usb mass storage" in recovery, NOT Mount /sdcard?

    No offence, but it all sounds a bit like user error (excuse the pun)
     
  13. Mr User

    Mr User Member
    Thread Starter

    i'll get this clear:
    +Partitioned with GParted, then powered off VM. Then unmount:
    -CWM mounts USB Storage successfully. PC detects, all normal.
    -But then, when I unmount in CWM, then try to install through zip files, doesn't work: "error moutinf /sd card"
    Tried USB Storage mounting again, works. Idk why :p
    +Then, I partitioned using CWM, 1024 MB, 0 swap:
    -Now, CWM works as usual, which is to say normal USB Storage and installing zips.

    IDK what I did wrong, maybe I'll try again if I have time :/
     
  14. SUroot

    SUroot Extreme Android User

    not sure, but its not obvious whats wrong. What cwm have you got by the way? sounds like one of the bad ones if it has the option to partition in the menu.
     
  15. Mr User

    Mr User Member
    Thread Starter

    CWM 5 from the official cyanogenmod website. Yeah it's true I used older versions before and kinda liked them better but couldn't find any i could trust online. Also, I read in your flashing/rooting page, you'd use CWM 2. something. I tried downloading that but it won't let me download. Can you attach it or something?
     
  16. SUroot

    SUroot Extreme Android User

    2.5.0.7 but only if your erase size is 20,000.

    It should download fine from the root tools thread. Just enter the username and password and you're away.
     
  17. Mr User

    Mr User Member
    Thread Starter

    I followed the Revolutionary guide and decided to the step tht I can use both(RA mon or something and yea CMW 2.5.0.7-srry i dont know the names since i personally prefer CMW so i never use any other)
    so I have to make an account with the server thts letting me download?
     
  18. spikyshotgun

    spikyshotgun Newbie

    No, you can get the most recent username and password from posts towards the end of the thread.
     
  19. Mr User

    Mr User Member
    Thread Starter

  20. SUroot

    SUroot Extreme Android User

    its on the last page of the thread. Its really not hard to find. I would never give it to you. Its there to stop leaching. If you cant find it, you cant download.
     
  21. Mr User

    Mr User Member
    Thread Starter

    K got the codes for flashing recovery, but do i need codes to remove the existing CWM 5?
     
  22. SUroot

    SUroot Extreme Android User

  23. Mr User

    Mr User Member
    Thread Starter

    yeah like

    "fastboot flash recovery c:/blah blah"

    but for removing the recovery i already have. i remember somewhere its

    "fastboot erase recovery"

    but i'm not sure. But do i even need to remove CMW 5 i have now or do i just flash CWM 2.5.0.7 over it?
     
  24. SUroot

    SUroot Extreme Android User

    ohhhh. Commands not codes haha.

    You dont need to erase. just flash
     

HTC Desire Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...