Help flytouch 3 doesn't see wireless or Ethernet connection


I bought a Flytouch 3 and went to android marketplace while on the Ethernet connection.
I was able to download 1 game then it wouldn't download any more.
I tried the browser but the computer doesn't see the connection.
It has the icon in the upper right showing Ethernet connection.
I tried the wireless but again it looks like it is on but doesn't see it. If I try to update the weather it says no network.

I tried holding the menu button while powering up and it went to recovery and deleted the downloaded programs but it still doen't work.

What can I try next?


Thread starter
does anything else connect on the same router.
I would try and reboot the router.

I have a desktop and laptop that does connect to the router fine.

Another (different) problem appears to be the SD card. I have tried 2 cards but they don't mount. They were not empty so maybe they need to be erased first? One was from an MP3 player and the other from my HTC cell phone with Android 2.3.


You must format the sd card on a windows machine. It MUST be formatted as fat32, not fat or ntfs. It may also be the reason your tablet is not connecting to wireless.


Do you have MAC filtering switched on.
Also are your laptop and desktop configured to a fixed ip address. It may be that the Flytouch is trying to use the same ip address as either your laptop or desktop. This used to happen with my wife's laptop until I configured my router to issue fixed IP addresses to certain machines and then anything else gets an ip address a lot higher.
Try disconnecting both machines and then connect just your Flytouch.