1. Are you ready for the Galaxy S20? Here is everything we know so far!

Flytouch 3 (SAWEE10) update

Discussion in 'Android Devices' started by crazyandroid, May 21, 2011.

  1. crazyandroid

    crazyandroid Lurker
    Thread Starter

    Hello guys,
    I'm new to the forum but I think it looks like cool :D
    Finally I got the tablet. It 's a Flytouch 3 and I must say it seems a pretty useful tool in spite of the price.
    However, there are some 'issues' that I would like to resolve and a point that it's not very clear for me. But first things first.
    The informations screen that I captured directly from the tablet is on the attachement.
    As you can see the kernel was last updated on April 30, 2011, so it is not dated. In any case, I would first resolve the fact that this version cannot display flash movies, then I heard some firmware (Tim4c) that improve the sensitivity of the touch screen, wireless reception and introduce the possibility of using the GPS with Google Maps. And then there is the fact that when I type on the keyboard appear in Chinese characters. I also noticed that the wireless connection is very bad, it frequently disconnects and it crashes when I use certain programs or reconnect the microsd. I really need to update it. Can you explain, please, how to update firmware and what do you recommend? Thank you.

    P.S. I apologize for my bad english

    Attached Files:

    1. Download the Forums for Android™ app!


  2. crazyandroid

    crazyandroid Lurker
    Thread Starter

    Nobody can help me ?
  3. eseriestv

    eseriestv Lurker

    just got the same pad, will let you know if tim works
  4. evoic

    evoic Lurker

    Strangers are watching this space anxiously. :)
  5. crazyandroid

    crazyandroid Lurker
    Thread Starter

    No tim firmware work with this tablet. I've tried every possible firmware, from the flytouch 2 to the latest ones. Now it is dead.

    To grammar: this is a good new, can you post here some old firmware for this f*ing clone ?
  6. balam6139

    balam6139 Lurker

    Just got my SP3 FT3 and have tried every firmware I can google but have no luck. The tablet recognize the update as I can see the whole updating process on the screen, did as directed and removed the sd card. When tablet restart I do not see any changes but the same as before. I have tried using different micro sd card ranging from 2GB to 32GB class 4 6 10 but still no result. Any advice? Thanks.

    Tablet info:
    Model Number: DISCO10

    Version 2.2-20110803

    Kernel Version: 2.6.32 zjd@dtlinuxserver #34

    Build: FRF85B
  7. lfc4ever

    lfc4ever Android Enthusiast

    Yes, you have to be confident enough to open the flytouch, it is quite easy, remove the crap sd card that is inside, replace with a fresh fat32 formatted new card - the bigger & higher the spec the better, and then re-assemble the flytouch, then reflash.

    Or you could re-use the internal card but you need to delete all partitions, reformat to restore its functionality to what it was and put it back - but why trust that card again when whilst you have it open you could put in a new faster, bigger card?

    The flashing will format & partition your new internal card as to hwo it should be.
  8. dart16

    dart16 Android Enthusiast

    If you have a SAWEE or a SAWEE10 tablet you cannot flash any of Tims firmware updates. You can go here
    Technical Help for SP III (Fake FT3-SP2-Clone)

    I think it is the place with the most info on these models.

    For those not aware.... there are two tf slots on a FT3, one external and one internal. The internal one is the one which holds the operating system. It quite often has a poor quality tf card fitted that seems to suffer from going read only, so when you re-flash or add apps it reverts to its previous state when you switch the tablet off. The fix appears to be open the FT3 up and replace the poor quality card with a better one and re-flash the tablet with a later firmware.
    The tf card in the external tf slot is where you place the upgrade files when you want to re-flash a DISCO or DISCO10 tablet, you will find the files here. SuperPad2 Flytouch3 Hybrid Tim Rom for SAWEE you need to go to the above link for instructions and for P041 tablets there are several threads on this forum detailing how to upgrade and where to get the upgrade files from. There appears to be a new 'kid on the block' called TAB10, there are no specific files available yet, and no-one yet knows if/how they can be updated. This model claims to be v2.3
  9. crazyandroid

    crazyandroid Lurker
    Thread Starter

    Finally I found a solution here. I think it's a good guide.
  10. pic85

    pic85 Lurker

    Hi. I have this model as well, and the problem I have is connecting the tablet to my computer. It didn't come with a usb so I order it seperately but it didn't even connect or pop up anything. What usb is the right one for it?
  11. MPSmith

    MPSmith Lurker


    A little late, but...

    I bought the Superpad III direct from a manufacturer in China. DOA. She sent me the ROM. No go. I had to disassemble the unit and replace the dead TF card. Reloaded the ROM, works like a champ...well, as good as it can work, anyway...

    I can't post a link yet, and the file is 80 megs, so if you need it, you can download it from my website, which I will spell out for you. The specs on the ROM are:

    Filename: 2.3_20110926_build_FRF85B.zip
    Android version: 2.3_20110926
    Build: FRF85B

    Get it at: ultimateliquidators dot org, slash _files


Similar Threads - Flytouch SAWEE10 update
  1. The_Chief
  2. Milo Williamson
  3. Losing My Religions
  4. 20GT
  5. ironass
  6. Jelyob
  7. luhazi
  8. Thamaraikannan S
  9. hannan012
  10. Ron Miel

Share This Page