1. Are you ready for the Galaxy S20? Here is everything we know so far!

Force app to use 3G only?

Discussion in 'Android Apps & Games' started by jamiedolan, Sep 1, 2011.

  1. jamiedolan

    jamiedolan Newbie
    Thread Starter

    I have the Nexus S. I started using Skype on it, and if I have Wifi and 3G turned on, it appears to switch back and forth as a go out of Wifi range and after a while it gives up and leaves me signed up out Skype.

    If I run in 3G only mode, it works very well and so far appears to never sign me out.

    However, 3G is pretty slow still for surfing, photo / video uploads, etc.

    Is there any hack / mod / setting so I could force Skype to always use 3G even if I have Wifi turned on?

    Thanks
    Jamie
     



    1. Download the Forums for Android™ app!


      Download

       
  2. amlothi

    amlothi Android Expert

    No, not that I know of. If you are connected to Wifi, I don't think your phone even maintains a 3G data connection. It's not as simple as making one app use it, it's more difficult as in "force phone to stay connected to 3G even when Wifi is connected at the same time".

    Your phone would then have 2 different IP addresses, and I'm not sure it's able to do that.
     
    jamiedolan likes this.
  3. mikedt

    mikedt 你好

    That's correct. Skype can't handle changing IP address while its signed in, probably because of how it works. Although I thought Skype had an 'Automatic sign in' option, so if it does get disconnected it can sign in again without any user intervention. I know the PC and Mac versions do this, not sure about the Android version.
     
    jamiedolan likes this.
  4. 2manyPHONES

    2manyPHONES Android Expert

    Yeah there should be an auto sign in option in the app. I think it's menu-settings and there is a box to check for auto sign in.
     
    jamiedolan likes this.
  5. jamiedolan

    jamiedolan Newbie
    Thread Starter

    HI;

    Thank You; Yes, I just checked and there is an auto-signin and I have it turned on. I think there must be a max_tries or something similar that kicks in after a while. I just watched it reconnect as I walked outside (which really was still in wi-fi range. But then I'll end up finding later on that one of the times it tries that, it fails to re-connect and gives up.

    Jamie
     
Loading...

Share This Page

Loading...