1. Are you ready for the Galaxy S20? Here is everything we know so far!

Forcing Apps to install to the SD Card without root

Discussion in 'Android Devices' started by El Presidente, Dec 23, 2011.

  1. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member Thread Starter

    One of the biggest complaints levelled at the HTC Wildfire S is the severe lack of internal memory. There are ways around this, one of which is forcing downloaded apps to install to the SD Card. There are a couple of pre-requisites, but the process itself is relatively straight forward. :)

    You'll need HTC Sync installed (or at least the drivers that come with HTC Sync) and ADB (Android Debug Bridge) or the Android SDK. The SDK itself is a >100MB download and can be relatively difficult to install, however if you head here, look under the section entitled Mini SDK, click show, you can download a zip file called SDK-Tools.zip. Once downloaded, extract the contents of that folder to a folder of your choosing. I recommend somewhere easy, like C:\SDK-Tools as you'll need to navigate to it via a command prompt later.

    You'll also need to enable USB Debugging on your phone, that's easily enough done by heading to Settings -> Applications -> Development -> USB Debugging. You'll get a warning message, but just ok that you'll be fine.

    Once you've done all the above, the process is as follows:

    1. Connect the Phone to the PC in Charge Only mode
    2. Open a command prompt (Start -> Run -> CMD, you'll need to run as Administrator)
    3. Navigate to the folder you extracted ADB to. In my case, the command would be "cd\SDK-Tools" (minus the quotes).
    4. Type adb devices and press enter. You should then see the serial number of your phone displayed on screen. If you don't check, that USB Debugging is enabled and you're connected in Charge Only Mode. If you get an error stating" 'adb' is not recognized as an internal or external command", it might well you've another SDK-tools folder within the original. If this is the case type "cd\sdk-tools\sdk-tools" and try again.
    5. Type adb shell, press enter.
    6. Type pm setInstallLocation 2 press enter (it's important you enter this exactly as written as it's case sensitive)
    7. Type exit, then disconnect your phone.
    8. PROFIT! :)

    You can now move apps that are already on the handset to the SD Card. Head to Settings -> Applications -> Manage Applications -> All -> Click an app -> Move to SD Card. All new apps will install to the SD Card.

    It's worth mentioning that apps with active widgets cannot be moved and a certain portion app will remain on the phones data partition, but this goes a long way to assist with the lack of internal memory!

    Pics for the ADB stuff below:







  2. Best Answer:
    Post #355 by radcore, Oct 30, 2012 (1 points)

    1. Download the Forums for Android™ app!


  3. Harish Harris

    Harish Harris Well-Known Member

    Thanks a lot for the post buddy. I will give it a try.
    It would be helpful if you post any screen shots too as i'm a beginner when it comes to android and stuff :)
    abhishekmshr22 and jamesbil like this.
  4. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member Thread Starter

    Yeah, no problem mate. I've just finished nights so I'm in need of a sleep but I'll sort something out later on today for you. :)
    chkmatr and FallOutNerd like this.
  5. GerJ

    GerJ Lurker

    Thanks for the info! Two questions, however. Does this also work with Android 2.3.5? And if installed with a previous version, did updating to 2.3.5 go withoiut a hitch??
  6. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member Thread Starter

    Yep, it should work with any Android version above 2.2. I've no idea about the upgrade though, I know I've done it on 2.3.3 but I've not upgraded to 2.3.5 yet as my handset is branded. I imagine you'd have to run the commands again after the upgrade though.
    yosoyines and FallOutNerd like this.
  7. I did all this and it all went fine except when I went to do that pm setInstallLocation 2, i copy as needed and it says ""pm " is not reconginized as an internal or external command... "

    Yeah :S

    And another question, Is it possible just to place the micro SD card as the internal memory. Make the phone believe that the micro SD card is the internal memory?

    I'm an android noob so yeah :S lmao thanks man.
  8. hpguru

    hpguru Newbie

    I got the same result but then I typed the adb commands in lower case and it worked just fine. Not sure if that was it or it just needed time to connect but it worked.
  9. what do you mean typed the adb commands in lower case. from the start? so like start over typing adb Devices... or like the install in lowercase.
  10. billbick

    billbick Lurker


    New to the forum, thanks to all for providing a site to discuss (and tweak) the Wildfire S phone. I performed all steps as described in the thread, and it seems to have worked, but when I go into Manage Applications, and try to move something (like HTC Likes, for example), the move to SD card button is grayed out. What apps have others been able to move to the SD card? Or will apps installed after this tweak be installed the SD card?

    Phone Info
    HTC Wildfire S (Virgin Mobile)
    Android 2.3.4
  11. khendeeh

    khendeeh Lurker

    how can I download HTC SYNC in to my wildfire s? It says the content is not supported on the phone. No application can be found to 9open this file.

    What to do?

  12. Kingduffy

    Kingduffy Lurker

    i have follow all steps, but when i type 'adb devices' it says 'adb is not recognized as an internal or external command'. please help me.
  13. Harish Harris

    Harish Harris Well-Known Member

    You need to download HTC Sync to your computer..
  14. karolisb

    karolisb Lurker

    Does it work with S-ON devices?
  15. xuerebx

    xuerebx Newbie

    It works! :)
  16. davejp

    davejp Lurker

    Thumbs up!!

    Cheers for that, nice one.
    kawi likes this.
  17. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member Thread Starter

    Do you still need pics? Apologies, I got a little sidetracked with the festive season and totally forgot about this. :eek:

    let me know and I can upload ASAP.
  18. Pootie Tang

    Pootie Tang Lurker

    yes please, pics would be greatly appreciated..MUCH THANKS!
  19. Harish Harris

    Harish Harris Well-Known Member

    Thanks for your reply. I think i can do it after reading the comments.
    But pics would be of more help :)
  20. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member Thread Starter

    No probs, I'll get them uploaded once I'm home from work.

    What do you need btw? Everything, or just the ADB stuff?
  21. Harish Harris

    Harish Harris Well-Known Member

    The ADB stuffs will be enough for me :)
  22. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member Thread Starter

    I'd just added pics to the post 5 mins ago! :)
  23. Harish Harris

    Harish Harris Well-Known Member

    Cool.. thanks a lot :)
  24. Harish Harris

    Harish Harris Well-Known Member

    It worked!!! My phone went from 30MB to 50MB free memory.
    And for the folks who said when they type "adb devices", it gives the message 'adb is not recognized as an internal or external command', you would have extracted the sdk-tools to C:\sdk-tools\sdk-tools. Even i did the same. So you need to type "cd\sdk-tools\sdk-tools" in the command prompt. Hope this helps some one :) .

    But i still need to move Gmail and Facebook to the SD card. But sadly i have to root my device to do that :(

    Thanks again el presidente for your help.. cheers! :)
  25. hytekk

    hytekk Lurker

    Works great! Thank you very much!!!!
  26. Sash1

    Sash1 Newbie


    Can anyone help as I dont know what I am doing wrong.

    I saved mines in the default download so when I type mines I put
    'downloads\sdk-tools\sdk-tools\adb device' after c:\user\**** and thats fine it brings up that killing and shows me the serial number, Im confused as what to do next as the prompt screen goes back to c:\user\**** and then when I type adb shell it does nothing and says that not recognise stuff etc

    I have different variations off trying to type adb shell but not getting anywhere passed this stage.

    Can anyone help?

  27. radcore

    radcore Lurker

    Hey there. Great instructions and I don't doubt this works. However, after trying to go through these steps multiple times and knowing that I have done everything to a T, I am still not able to transfer apps to the SD card via Manage Applications. Move to SD as an option is still greyed. I did the command pm getInstallLocation and the prompt tells me it is located on the external, not the internal. So everything worked, the phone is just not allowing it.

    I am using a HTC Wildfire. Model number is HTC-A510a. Android version 2.3.3 and HTC sense version 2.1.

    Any help would be great as I am out of space, even after clearing caches and uninstalling updates.

HTC Wildfire S Forum

The HTC Wildfire S release date was May 2011. Features and Specs include a 3.2" inch screen, 5MP camera, 512GB RAM, Snapdragon S1 processor, and 1230mAh battery.

May 2011
Release Date

Share This Page