1. Are you ready for the Galaxy S20? Here is everything we know so far!

Forcing Apps to install to the SD Card without root

Discussion in 'Android Devices' started by El Presidente, Dec 23, 2011.

  1. oralover2006

    oralover2006 Newbie

    hi,

    I have HTC Wildfire S 510e Marvel and am here for guidance to use / upgrade my phone smartly to get much benefits.
    I have Installed HTC Sync on my PC, on my mobile I have CM10.1 (OWLPROJECT) and Link2SD ( phone is S-OFF and Permanently Rooted ), it has 8gb SD Card with 2 Partitions FAT32, one is 6gb another one is rest of space.
    Now as I want to use second partition as Internal Storage, I tried to follow the instruction here, downloaded mini-SDK and extracted all files in C:\sdk-tools, using cmd i issued command
    c:\sdk-tools\adb devices
    and it shows me
    List of devices attaced
    xxxxxxxxxx offline
    when issued command
    c:\sdk-tools\adb shell
    it is showing error:
    error: device offline

    what i have to do ? i am stuck here and looking for your guidance, plesse help me.

    with best regards.


    Sorry for inconvenience, it was my fault, when i saw my phone it was asking me to Connect always on this computer with some kind of computer identity, when pressed OK and run command c:\sdk-tools\adb shell again, it worked. and i completed another steps successfully !!Thanks very much President for a great guidance, now going to install new app, i have only 22mb free as internal memory :(


     



    1. Download the Forums for Android™ app!


      Download

       
  2. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member Thread Starter

    I'm not sure how the process works with rooted devices running custom ROMs, especially if you're using Links2SD. Couldn't you resize one of your partitions?
     
  3. oralover2006

    oralover2006 Newbie

    First thanks very much for your reply and again for great guidance.

    as i mentioned after edit my post, the problem has solved, my phone was
    asking to permit or not to connect to PC with my PC's ID (dont know
    what was it ).

    I informed about my Phones current status / configurations it have to
    give maximum info. after your great guidance i have uninstalled Link2SD
    and install MoboPlayer from store and yes its codec also which comes
    seperately, but when checked MoboPlayer was installed in Internal
    Memory and Codec by default installed in SD Card ( becoz of as per your
    instructions i have issued command pm set-Install-Location 2 ) but
    surprised that it not worked for MoboPlayer itself and I moved it
    manually to SD Card and it moved successfully and i noticed the effect
    on my internal storage.

    one thing to ask, in your method it is necessary one have two
    Partitions on SD Card ( as usually gurus told that Second Partition is
    necessary to install all user applications )? and what the size you are
    recommending for us as also you are asking to RESIZE Partition. ( I
    have plan to reinstall every thing from scratch to get maximum benefits
    from your guidance ).

    Thanks very much for your concerns.
    Regards.
     
  4. slinkykc

    slinkykc Lurker

    Viva la Revolution gracias mucho gracias El Presidente! 3 attempts and 20 minutes later Arriba Arriba Vamanos!!!
     
  5. ArunCloud

    ArunCloud Lurker

    Great post. However, I'm still trying to get it to work on mine. For some reason, I cannot see the HTC serial when I type "adb devices". I wonder what I am doing wrong.
     
  6. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member Thread Starter

    Have you made sure USB Debugging is enabled? Is HTC also running in the background (You need to make sure it's closed)?

    What does it say when you type ADB devices?
     
  7. ArunCloud

    ArunCloud Lurker

    With the previous version of HTC Sync (the one that came with the mobile), I get the following when I type adb devices:

    * daemon not running starting it now at port 5037 *
    * daemon started successfully *
    list of devices attached

    With the new version of the software, I only get "list of devices attached".

    Yeah, it's enabled. I have tried doing the whole processs with USB Debugging enabled before even connecting the phone to the PC as well as I have also tried doing it by enabling USB Debugging when I get to Step 4 of the instructions posted.

    And, no, I don't have HTC Sync running in the background.
     
  8. Wyger

    Wyger Lurker

    Worked for me, im a beginner at this, dont know what rooting etc is, but this was without a hitch. big thanks for finding this elegant solution, saves me buying a new phone. i'll come here more often... cheers, Wyger.
     
  9. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member Thread Starter

    Welcome to AF Wyger, glad you found the guide useful. :)
     
  10. kaishrose

    kaishrose Lurker

    It worked like a jet. This is an awesome effort.
    I appreciate the skill showed here.
    Tutorials are pretty descriptive and straight forward.
    Images helped in executing the task easier.
    Thanks a ton...
     
  11. popap15

    popap15 Lurker

    Hey! Been trying to get this to work and I have the strangest problem. I do everything correctly, get the final $ sign, exit the CMD prompt, but it did not work. I disconnect my phone and it seems as if the settings didn't change at all. Can't move apps, downloading new apps still puts it onto the internal storage. I run the pm getInstallLocation command and I am told "2" however the settings remain unchanged. Anything I can do?
     
  12. milsoles

    milsoles Lurker

    thank you so much! i have been struggling the last three days to fix this. just never never try to do it on a mac, its impossible. ask somebody with Windows and it will do in 5 min.
     
  13. MattThomas

    MattThomas Lurker

    Thank you so much! I've been struggling with memory on my phone for ages, decided to give this a go even though I'm usually crap at this kind of thing but it actually worked :D thank you!
     
  14. great! thanks a super ton for this share.....
     
  15. tfranks75

    tfranks75 Lurker

    I have tried to follow all of these steps but when ever I plug the phone in I never get the option to charge only. btw I have a htc desire 510
     
  16. speem

    speem Newbie

    Thanks for your question ,I can try to reply.the storage in the settings - applications is fake ? You know that?
    Best way is to check the actual storage in settings
     
  17. titusxp

    titusxp Lurker

    Well I don't know about all these but I just use Mobogenie to install apps automatically to the SD card
    of my HTC wildfire S and it works well
     
  18. saed george

    saed george Lurker

    Hey , i have done all the steps and i got the attached pic, but still, whenever i want to download it gives me that there is insufficient space , please help me !

    PS: i tried to type the letters as what you showed, it's not working , so i typed it like this ---> "adb shell" then i pressed (enter) then "pm set-install-location 2"

    and to make sure i ran the command "get-install-location"

    as the attached, it's showing external 2


    anyway , please help me
     

    Attached Files:

  19. nskblogs

    nskblogs Lurker

    Good day.

    I tried all the steps and results show as successful as below, however when I try to move/install new app phone gets rebooted. Can someone suggest a resolution ASAP? Thanks in advance.

    c:\sdk-tools>adb devices
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached
    <slno> device

    C:\sdk-tools>adb shell
    $ pm setInstallLocation 2
    pm setInstallLocation 2

    $ pm getInstallLocation
    pm getInstallLocation
    2[external]

    Phone details
    HTC Wildfire s
    android2.3.3
    HTC Sense version 2.1
    software number 1.35.720.3
    Available space internal storage - 14.45mb
     

HTC Wildfire S Forum

The HTC Wildfire S release date was May 2011. Features and Specs include a 3.2" inch screen, 5MP camera, 512GB RAM, Snapdragon S1 processor, and 1230mAh battery.

May 2011
Release Date
0
Reviews
Loading...
Similar Threads - Forcing Apps install
  1. Romecasa
    Replies:
    7
    Views:
    772
  2. npuleio
    Replies:
    0
    Views:
    1,283
  3. App Update
    Replies:
    0
    Views:
    461
  4. App Update
    Replies:
    0
    Views:
    2,647
  5. behrprofl
    Replies:
    6
    Views:
    2,107
  6. App Update
    Replies:
    0
    Views:
    688
  7. elzbone
    Replies:
    9
    Views:
    3,666
  8. merthkm
    Replies:
    1
    Views:
    879
  9. muddlemand
    Replies:
    41
    Views:
    6,712
  10. Are21
    Replies:
    3
    Views:
    1,313

Share This Page

Loading...