1. Download our Official Android App: Forums for Android!

Support Found two bugs with 2.2

Discussion in 'Android Devices' started by Totenglocke, Aug 4, 2010.

  1. Totenglocke

    Totenglocke Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Aug 4, 2010

    Aug 4, 2010
    9
    0
    5
    I found two bugs - one major, one less severe.

    The major bug is that the Mail app (not GMail, the Mail app that HTC put on the phone) does NOT connect to gmail when the phone is on 3G (no 4G in my area so I can't test that). It will only connect to gmail when the phone is on WiFi.

    The other bug is that sometimes the Marketplace doesn't show any apps that I've downloaded. I've never found a for sure way to make them appear, but it usually takes rebooting the phone.

    Any ideas? I've already done a factory reset due to people on here claiming it would fix most issues (all it did was succeed in wiping my contacts, which are NOT automatically backed up to you google account, despite what people claim).
     

    Advertisement

  2. htcevolee

    htcevolee Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    255
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
    1. Just wondering why use the mail app over GMAIL app for a GMAIL account?

    2. In the market hit "menu" button then "Downloads".
     
  3. Totenglocke

    Totenglocke Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Aug 4, 2010

    Aug 4, 2010
    9
    0
    5
    1) Because the Mail app is much better. The GMail app is extremely primitive and nowhere near as polished.

    2) I'm well aware of where they're located, thanks. Nothing shows in the list but google maps.
     
  4. EarlyMon

    EarlyMon The PearlyMon
    Rank:
     #1
    Points:
    5,218
    Posts:
    57,632
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    57,632
    70,424
    5,218
    New Mexico, USA
    I don't bother with the GMail app. Its only apparent advantage to me is to have instant notification of emails. The advantage of Mail is just the fusion of all email into one app. Pretty handy. Our bandolero may have other needs, tho, just speaking for me.

    I am surprised about the factory reset not curing things.

    Be sure though that you do have Background data and Auto-sync on under Settings -> Accounts & sync - or go to that area, and hit sync all.

    Totenglocke - Welcome to the forum!
     
  5. Totenglocke

    Totenglocke Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Aug 4, 2010

    Aug 4, 2010
    9
    0
    5
    It's on. If it wasn't on, it wouldn't work under WiFi :)

    I'm a little irked that after waiting for 2.2 that they decided not to test their freaking code. Is there any way (short of a ROM) to roll back to 2.1 until they finally fix 2.2?
     
  6. htcevolee

    htcevolee Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    255
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
    I hate to say it but maybe a hard reset may fix the issue?
     
  7. EarlyMon

    EarlyMon The PearlyMon
    Rank:
     #1
    Points:
    5,218
    Posts:
    57,632
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    57,632
    70,424
    5,218
    New Mexico, USA
    We originally anticipated that (rolling back to 2.1), but no one seems to have found a way yet.

    If anyone does, it's almost a certainty it's going to be these guys first:

    EVO 4G Q&A - xda-developers
     
  8. GODMODE

    GODMODE Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    197
    Joined:
    Oct 15, 2008

    Greetings, brother. Where are you 3G'ing in from? (Where do you live). Also, what carrier?
     
  9. Totenglocke

    Totenglocke Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Aug 4, 2010

    Aug 4, 2010
    9
    0
    5
    I already did that and it didn't change anything.

    Cincinnati - and it's on Sprint, just like everyone with an Evo. :)
     
  10. Totenglocke

    Totenglocke Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Aug 4, 2010

    Aug 4, 2010
    9
    0
    5
    Ok, so this is odd. I'd found at least half a dozen other people on forums who had the same problem I had. After resetting my phone I still had the issue (Mail only works on WiFi, "login failed" on 3G) and all of the sudden it's magically working.
     
  11. EarlyMon

    EarlyMon The PearlyMon
    Rank:
     #1
    Points:
    5,218
    Posts:
    57,632
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    57,632
    70,424
    5,218
    New Mexico, USA
    As it turns out, I've heard of at least one report tonight that the google servers were not responding to syncing at all.

    So, rather than this being something directly related to 2.2, it sounds more like once after you did your reset and started expecting service, you ended up hitting the coincidental window that made it look like your phone's fault - when it was Google's or Sprint's - or someone else along the line in the backbone.
     
  12. Totenglocke

    Totenglocke Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Aug 4, 2010

    Aug 4, 2010
    9
    0
    5
    I don't know. I got the update to 2.2 on monday night (so two days ago) and this started happening the INSTANT I installed 2.2. I had no problems when on WiFi, only on 3G, so that sounds more like a phone issue than a server issue. I know that I'd had Gmail not connect with Mail on my Evo before briefly and I'd had the same thing happen from time to time back when I had an iPhone 3GS - however, when it happened before, it happened regardless of how you were connected to the internet.

    I'm not sure what happened to fix it, all I know is I'm happy it's working!:D
     
  13. Totenglocke

    Totenglocke Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Aug 4, 2010

    Aug 4, 2010
    9
    0
    5
    *sigh* And it stops working again.......this is getting old, fast.
     
Tags:

Share This Page

Loading...