1. Download our Official Android App: Forums for Android!

Free VoIP Calling Using Google Voice + Sipdroid

Discussion in 'Android Apps & Games' started by lexluthor, Jan 6, 2011.

  1. dwl

    dwl Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 21, 2011

    Feb 21, 2011
    2
    0
    5
    great write-up derek2079. thanks! I was able to do VOIP calls over sipdroid, outgoing and incoming without problem; but one thing missing is the caller ID. All my outgoing calls through sipdroid+GV are shown as "out of area". Is there any setup I should change to make it show up as GV number?
     

    Advertisement

  2. gcobb

    gcobb Android Enthusiast
    Rank:
    None
    Points:
    58
    Posts:
    425
    Joined:
    Nov 18, 2010

    Nov 18, 2010
    425
    23
    58
    Southaven, MS
    When I registered with Sipdroid, it only allowed a certain amount of minutes before requiring someone to purchase minutes....Not Free.
     
  3. mj56gt

    mj56gt Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 22, 2011

    Feb 22, 2011
    2
    0
    5
    I successfully set up my phone with the OP's instruction and made some phone calls. However, after flashing the phone today, I lost most of the 3rd-party applications. So I had to reinstall everything. Now my problem is that it does not allow to create a new PBX account with my original Google Voice account: it complains that a trunk has already been existing. What can I do? Anyway to get around this? Or do I have to create a totally new Google Voice account?
     
  4. paulhusker

    paulhusker Newbie
    Rank:
    None
    Points:
    16
    Posts:
    36
    Joined:
    May 5, 2010

    May 5, 2010
    36
    2
    16
    Do you know how many minutes you used before they started wanting to charge? That's something I had never heard about before.
     
  5. paulhusker

    paulhusker Newbie
    Rank:
    None
    Points:
    16
    Posts:
    36
    Joined:
    May 5, 2010

    May 5, 2010
    36
    2
    16
    That's odd. When I called my GV # via Sipdroid, it showed the phone # w/ a 1 in front of it on the Caller ID.
     
  6. gcobb

    gcobb Android Enthusiast
    Rank:
    None
    Points:
    58
    Posts:
    425
    Joined:
    Nov 18, 2010

    Nov 18, 2010
    425
    23
    58
    Southaven, MS
    It stated I had 60 total to use.
     
  7. dwl

    dwl Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 21, 2011

    Feb 21, 2011
    2
    0
    5
    After numerous trial and error, I finally figure out what's going on. If I have GV voice setting (from the webpage) with Caller ID(incoming) set with "Display caller's number", my outgoing calls from android phone to my landline, for example, always show "out of area" on my landline. And my incoming calls from my landline to android phone can display my landline's caller ID properly. And if I have Caller ID(incoming) set with "Display my Google Voice number", my outgoing calls from android phone to my landline can now have GV's number shown up properly on my landline, but my incoming calls from my landline now always show up with GV's number. And playing around "Caller ID(outgoing) field makes no difference.

    I would like to have Caller ID showing up on both sides of phones properly, I guess I can only get one to work correctly, too bad! Is this what people on the forum expect to see?
     
  8. svh105

    svh105 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    16
    Joined:
    Apr 29, 2010

    Apr 29, 2010
    16
    0
    15
    I have sucessfully set up the SIPdroid / GV combination, however when I receive an incoming call both SIPdroid dialer & my phone dialer ring. If i answer the SIP dialer, nothing happens. When I answer the phone dialer, it acts like a normal call.

    Thoughts?
     
  9. riffdex

    riffdex Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    730
    Joined:
    Jan 28, 2010

    Jan 28, 2010
    730
    32
    68
    The reason it calls both is because you have Google Voice set up to forward to both your cell phone number, and to your chat account (which is how it gets to SIPDroid). You can just ignore the cell phone call and answer the SIPDroid one if you are connected to WiFi. Of course, if you have tried answering the SIPDroid and it is not working, you may not have set it up right.
     
  10. mj56gt

    mj56gt Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 22, 2011

    Feb 22, 2011
    2
    0
    5
    I've set up my phone working with GV+Sipdroid in the U. S.. Anyone know whether it would still work if I go to Canada?
     
  11. NYGIANTSFAN

    NYGIANTSFAN Lurker
    Rank:
    None
    Points:
    25
    Posts:
    2
    Joined:
    Feb 26, 2011

    Feb 26, 2011
    2
    0
    25
    Works like a charm, thanks!
     
  12. bryanheath

    bryanheath Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    103
    Joined:
    Oct 21, 2009

    Oct 21, 2009
    103
    10
    38
    Sys Admin
    Does this work with BT headsets? Good find!

     
  13. fungo45

    fungo45 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    24
    Joined:
    Mar 1, 2011

    Mar 1, 2011
    24
    1
    16
    Chicago
    I've tried a couple times to get this up and running with no success.

    A couple things I've noticed in my attempts. First, when creating the pbx account through sipdroid, there are boxes for my gmail password, but not one to create a pbx password. Looking at the pbxes.org site, I can log in and see that they've created a random password for me. Shouldn't matter, but thought I'd bring it up.

    Secondly, one of the earlier posts mentioned that you have to have Google Talk installed on the phone. I don't and can't find it in the market. I assume he meant Google Voice, but thought I'd ask.

    Everything looks to be in order based on all the posts here, but I can't get pbxes to register on the phone. On the top of my home screen (notification bar?) I see a yellow dot that says it's registering, then it goes to red Registration Failed (timeout).

    Not sure where to go next.

    I've deleted my pbxes account and uninstalled Sipdroid, and then started over, but get the same results.

    Any suggestions? Thanks!
     
  14. paulhusker

    paulhusker Newbie
    Rank:
    None
    Points:
    16
    Posts:
    36
    Joined:
    May 5, 2010

    May 5, 2010
    36
    2
    16
    Yes, you must have Google Voice and have received a Google Voice #.

    Re: the password---enter what your gmail password is. (Some people might get nervous giving someone like pboxes their gmail password & you may get a security alert from gmail, but it is necessary for this trick to work.)
     
  15. fungo45

    fungo45 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    24
    Joined:
    Mar 1, 2011

    Mar 1, 2011
    24
    1
    16
    Chicago

    I do have Google Voice set up on my phone and online. Just not Google Talk, which seems to be a IM application.

    Regarding the password, I did enter my Google Voice password, I was just pointing out that there was not a third box to create a PBXes password. But when I log into the PBXes.org account, it shows a new password that looks like was automatically generated.

    I'll try changing that to my gmail password (on the PBXes site and on the Sipdroid settings) to see if that makes a difference.

    Thanks
     
  16. fungo45

    fungo45 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    24
    Joined:
    Mar 1, 2011

    Mar 1, 2011
    24
    1
    16
    Chicago

    Making some progress here, but still not able to make calls. I changed the password as described above, and now I get the green light telling me that Sipdroid/PBX is registered.

    So I made a call, and it looks like it starts to work. But the phone I called (my office phone) never rings, and then after about 5 seconds, the Sipdroid dialer goes from green to red and the call ends.

    BTW, I've set up Sipdroid to work over 3G and wifi, and the signals on both seem good.
     
  17. jj2me

    jj2me Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    161
    Joined:
    Feb 19, 2011

    Feb 19, 2011
    161
    29
    43
    Sounds exactly like what I went through yesterday. Did the uninstall-re-install. It worked until I fiddled a bit. Then I spent half a day to get the green light for registered. The second half of the day was dedicated to getting rid of the two-second hangup.

    My pbxes login was the same as my gmail login.
    My SIP account in the sipdroid app is [my-gmail-login]-200 (the pbxes extension). My SIP account password is, I believe (too much fiddling yesterday to be certain), the generated password in my pbxes Extension. It should have been pre-populated anyway. I just know because password was a field I fiddled with.

    Oddly, what got me going was a change in sipdroid under my SIP account, to check all three of "Use WLAN", "Use 3G", and "Use Edge". Previous to that I only had "Use WLAN" checked, because that's all I was interested in. I can't be sure that wasn't just a coincidence, because I was changing to have sipdroid use another, new gmail/google voice account, so it might have instead been a matter of timing, where pbxes and Google finally got their databases updated at that moment. But the expert at this thread in post #284 recommended it, so that's why I did it. Voila, success.

    Your PC's Google Voice "Voice Settings" under "Phone" needs to have Google Chat checked as a "forward to", but you probably know that.
     
  18. fungo45

    fungo45 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    24
    Joined:
    Mar 1, 2011

    Mar 1, 2011
    24
    1
    16
    Chicago
    Thanks. Still doesn't work fully, but I'm getting there! The green light still comes on showing that I'm registered to PBXes, and I'm able to dial out, but I immediately get a recorded message telling me that the call can't be completed as dialed.

    I'll keep trying. Thanks
     
  19. jj2me

    jj2me Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    161
    Joined:
    Feb 19, 2011

    Feb 19, 2011
    161
    29
    43
    I was hoping I wouldn't have to suggest reading this entire thread on the subject on the DroidX forum like I did (unfortunately, I had to go through 29 pages to find something that worked for me). The OP there has been wonderful, answering everyone's questions.
     
    Snow02 likes this.
  20. lil_wayne99

    lil_wayne99 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jul 22, 2010

    Jul 22, 2010
    2
    0
    5
    what did u do to fix it. thats a long thread. im having the same problem. but i did try to use titanium back up to restore mine now it still gives me the same problem though.

     
  21. PSkeptic

    PSkeptic Android Expert
    Rank:
    None
    Points:
    78
    Posts:
    905
    Joined:
    Jan 10, 2011

    Jan 10, 2011
    905
    97
    78
    IT Project Manager
    Buffalo, NY USA

    Put a +1 in front of the number. Does it work if you do that?
     
  22. jj2me

    jj2me Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    161
    Joined:
    Feb 19, 2011

    Feb 19, 2011
    161
    29
    43
    My sipdroid symptom was immediate hangups after dialing. The last thing I did before it started working was to change, in sipdroid under my SIP account, to check all three of "Use WLAN", "Use 3G", and "Use Edge". Then I tried again and it worked, no hangups. Nevertheless, I'm still not sure that's what fixed it, because on a previous day when it worked, I only had "Use WLAN" checked. As explained in an earlier post, in my situation it might have instead been a coincidence, because I had made changes a few hours earlier to Google Voice and to my pbxes account to have a new Google Voice number. Maybe the two databases finally caught up at that moment, I don't know.
     
  23. jj2me

    jj2me Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    161
    Joined:
    Feb 19, 2011

    Feb 19, 2011
    161
    29
    43
    Now I'm wondering if you aren't having trouble with your SIP account password (in the sipdroid app).

    This post gives details.

    Essentially,
    These username/password values are all the same:
    = Google gmail
    = Google Voice
    = pbxes.org login [Note 1]
    = what's listed at pbxes.org/Trunks/GTALK/[yourGmailAddress]

    These two Authorization Username and password values are the same:
    = pbxes.org/Extensions/Sipdroid<200>
    = sipdroid app under Settings/SIP Account

    That last item is possibly the problem. It is originally auto-populated, but Password may possibly change. Worth a shot, especially before you uninstall/re-install.

    [Note 1] exception: if you started a pbxes.org account under a different Google Voice number, then the pbxes.org login would be for that original Gmail/Google Voice account. This would be true if you followed Post 1 in the link above (which sends you to Post 36), to use a separate Google Voice account from your main one because you have privacy fears due to the username/password being stored in the clear (under your password) at pbxes.org (under Trunks/GTALK).
     
    telek and lil_wayne99 like this.
  24. lil_wayne99

    lil_wayne99 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jul 22, 2010

    Jul 22, 2010
    2
    0
    5
    thanx for the help. i forgot i had changed my gmail password the other week. i hadnt used this sipdroid since then. that fixed my out bound call problem. i can now make out bound calls but cannot recieve them. i went in and changed the pbxes trunk to the one that is the same as my the google voice account i was using but that made it so i had no out or in bound calls. so i just changed it back to the same one as my gmail account onthe phone. which gives me outbound calls. but no inbound calls. i looked at the link u put up and followed the directions. didnt work for me. thank u for ur time and help i give up. and will jsut deal with it like it is. it would have been nice to have it working as i have no phone service at the moment. but for the most part i dont like talkingon the phone anyway. i can txt with google voice.

     
  25. RazzMaTazz

    RazzMaTazz Android Expert
    Rank:
    None
    Points:
    173
    Posts:
    1,392
    Joined:
    Jan 28, 2011

    Jan 28, 2011
    1,392
    498
    173
    Before anyone tells all of their friends, family, and business contacts to start using their Google Voice phone number, keep in mind that Google has indicated that they will start charging for those numbers next year. So depending on Google's pricing, you may end up telling everyone to start calling you at your real phone number in January 2012.

    I'd like to be able to flip a switch so that Sprint would forward my calls to a SIP account when I'm overseas in WiFi coverage. I don't even care if they debit it against my minutes. I'd just like for the phone to be used internationally.
     

Share This Page

Loading...