1. Are you ready for the Galaxy S20? Here is everything we know so far!

FRG01B and FRG22 - Wifi Problems

Discussion in 'Android Devices' started by Brettus, Aug 9, 2010.

  1. Brettus

    Brettus Newbie
    Thread Starter

    I recently went from Stock 2.1 to Pete's FRG01B. At that point, DoggCatcher, my podcasting program was not able to download full podcasts, and Xiaa (?) Live (DroidLive) was no longer able to stream audio feeds for a long period of time. The browser would intermittently show a 404 error. Looking at the status bar, my Wifi would sometimes drop off and then come right back on.

    So, I noticed FRG22 was released and decided to change to that - same problem.

    The strange thing is that some routers are good and have no problem, but the one at my house (Which is an Apple Airport Extreme N) is not working correctly. All other devices in my house work fine (Xbox 360, Roku box, two laptops, etc.).

    Is this a known issue? Any suggestions other than trying the non-rooted stock 2.2? Any help would be great as I would love to get this working, I am destroying my 3G bandwidth at the moment.

  2. droid9

    droid9 Lurker

    You might try a custom ROM like the latest Cyanogen, Lithium, Chevy SS, or Sapphire. These ROMs I know have a "50% signal loss" wifi fix (by Koush I think) that solved the router/wifi
    problems I've had with every leaked/OTA stock 2.2 ROM including FRG22.
  3. ShuttleXpC

    ShuttleXpC Newbie

    I've used XiiaLive since before I was rooted and I can tell you its nothing to do with a custom ROM that is causing signal loss. The app just really isn't that great. I cannot speak for the other things, but I was running 2.1.1 before I rooted the Droid I am on now and the connection problems XiiaLive had before are still exactly the same after. The thing won't stay connected, and it seems to be a problem with the connection itself, but I'm no expert to call either or on this issue.

    I can't speak for the other app though, no experience with it.
  4. Brettus

    Brettus Newbie
    Thread Starter

    Droid9 - out of all the other ROMs you mentioned, which do you recommend the most?
  5. droid9

    droid9 Lurker

    Chevy's SS 4.6 is my favorite but I tried and liked them all. Good luck -- it's definitely worth a try since you're already rooted.
  6. gnath9

    gnath9 Android Enthusiast

    you may want to try a new"Froyo" kernel .... Its worth a try as some of the older ones had wifi issues.
  7. midax

    midax Newbie

    I'm in the same boat. First did the upgrade to FRG01B and lost WiFi. Actually it cycles thru scan, connect, disconnect, ... So I did the upgrade to FRG22 and now I'm rooted but the WiFi still acts the same. So its 3G or nothin. My router is good and worked fine with the droid until the upgrade.

    Is there any easy way to revert to the old 2.1 and just wait for the OTA upgrade? Or do I need to experiment further with the ROMs or whatever was posted earlier? Where do you find those files?

    I'm kicking myself here for not being more patient.
  8. Brettus

    Brettus Newbie
    Thread Starter

    Midax, you can use RSDLite and a 2.1 sbf file to get back to the stock 2.1. I use this as a fail safe in case I my rooting fun gets really out of hand.

    See this post: http://androidforums.com/all-things-root-droid/136508-guide-all-things-root-related.html

    Find the section titled "How to revert back to stock 2.0, 2.0.1, or 2.1", it will tell you all you need to know. Using this is great because it gets your phone back to a true factory state (as long as your format your SD card too). Be careful, it can go wrong if you don't follow the directions.
  9. midax

    midax Newbie

    Here is a guide.
    A. A stock sbf file
    2.0 VZW_A855_ESD20_QSC6085BP_C_01.3B.01P_SW_UPDATE.sbf
    2.0.1 VZW_A855_ESD56_QSC6085BP_C_01.3E.01P_SW_UPDATE_03. sbf
    2.1VZW_A855_ESE81_QSC6085BP_C_01.3E.03P_SW_UPDATE_02. sbf

    B. http://androidoverdrive.com/downloads/RSDLite4.6.7z (RSDLite 4.6)

    C. Current Motorola Drivers

    Make sure you download the correct drivers for your system either 32bit or 64bit

    1. Download all of the files above including the 32-bit OR 64-bit Motorola USB Drivers.
    2. Install RSDLite AND the 32-bit or 64-bit Motorola USB Drivers (Depends on your system most will need 32-bit some will need 64-bit)
    3. Connect your phone to USB and turn it off then turn it back on, while your phone is booting hold up on the DPAD. (Some users have said it is easier to hold the volume down button and camera button instead.)
    4. Run RSD Lite 4.6 as Administrator (For all you Vista and 7 folks out there. If you are using XP you may not need to run as Administrator)
    5. Click the ... next to the filename box and browse to where you saved the .sbf file and double click the .sbf file.
    6. Hit start and below it should give you completion progress and all of that.
    7. Once your phone is done being flashed (It may take a while so don't unplug it) it will reboot and you will be back at stock 2.0.1 no root.
    8. Done

    Brettus, thanks.
    I found the instructions (copied above). I already had the latest USB driver and RSD Lite installed so all I need is the 3rd .sbf file (ESE81) to get back to 2.1 stock?? It seems too easy. Are there any other issues I should be aware of (other than getting un-used to the improvements of 2.2)?
  10. johnlgalt

    johnlgalt Antidisestablishmentarian

    Be careful, the 2.1 file was not downloading yesterday and a few mirrors that I had were also not working correctly - the file would not work in RSDLite for whatever reason.
    ^-- Hidden because it no longer applies.

    If you're having WiFi issues, before you do all this drastic stuff, try performing a factory reset and letting all our settings start out from scratch again - it has helped a few people who have upgraded to FRG01B as well as FRG22.
  11. OMJ

    OMJ Bazinga

    I reuploaded and changed the link yesterday
  12. johnlgalt

    johnlgalt Antidisestablishmentarian

    Ahh, thanks for that. Let me change my post then.
  13. midax

    midax Newbie

    I did the factory reset (after backing up all my apps with Astro & Titanium) and did the *22899 and reinstalled all my apps. I'm getting a somewhat better wifi, but it still doesn't seem stable.

    BTW my specs show: version 2.2, Build FRG22, Kernel android- build@apa26 #1, Baseband C_01.43.01P

    Any ideas?
  14. capndroid

    capndroid Newbie

    Having SSID broadcast turned off seems to have been a problem for a few people, turning it on solved my wifi cycling issue.
  15. midax

    midax Newbie

    Today my droid seemed to have no problem connecting with the free wifi at a restaurant, so I thought the problem might just be my home wifi.

    I went into my wifi router and saw that it was broadcasting SSID already, but noticed there was a firmware update for it, and thought, here's a great opportunity to screw up not just my phone, but my whole internet wifi at home. I tried it - it worked! Yeah!

    Bottom line: the router firmware seemed to improve things so my droid now seems OK with wifi and everything else after the force to FRG22.

    Thanks to all who offered their help. :)
  16. djembeman

    djembeman Well-Known Member

    Enabling SSID Broadcast definitely fixed my WiFi fluctuations. What was funny about my problem was that I don't have any degradation of WiFi signal even-though the WiFi notification shows only 1 dot and where you select your WiFi network it kept going from "poor" to "excellent."

    Even weirder, I Disabled SSID broadcast again and WiFi signal was showing normal until I turned WiFi off on my Droid again. Today when I got home from work I already had WiFi turned on and my WiFi was showing completely normal. I had to test it, so I turned WiFi off and on again and I'm only getting 1 dot again.

    So, if I already have WiFi turned on before I'm in range, the phone has no problems. It's extremely weird. I'll just leave SSID Broadcast disabled, I like to have as much security as possible, and it seems to be more of what displays... not actual connection.
  17. richiedadd

    richiedadd Lurker

    Verizon already stated that the new Froyo will not have Hot spot or tethering capabilities. Just look in the Android Market and you will find an app that will let you use wifi once again.
  18. Brettus

    Brettus Newbie
    Thread Starter

    I downloaded ROMManager from the Market, and installed the CyanogenMod 6 RC2, and all of my Wifi problems have gone away. Thanks for the suggestions.
  19. skiahh

    skiahh Well-Known Member

    Here's an odd one for consideration. My Droid was working fine on my home network (wifi) until I updated to 2.2. Then no joy. It'll connect with open networks at restaurants but not here.

    I've changed the router to be completely open and still nothing.

    Well, it's more than nothing... it will get to the "Obtaining an IP address from XXX" and then it times out. I've "forgotten" the network and re-entered it, verified all the settings, done multiple battery pulls and done a factory reset.

    On the router, I've tried broadcasting the SSID, set it to completely open, set it to B+G only (It's an N router) and B+G+N and G+N (where it was before the problems began). I've restarted the router and re-entered the passcode there to make sure they're all matching up. I have 2 laptops and a Blackberry Curve in the house that all connect to the wifi network just fine.

    So, what am I missing? Why will my 2.2 droid not connect to by Belkin router??

    I messed with the channels on the router... I tried Auto and two fixed channels, all with the same results. Can I change the Droid's channel and if so, how? I'll give it a try even though I don't think that's it since the Droid is connecting... just not accepting the IP the router assigns it.

    I can see the Droid on the router with a client name of android_cf9e9946
  20. Lock-N-Load

    Lock-N-Load Android Expert

    I have had wifi issues similar to skiahh, the Obtaining an IP address from XXX while WiFi Analyer sees my wireless, the Droid sees my wireless but it would just show Obtaining an IP address from XXX & not connect. I have never figured out why as it seems so random but when it last happened I do recall my modem was losing it's signal - something with Time Warner - off and on for a few hours and so I finally got the Droid to find the IP when I rebooted modem, router, wireless and viola... wifi was found on Droid again.

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date

Share This Page