1. Check out our companion app, Forums for Android! Download from Google Play

Support Fried GPS chip from overclocking?

Discussion in 'Android Devices' started by roscko, Mar 29, 2010.

  1. roscko

    roscko New Member
    Thread Starter

    Dec 9, 2009
    Hi all,

    I'm having trouble with my GPS getting a lock. Sorry for the long post, but I wanted to be thorough in my description and "help you help me" :D

    About a month ago, I rooted my Droid, threw the 0.8ghz kernal on it from "Root Your Droid" website, and overclocked it to 0.8ghz using SetCPU. It worked great for a few days, but the back side near the camera would always get warm to the touch if I did anything processor-intensive on the phone.

    One day, I docked the phone to the Motorola car dock and used the GPS navigation for a road trip. The car dock was suctioned on the driver's side of the windshield, and since it was a sunny day that day, it had full exposure to sunlight. I also had a car charger hooked up to keep it juiced up.

    30 minutes into the drive, the navigation went all crazy. It lost GPS signal, then a few seconds later, it tried to hone in my position to some random location, drifting southeast every second, even if the car wasn't moving. I tried to zoom out, but it kept scrolling the map screen to my "new position". I quitted the Navigation and checked on Google Maps: same thing.

    I also noticed my phone was really, really hot. Not painful just yet, but getting there. I shut the phone down, pulled the battery, and let it cool down for 30 minutes or so. When I turned it back on, the GPS was working again, and so was navigation. That whole ordeal freaked me out, so I used my TomTom for the rest of the trip instead.

    My GPS continued to function ok for a few days, but I didn't use it too much after that incident. Several days later though, my GPS failed to lock onto my location in Google maps again, and it did that messed up scrolling/false locking thing. At the time, I ignored it, and several days later, it was working fine again. This repeated itself continuously, although nowadays it wouldn't do the scrolling/false locking as much; it just wouldn't acquire a lock.

    The Problem and Current State
    I have Pete's BB v0.9 ESE53 Android 2.1 overclocked to 800 mhz max, 400 mhz min. Everything on the phone is working fine EXCEPT for the GPS. The GPS fails to lock onto my position, although the cell tower AGPS always gives me a good regional approximation of my location in Google maps and in any apps that uses general geolocation.

    The real kicker is that GPS fails like 80% of the time, regardless if the phone is warm to the touch or not. In other words, there's a small chance that for any given day, the GPS would work for some time for that day. When it works, it works great. When it doesn't, it won't lock onto my position and occasionally gives me false positionings that persistently update in one direction or another (as if I'm always movving, even though I'm not).

    I'm afraid my overclocking may have overheated the GPS chip and fried it, even though it was at a speed that's informally accepted as (relatively) "safe". Maybe it was a combination of overclocking, being in the sun, and hot battery from being plugged into the car charger that fried it?

    Attempted Remedies
    Whenever my GPS didn't lock, I did one or more of the following (not necessarily in this order) to no avail:
    1. Factory wiped and restored to virgin Droid ROM, Android 2.0.1
    2. Killed all GPS/geolocation-using apps
    3. Disabled/enabled GPS/geolocation/wireless networks lock settings
    4. Shutdown, pulled battery, left off for 30+ minutes, turned back on
    5. Left Google maps or Navigation app on for 60+ minutes to try to acquire position
    6. Downloaded GPS Status and GPS Test apps. Both would show 2 to 6 satellites, but for the majority would not acquire signal. For when they DO acquire signal, 1 of 2 things occur:
      • It's a good acquisition and it's one of the rare times the GPS works as intended.
      • It's a false position (as described above), and I'm moving 20 to 40 MPH in some odd direction at an altitude of -5km :thinking:
    7. Dialed *228 and hit "1" to reprogram my phone, followed by a reboot.
    8. Spun it several times on all 3 of its axes.

    Any help would be greatly appreciated! I've scoured the interwebs and found nothing similar to my case (especially with the perpetual false positioning/movement).


  2. milrtime83

    milrtime83 Well-Known Member

    Nov 4, 2009
    There is the possibility that it is just a defective phone which would be covered under the warranty. Take it back to a Verizon store and see what they say.
  3. roscko

    roscko New Member
    Thread Starter

    Dec 9, 2009
    Yeah, that's my plan now... just got to backup all my stuff and unroot before heading over to the Verizon store... *sigh*

Share This Page