1. Check out our app, Forums for Android! Download and leave feedback here!

Root Fritzed Facebook after LeeDrOid 2.2f flash

Discussion in 'Android Devices' started by turbohobbit, Nov 24, 2010.

  1. turbohobbit

    turbohobbit Well-Known Member
    Thread Starter
    63

    Aug 2, 2010
    665
    19
    63
    England
    I reinstalled all my apps from Titanium after flashing Leedroid last night, but Facebook stopped working - the programme opened up ok but wouldn't update (I suspect I may have messed this up when I reinstalled everything) so I tried to uninstall Facebook via Titanium in the hope that I could reinstall from the market. But that hasn't worked as Facebook has disappeared from Titanium but remains on my phone, recognised in Market as "Installed" and still not working.

    I have found the Facebook app in the LeeDrOiD .zip file on my SD card via Astro (/mnt/sdcard/LeeDrOiD_v.2.2f_A2SD.zip/system/app/Facebook). When I select the Facebook file I get the "Application File" window up, showing "Browse File" and "Open App Manager" options. When I select "Open App Manager" I get two options: Uninstall or launch. If I uninstall from here, can I then reinstall from Market, or is it more complex than that?
     

    Advertisement

  2. EddyOS

    EddyOS Well-Known Member
    163

    Apr 29, 2010
    1,681
    283
    163
    Technical Support
    Liverpool, Merseyside
    Just uninstall it from Settings>Applications>Manage applications and then reinstall it from the Market
     
  3. jay_kay

    jay_kay Well-Known Member
    98

    Apr 30, 2010
    606
    96
    98
    Marketing & Communications
    Essex
    Can try it that way or can go into Settings> Applications> Manage applications and find facebook in there. Uninstall it and then reinstall from the market.

    Let me know how you get on.
     
  4. turbohobbit

    turbohobbit Well-Known Member
    Thread Starter
    63

    Aug 2, 2010
    665
    19
    63
    England
    It's all greyed out guys, presumably because the phone sees it as a /sys file. And a duff one at that.
     
  5. EddyOS

    EddyOS Well-Known Member
    163

    Apr 29, 2010
    1,681
    283
    163
    Technical Support
    Liverpool, Merseyside
    Then you'll have to wipe and start again - just don't restore Facebook!
     
  6. turbohobbit

    turbohobbit Well-Known Member
    Thread Starter
    63

    Aug 2, 2010
    665
    19
    63
    England
    The whole blooming lot?!?
     
  7. InfernalByte

    InfernalByte Well-Known Member
    183

    Oct 8, 2010
    1,551
    255
    183
    Male
    Stunt Pope
    Puerto Pollo
    Try; Uninstall Facebook app. Go to the Facebook mini site, sign in, at the bottom of the page you'll find an install app feature as it will have already detected your phone. Good luck.
     
  8. turbohobbit

    turbohobbit Well-Known Member
    Thread Starter
    63

    Aug 2, 2010
    665
    19
    63
    England
    Ok, I've reinstalled from the LeeDrOiD zip (basically ran the app from the zip and it automatically reinstalled), but it still doesn't seem to want to work. When I start the app it refreshes, then gives the message "An error had occurred while fetching data [500/Internal Server Error]". I'm getting the impression this is more to do with me than with Facebook. Looks like a wipe and reflash is inevitable...
     
  9. SUroot

    SUroot Well-Known Member
    1,123

    May 25, 2010
    23,925
    5,304
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Do a titanium back up then wipe. See if it works then. If it does, it was your data / settings.

    Once you know a wipe (factory reset), you can start to restore bits from titanium and by a process of elimination, work out what setting it is that causes it.
     
  10. turbohobbit

    turbohobbit Well-Known Member
    Thread Starter
    63

    Aug 2, 2010
    665
    19
    63
    England
    Good plan. I guess I can do a factory reset from Settings rather than a wipe from the bootscreen? Save a bit of faff?
     
  11. SUroot

    SUroot Well-Known Member
    1,123

    May 25, 2010
    23,925
    5,304
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Yeah, its the same.
     
  12. turbohobbit

    turbohobbit Well-Known Member
    Thread Starter
    63

    Aug 2, 2010
    665
    19
    63
    England
    Well, I factory reset but for reasons best known to God that left some of the apps still on the phone so I ended up wiping anyway. I'm still getting the same message in Facebood when I try to retrieve / update the messages but I still have access to my wall, etc. I'm starting to think this isn't directly to do with flashing the ROM...
     
  13. Rastaman-FB

    Rastaman-FB Well-Known Member
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    when you reflashed the rom does it say in the market that there is a facebook update required?

    its not the rom itself as i use leedroid 2.2f and facebook works (ive not updated facebook as ive black skinned mine)

    btw when you did a wipe, did you do it from recovery? you might want to wipe dalvic cache aswell
     
  14. turbohobbit

    turbohobbit Well-Known Member
    Thread Starter
    63

    Aug 2, 2010
    665
    19
    63
    England
    I'm back up and running now. God knows what happened. That's for the advice folks.
     
Tags:

Share This Page

Loading...