1. Download our Official Android App: Forums for Android!

Support Froyo 2.2 - Change in Battery Performance?

Discussion in 'Android Devices' started by JDM9499, Feb 25, 2011.

  1. JDM9499

    JDM9499 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    97
    Joined:
    Jul 27, 2010

    Jul 27, 2010
    97
    8
    16
    Before, I was running a stock 2.1 Eclair, with a Voodoo LagFix, and LauncherPro (using all 7 screens with widgets). My battery then, would last all day, easily, as long as I wasn't using GPS. I had all my email settings, and widget settings to update EVERY HOUR. For a smart phone, with many widgets running and lasting all day, it was wonderful.

    Fast forwarding to now: I updated to the new Froyo 2.2, and re-installed all the apps I previously had, along with the Voodoo LagFix for 2.2, LauncherPro (still using all 7 screens with the SAME widgets) and set all of my applications (that do need updating) to update EVERY HOUR. Now, I literally sit back and watch the battery percentage just drop. Ex. My battery was at 97%, but after writing this, it's now at 93%. In about 2 minutes....what the hell?

    Has anyone else noticed a change in your battery performance? I've downloaded the OS Monitor to see if anything new has been added, and that's draining the battery, but there is nothing showing that wasn't before. I'm wondering in there is something new that was added, which is running in the background. Ideas?
     

    Advertisement

  2. Frisco

    Frisco =Luceat Lux Vestra=
    Rank:
    None
    Points:
    1,343
    Posts:
    22,478
    Joined:
    Jan 19, 2010

    Following a major update it's a good idea to do and check a few things, including the PRL (preferred roaming list) by dialing *228 and selecting option #2.

    Also, it is possible that some syncing apps/widgets were reset as default to auto sync, background update (Facebook, Gmail, Weather, etc) and they're going crazy.

    I'd go over all menu configuration items and make sure they're where needed and not at new settings.. even screen timeout/brightness, etc, sound levels, wifi and network settings and on.

    Then reboot, but not before going into the recovery/boot menu and wiping cache from there (volume down + power key on some Android devices, not sure what the combination is on Captivate).
     
    JDM9499 likes this.
  3. JDM9499

    JDM9499 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    97
    Joined:
    Jul 27, 2010

    Jul 27, 2010
    97
    8
    16
    Thanks Frisco. I'll give that a shot after this response and see if that helps. I'll post back here any changes after going through the check list you've mentioned.

    Anyone else experiencing this and have you tried the above? Cheers.
     
  4. Frisco

    Frisco =Luceat Lux Vestra=
    Rank:
    None
    Points:
    1,343
    Posts:
    22,478
    Joined:
    Jan 19, 2010

    I was going to edit my post up there to include checking GPS for runaway searching; go into maps with "my location" enabled and see if the little blue arrow is constantly changing position. If so, go into the application manager and clear cache and data on maps, then reboot.

    Check running services, as well; that'll tell you what's at the battery hog trough. ;)
     
  5. JDM9499

    JDM9499 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    97
    Joined:
    Jul 27, 2010

    Jul 27, 2010
    97
    8
    16
    I opened up Maps, and yes, the blue arrow was changing locations, constantly whenever I was moving, and not even using that App. I have noticed in OS Monitor that Maps is constantly running, and even if I force close it, it comes back on. I stopped force closing it and just gave up.
     
  6. Frisco

    Frisco =Luceat Lux Vestra=
    Rank:
    None
    Points:
    1,343
    Posts:
    22,478
    Joined:
    Jan 19, 2010

    You might check settings in maps configuration via the menu once maps is open.

    Force close it from application manager (menu > settings > applications > manage applications > sort by "all").

    Also, while in there, clear cache and data in maps. Then reboot.
     
  7. JDM9499

    JDM9499 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    97
    Joined:
    Jul 27, 2010

    Jul 27, 2010
    97
    8
    16
    Ok, here are a couple things I have found thus far.

    One - After installing the Voodoo LagFix for 2.2, and rebooting into recovery mode, I was actually booted into ClockworkMod - Voodoo Lag - Recovery Mode. That's something new. Anyways, there is an option to "clear battery stats". After briefly reading about this on another thread, the individual said it's a must to do. I'm not sure if this is because of the Voodoo Lag Fix or what, but I did it and will report back at the end of the day.

    Two - This is something new in Froyo 2.2, and it was never an option in 2.1. After going into Settings - Location and Security - and un-checking "Use wireless networks" and the re-checking it, it says "Location Consent - Allow Google's location service to collect anonymous location data. Collection will occur even when no applications are running." That right there could be the reason why the Maps app is constantly running? I turned it off, which I have never done and have always left on, but will see if this makes a difference as well.

    I'll report back with results tonight.
     

Share This Page

Loading...