1. Are you ready for the Galaxy S20? Here is everything we know so far!

Froyo (Android 2.2) update disables USB tethering

Discussion in 'Android Devices' started by gamblor01, Aug 3, 2010.

  1. gamblor01

    gamblor01 Well-Known Member
    Thread Starter

    Just FYI my co-worker has upgraded his Evo to run Froyo today. The update takes quite a while to execute so be patient, but one thing I noticed was that the USB tethering no longer works. On my phone (still running 2.1) I can plug in the USB cable, enable the 4G radio, and then go to Menu -> Settings -> Wireless & networks and click on the "Internet sharing" option. Once I do this, my computer automatically picks up the new USB device and can use it for internet access (it shows up as "usb0" in my ifconfig on Ubuntu 10.04). Note that this USB tethering ONLY works when the phone has a connection to the 4G network, otherwise tapping the "Internet sharing" option will produce an error 67 message.

    I tested on my co-worker's phone after he upgraded to 2.2 and found that:

    1) The "Internet sharing" option has been renamed to "USB tethering"
    2) Tapping the "USB tethering" option will immediately disconnect your phone from the 4G network. Consequently, this means that you cannot tether.

    Anyone else notice this issue after moving to Froyo? I have downloaded the update but I haven't applied it yet (for this and other horror stories I have heard). If you do lose the ability to perform USB tethering after the upgrade, have you been successful with tethering the Evo to a Linux machine? I have tried these two tutorials and been unsuccessful:

    Linux + GNU = Humans Enabled: How to Tether your Android to Ubuntu(or Fedora) GNU+Linux for Internet Connectivity

    James Titcumb Blog Archive Tethering your HTC Magic Android Phone in Ubuntu 9.04 (Jaunty Jackalope)

    1. Download the Forums for Android™ app!


  2. tangfj

    tangfj Lurker

    Yes, I've noticed the exact same issue. The other problem that I have is that when you do activate the wifi hotspot it forces you to 3G even if you are in 4G coverage area.

    I don't know why this is happening because I pay the $30 for wifi hotspot. Anyone know how to fix this or how to go back to 2.1??? I really need the usb tethering and wifi hotspot over 4G!!
  3. gamblor01

    gamblor01 Well-Known Member
    Thread Starter

    Very odd. I don't pay for the $30 wifi hotspot feature so I cannot comment on how well that works (or doesn't work) after the upgrade. But the USB tethering definitely doesn't work after the upgrade. If you cannot use the hotspot feature on the 4G network then that should be something that Sprint supports. I would go into the store and have them look at it, or flash your phone back to 2.1 or something.

    You could (if you really want to) try some instructions for unrooting a phone (which flashes it back to default -- and is old enough that I believe it's a 2.1 version), but why? You're paying Sprint $30/month to have a 3G/4G wifi hotspot and after the upgrade your 4G capabilities are broken. I would let them deal with fixing it!

    I wouldn't personally recommend this but here is a link:

    [How To] Unroot and return to stock. - Android Central Forums
  4. tangfj

    tangfj Lurker

    Oddly enough, I just looked down at my phone and it now has the hotspot in 4G. I didn't change anything or move locations, it just switched from 3G to 4G by itself. (When I was in 2.1 the same area where I work is almost always in 4G)
  5. tangfj

    tangfj Lurker

    So as a paying customer the question I would have... is usb tethering supposed to work as part of my $30?? The only reason I prefer to use usb tethering is that it seems to use less battery than the hotspot uses (at least in 2.1). I noticed that when I had the hotspot on in 4G, that the USB charge could not keep up with the battery consumption. So even though I was plugged in via USB the hotspot would still drain the battery so a lot of the time I would use USB tethering b/c it seemed to work better in terms of battery life...
  6. gamblor01

    gamblor01 Well-Known Member
    Thread Starter

    That is a good question, and one you would have to ask Sprint for the final word on. Again though, it seems silly to have it charging but the charger isn't capable of keeping up with the hotspot app! The Sprint terms of service definitely seem to suggest that tethering is not an allowed form of data usage:


  7. The Monsoon

    The Monsoon Newbie

    I was actually expecting the opposite from FroYo, I personally wasn't smart enough to figure out how to tether the phone with my computer on 2.1 without paying for PDAnet which in my circumstances would do me no good. I read all about 2.2 and one of the points made was tethering capabilities, seems to me that Sprint may have altered the code to make it more difficult as opposed to more accessible!? Which blows my mind seeing as this is a 4G phone which can support speeds that in my opinion can only be appreciated on a computer! Hahaha, I laugh when I think about the irony in all this!!! We are all in the same boat and I feel we will never be satisfied....

    So anyways, maybe you guys can shed some light on me with what I want to achieve. My wife and I both have EVO's and with the amazing 4G speeds we get at our house I would love to cancel my DSL and we can use our phones for our Internet needs. To activate BOTH phones to share internet would be $60 right? Out of the question since DSL is only 30. So I looked at PDAnet and that's great but I can only have it on one computer and I have a network with 2 desktops, a laptop, xbox, and my Dish Network. So I purchased a Cradlepoint which allows me to plug the usb from the phone in and then have ethernet out which I'd then run into the Linksys router and hit the ground running. I wish it was that easy! The cradlepoint cant find an internet connection on my EVO because with programs such as PDAnet you must have the program on your computer running as well so it does nothing!!!

    I hope someone reading this can point me in the right direction and possibly work with me here, I am not clueless with computers but this phone has definitely got me stumped. Thanks to anyone that offers assistance!

  8. Yomba

    Yomba Lurker

    " If you do lose the ability to perform USB tethering after the upgrade, have you been successful with tethering the Evo to a Linux machine?"


    You can enable tethering with an Evo to a Linux Machine. Even after the update to 2.2.

    As most people know, PDA Net works for Windows and Mac machines. However, PDA Net does not yet work for Linux.

    There is a working solution and I use it at this very moment on my Linux Ubuntu 10.04 notebook PC. It is available in the Android Market. It is called "Easy Tether". You will have to download some Ubuntu enabling files to get started. However, the big trick is that there are no instructions on the site as to how to enable Ubuntu 10.04's use of Easy Tether. I had to email them for instructions and they did get right back to me.

    To hopefully, save you that trouble, see below for the pertinent part of the instructions. If you have a problem, email the developer and you should get on track quickly. There is a free version, but I liked it so much that I paid to upgrade to the Pro version.

    Okay, here goes: (After enabling the Ubuntu related files you will download)

    Start Easy Tether on your Android Smartphone
    Enable Disk Drive on your Android Smartphone when asked
    (Note: USB debugging connected is also enabled in my Notifications drop down)

    USB sharing should be enabled with a checkmark in EasyTether

    Open a Terminal window and type:
    sudo easytether connect

    insert your administrator password and hit return

    Once it says the connection is established, do _not_ stop
    the running "easytether connect", open another Terminal and run

    "sudo dhclient easytether0"

    (without the quotation marks. Zero not o)

    You should now be connected to the Internet.

    To quit:
    press Ctrl-C to disconnect (in the first Terminal window)
    You should see the following message:
    "connection closed from the smartphone"


    I'm a single user so I have never had to use the alternative method which I believe is for people on a network. It requires another line of code in the first terminal before the ones I have already provided. In other words:

    sudo easytether enumerate (This returns a number that I have never needed)
    Then you do as above:
    sudo easytether connect
    Open the 2nd terminal after connecting and:
    sudo dhclient easytether0 (That is a zero at the end)

    It works great for me even after the 2.2 update. Good Luck!
    JohnnyStorm likes this.
  9. gamblor01

    gamblor01 Well-Known Member
    Thread Starter

    I have already tried easytether on Ubuntu and it doesn't work. I have tried on both an 32-bit and 64-bit system and got the same results -- the system receives an IP address (on interface easytether0) and I can ping the gateway (which would be the phone) but I can't make it any farther than that. Maybe the free version is broken with Ubuntu or something. My co-worker installed it on WinXP and it worked fine (though he couldn't use any https stuff obviously since it was the free version).

    @The Monsoon:

    Does this cradlepoint device have an input ethernet connection (or is it only USB)? If so, you might look into "internet connection sharing" -- though this assumes that you are running Windows. I did this years ago on an XP system -- just had 2 NICs in it. One NIC was connected to the cable modem and the other NIC was connected to a second computer. I configured things to share the internet from the one NIC to the other (and thus the second computer had internet access).

    You're pretty brave to want to cancel your DSL and only use your phone to provide internet. Also, if Sprint finds out they can cancel your contract and make you pay an early termination fee for violating terms of service. ;)

    But if you want to try it and you have a computer you can plug in, then technically you could probably:

    1. Connect the computer with your phone via PDAnet
    2. Configure the system to share it's connection with a NIC card
    3. Plug the cradlepoint thingy into the NIC where the connection is shared from
    4. Plug in your router to cradlepoint and enjoy

    I don't know how reliable that would be, but it's a possibility.
    The Monsoon likes this.
  10. The Monsoon

    The Monsoon Newbie

    gamblor, Thank you for the ideas...with what you are suggesting I would actually bypass the cradlepoint all together! With your scenario the desktop itself would feed the internet into the linksys router and then to my other components correct? Anyway, I used to do a lot of media and torrents on the web but lately I find it cumbersome and I have no desire to use GB after GB of data!!!! Still you bring up all good points and with all the uncertainty of these phones and data consumption I may as well look at keeping DSL....or another option other than this amazing phone!!! Thanks!
  11. gamblor01

    gamblor01 Well-Known Member
    Thread Starter

    Yes I suppose you could bypass the cradlepoint thing entirely. I haven't looked up what that device is/does so I wasn't sure if you would still need it or not. Just one point of clarification...you can share your connection using any OS, but Windows specifically calls the option "internet connection sharing".

    Maybe in the future things will be stable enough to use a phone as an ISP but I wouldn't personally try it. Plus it's constant effort to keep connecting the phone and starting up PDAnet, and what happens when you want to leave the house but your wife is staying behind? Now you have to unplug your phone and then connect hers...doesn't sound like fun to hassle with that all the time...
  12. gamblor01

    gamblor01 Well-Known Member
    Thread Starter

    FYI back to the original reason for this post -- tethering was disabled. As I mentioned before, I tried using the instructions in those 2 links above but was unsuccessful. I found a third blog post with instructions on using azilink and it worked!

    Setup USB tethering on your Android phone, no root access required | AndroidNexus.com

    The trick seemed to be the correct info in the 91-android.rules file, which for me was:

    Code (Text):
    2. SUBSYSTEM=="usb", ATTRS{idVendor}=="[COLOR=Red][B]0bb4[/B][/COLOR]", SYMLINK+="android_adb", MODE="0666", OWNER="[COLOR=Red][B]username[/B][/COLOR]"
    Obviously, replace the items in red -- idVendor needs the correct value for your phone (0bb4 is the correct value for HTC) and OWNER should be set to your uid on your Linux system.

    Following that guide worked for me, even while running 2.2!
  13. lousyskater

    lousyskater Newbie

    EasyTether still works for me, posting from my computer that's currently tethered to my EVO right now.
  14. tangfj

    tangfj Lurker

    Somehow I got USB working on my 2.2 EVO today (Please note that I am paying for the $30 hotspot).

    I connected my phone to my computer using HTC Sync, then my phone to displayed a message about USB debugging, at which point a notification came up saying that there was a USB debugging option or something like that. At that point I clicked on the notification and it took me to a screen that had an option for USB debugging and disabled it.

    After USB debugging was disabled, I was and am able to use USB tethering! Problem is I searched everywhere in my phone and I can't seem to find where the USB debugging option is. Anyone know?
  15. gamblor01

    gamblor01 Well-Known Member
    Thread Starter

    Sure do! Menu -> settings -> applications -> development

    The easytether thing doesn't seem to work with my ubuntu laptop and PDAnet doesn't support Linux at all...plus their free versions block SSL. The azilink stuff works great for me, allows SSL (so I can connect to my work VPN), and is totally free!
  16. rperiod

    rperiod Lurker

    This is by far my biggest frustration with the update. I live in a 4g area but beside tethering, I don't really see a need for the increased speed. I'm surprised this issue has not been discussed in detail compared to many of the other changes/glitches with 2.2 on evo forums...? Maybe I'm one of the few guys left who hasn't rooted?

    Guessing there is no fix for windows os systems?
  17. gamblor01

    gamblor01 Well-Known Member
    Thread Starter

    Check out easytether or PDAnet. You can get a lite version of them for free in the market and they should both work very well with Windows. If you want SSL support then you have to purchase the full version. The only reason I can't use them is because PDAnet doesn't even have a Linux client, and I can't get easytether to work properly (even though it says it's connected).

    I actually found that I still can't get tethering to work properly unless I'm already connected via another interface (such as eth0 or wlan0 -- in which case what is the point of tethering?). For some reason the traffic is going through the Sprint network (bandwidth tests confirm it and the bytes sent/received continue to increase in the azilink app) but as soon as I turn off wireless and/or update /etc/resolv.conf -- the tethering no longer works. Must be some configuration setting somewhere but I can't figure it out. :(
  18. JohnnyStorm

    JohnnyStorm Lurker

    This worked perfectly.

    I wonder if the people who are not successful are remembering to open separate terminal windows? I blew that on my first try; the relay didn't establish when I used only used terminal window.

    Your description couldn't have been more perfect. I'm tethered as I write this. Completely on the money. Thank you very much!
  19. Hey there... I'm the author of the blog at "Linux + GNU = Humans Enabled: How to Tether your Android to Ubuntu(or Fedora) GNU+Linux for Internet Connectivity".

    Today, I just upgraded my Verizon Droid Incredible to the latest Android version (2.2(Froyo)) via the OTA update.

    Just wanted to let you know that USB tethering still works perfectly, per the setup instructions on my blog. Also, just to test, I've since reset my phone to factory defaults (down volume button plus power on button held until you get the special reset screen) and then I re-installed the tethering via method I outline on my blog noted above. I'm here to tell ya: USB tethering works perfectly with Android 2.2.(Froyo).

    Also, now there's a python script on my site to simplify setting this whole thing up... The script adds the special udev rules for both the Motorola(e.g., Droid) and HTC devices (i.e. EVO and Incredible) and it works great! If someone could provide the output from lsusb while connected with a Samsung Android device, I could add that too. I have over 190 comments from people that have used my setup procedure, and most indicate success.

    So give my post another try - it should work without issue: http://tinyurl.com/tetherdroid

    Humans Enabled - That's what GNU/Linux is for!

    Shannon VanWagner
  20. mikebgb4

    mikebgb4 Newbie

    What is required or what is the process for a windows machine on 2.2?


  21. gamblor01

    gamblor01 Well-Known Member
    Thread Starter

    Thanks Shannon. I tried your method several times but was never able to get it to work. Sprint apparently had a bug in their code that allowed tethering while the Evo was running 2.1 (if and only if you were connected to the 4G network). Actually, it allowed people to use the wifi hotspot feature as well. They fixed that loophole in 2.2 so I looked for alternatives -- not really because I needed it but simply because they took it away from me. As I said though, I have tried multiple times and it just doesn't work. I didn't use the script but am more than capable of running things from the CLI.

    Thanks, but that definitely isn't my problem. I opened up a separate terminal to try things. Certainly I didn't close the original window (or CTRL+C or anything else) as that would have killed the child process that connected over azilink. I have been using Linux off an on for past 10 years or so and have been using it as my main OS for past 3-4 years so I definitely know what I'm doing. It's not the separate terminal issue I promise. ;)

    I'll give things a shot again I guess, but I'm not confident that it will work.

    Windows users have it easy. You can just download PDAnet or EasyTether from the Android market and they should work fine. They'll block the SSL protocol unless you pay for their full versions though.
  22. gamblor01

    gamblor01 Well-Known Member
    Thread Starter


    I went back and read your blog again Shannon. One thing I noticed this time around (which I didn't notice before because the text is so small...might I recommend you increase that warning?) is that you need to uncheck the "Work Offline" option in Firefox to get it to work. The Proxoid instructions have this same restriction (but Proxoid only handles HTTP traffic).

    I'm tethered right now and it's working great. In the past I tried using the browser and it didn't work. I then tried pinging machines (such as Google) and didn't get a response. azilink must be capable of handling TCP (and I guess UDP packets) but not ICMP. So pings always fail.

    This time around the browser is working great. I was also able initiate an SSH session to a remote system and even connect through my VPN for work.

    Victory is mine!
  23. New Jersey

    New Jersey Member

    so, nobody found a way around the 2.2 update stealing usb thethering for all of us non rooted windows users?
    this really ticks me off...
  24. gamblor01

    gamblor01 Well-Known Member
    Thread Starter

    Take a deep breath and think happy thoughts! The azilink app was also written with Windows users in mind. It's not the clearest of instructions, but there are instructions on the azilink web page:

    azilink - Project Hosting on Google Code

    If you don't have the patience to get that working you can always just use (or purchase full versions of) easytether or pdanet as mentioned previously.

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
Similar Threads - Froyo Android update
  1. tube517
  2. stealthpaws
  3. BuckLikesAndroid
  4. cidea
  5. DaneWells91
  6. RedHeadDev
  7. Anirudha Deshpande
  8. Sunny Rio
  9. AntiMorrisey
  10. MsTessie

Share This Page