1. Download our Official Android App: Forums for Android!

Support FroYo - Camera and Camcorder not working

Discussion in 'Android Devices' started by bigtart, Aug 1, 2010.

  1. bigtart

    bigtart Newbie
    Thread Starter
    15

    Apr 19, 2010
    26
    0
    15
    When launching the camera or camcorder the icon for either the camera or camcorder appears in the middle of the screen for a fraction of a second then the app closes. sd card is mounted and i can read existing pictures and videos off it.

    i unmounted and remounted the card. issue remains.

    anyone else?
     

    Advertisement

  2. bigtart

    bigtart Newbie
    Thread Starter
    15

    Apr 19, 2010
    26
    0
    15
    same as last update. do 3 restarts and all goes back to normal.....weird
     
  3. chris 290

    chris 290 Android Enthusiast
    43

    Jun 29, 2010
    280
    44
    43
    Just reboot your phone / take battery out for 30 arcs should work fine after that :)
     
  4. Mark One

    Mark One Member
    16

    Apr 29, 2010
    52
    4
    16
    Culprit for me was: LED Light Widget 1.0.9

    Uninstalled this and camera working normally even after reboot.
     
    mms1946 and nacatomi like this.
  5. mthuen

    mthuen Lurker
    5

    Jun 9, 2010
    5
    0
    5
    mine did the same, but after just waiting a few hours it suddenly decided to work. Pressed it once, and it didnt load, pressed it again immediately afterwards and it worked...
     
  6. nacatomi

    nacatomi Android Enthusiast
    78

    Jun 22, 2010
    502
    82
    78
    Same for me, uninstalled and everything ok.

    Thanks.
     
  7. l8rgdkd

    l8rgdkd Lurker
    5

    Jul 22, 2010
    4
    0
    5
    my camera wasnt working after doing the froyo 2.2 update... found this thread and uninstalled the LED Light Widget and it worked again
     
  8. FC360

    FC360 Lurker
    25

    Apr 16, 2010
    9
    0
    25
    Unemployed
    UK
    Yeah I had the same problem, was starting to panic and then I saw this thread and uninstalled LED light and now camera works perfectly. I have now reinstalled LED light and the camera is still working.
     
  9. tduke53

    tduke53 Newbie
    16

    Apr 11, 2010
    29
    8
    16
    Rochester Hills, MI
    I had this problem too. I just waited a while than ran my task manager and after that it worked.
     
  10. ouzunlar

    ouzunlar Lurker
    5

    Jun 6, 2011
    3
    0
    5
    I have the same issue on htc desire s with android v.2.3.3 and i have not installes extra application, factory data reset does not solve the issue , do you have ideas? thanks in advance
     
  11. Rastaman-FB

    Rastaman-FB Android Expert
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    try the desire s forum
     
  12. luckyoutlandish

    5

    Dec 29, 2009
    3
    0
    5


    hey, i have the same problem, how do i uninstall the LED Light widget, i have a flashlight installed by the manufacturers. tried to uninstall the flash light through application>manage application>all>flashlight. but the phone won't let me uninstall :(
     
  13. Usta

    Usta Android Expert
    333

    Jul 8, 2010
    2,585
    1,374
    333
    The Netherlands
    That means it is a system application. Even if you do a factory reset, it will still be there. So, either use it or ignore it.
     
    luckyoutlandish likes this.
  14. luckyoutlandish

    5

    Dec 29, 2009
    3
    0
    5
    thanks for the reply, but since the camera turns into a black screen and every one got it fixed by uninstalling the LED light, i thought uninstalling might help me as well.
    I also tried to downgrade the rom from froyo but i can't seem to find the the right rom for my desire. I also ran factory reset on the phone, pulled the battery and sd card out and I also formated the sd card. NOTHING helped .
    Can you plz help me solve the camera issue or point me the right way to find an older version of rom (2.1)or(1.5) that may help fixing my desires camera? thanks in advance
     
  15. Usta

    Usta Android Expert
    333

    Jul 8, 2010
    2,585
    1,374
    333
    The Netherlands
    Does the camera remain black if you press Back button?

    Factory reset should have fixed the issue.
    Have you tried other camera applications, like Camera360? Does the problem happen when you use those?

    It could also be a defect, so if the phone is still under guarantee, you can send it to HTC for repair.
    Or, you can wait for Gingerbread update and see if that fixes the problem (expected this summer).

    Finally, if nothing helps, you can decide to root the phone and put a custom ROM on it.
     
  16. luckyoutlandish

    5

    Dec 29, 2009
    3
    0
    5
    yeah it remains black after pressing the back button and I've tried other camera apps too but i get the same result.

    it was working fine untill i did froyo update, so I don't think it's a hardware problem.
    I guess i will wait untill the new Gingerbread update. thanks for the help :)
     
  17. JaneN

    JaneN Member
    15

    Sep 5, 2010
    34
    0
    15
    Did you get a resolution?

    The camera and camcorder died for me today. I too only have the factory loaded Flashlight app.

    I see the factory reset did not work, so I'm not going to bother trying that on mine.

    I will be very angry if it has to go back for repair, seeing as mine was one of the ones that had to go back for a new motherboard due to the over heating/resetting problem :(
     
  18. jefftemp2

    jefftemp2 Lurker
    5

    Jan 6, 2012
    3
    0
    5
    I'm having the exact same issue. Upgrated to 2.3.5 and camera/camcorder stopped working. Opens up for a second, shows the icon, then closes. I've hard reset, rebooted, battery pulled, etc.. The same issue happens whether i use standard factory app or camera 360, FxCamera, or RetroCamera. RetroCamera says unable to reach camera. Camera360 says failed to connect to camera. Highly unlikely its a hardware issue as the camera worked fine seconds before upgrading to 2.3.5, and then following upgrade no longer works. I do not have any LED apps or LED widgets installed. Only thing "light" related is the standard factory Flashlight App and Flashlight Plugin, neither of which are removable. Any ideas would be appreciated! Thanks in advance.
     
  19. banivani

    banivani Lurker
    5

    Jan 28, 2012
    2
    0
    5
    I'm having issues with this too. I got my Desire in ... October 2010 my husband tells me (wouldn't remember a thing like that myself), but didn't do an upgrade until just this year (because I had to delete/rearrange so much stuff to give it the memory for an upgrade). Don't ask me which upgrade I have, I don't even know where to look for that info. Anyway, I upgraded, and shortly after that the camera and flashlight stopped working. Just stopped, out of the blue. If I try to turn on the camera the phone shuts down and restarts. :thinking: I've been reading threads on various forums but I really don't know what to do. Seemingly factory reset doesn't always work? Today it came with another upgrade and I deleted six apps so I could manage that :)rolleyes:) just in case this upgrade would fix it, but no luck.
     
  20. ducky1979

    ducky1979 Android Expert
    98

    Dec 16, 2010
    910
    96
    98
    Male
    conductor
    Buxton, Derbyshire
    I had this issue and i sorted it by deleting. .thumbnails folder from the SD card. It's a hidden folder so if your unable to see it using a file explorer check the settings to see if you can enable view hidden files, otherwise just pop it into a card reader on your PC and make sure you can see the hidden files.
     
  21. banivani

    banivani Lurker
    5

    Jan 28, 2012
    2
    0
    5
    Okey, bizarre follow-up.

    I'd done nothing to fix this. Was thinking of backing everything up, doing a factory reset and then, if it wasn't fixed, take it back to the shop. But yesterday while sitting on the bus home I idly went through the "handle your apps" section (my phone is in Swedish and I forget what it's called in English). I did what I often do, I force a stop to programmes I don't want (like stock info and the weather app) but can't get rid of unless I root the phone which I'm do scaredy-cat to do. Anyway, force stop, delete all settings to them or whatever it's called (just because it annoys me that they're running when I didn't start them and don't want them). I didn't do this to ANYTHING remarkable. Maybe to Footprints, which I don't know what it is. I've done this to Footprints before though to see what happens and nothing did.

    So I back out of that, and the phone reloads a little, like it does. And when home screen comes back online it's COMPLETELY DIFFERENT. It's like what it looked like when I first got the phone. My chosen background - gone. My links to favourite apps - gone.

    A moment of panic.

    Then I check if they're actually gone off the phone, but they're not. Everything is there.

    I check the camera. It turns on, but the flash is gone (i.e. very dark photos). I fancy it makes a very faint funny, protesting noise.

    The flashlight doesn't work.

    I am so befuddled. This is so strange.
     
  22. jefftemp2

    jefftemp2 Lurker
    5

    Jan 6, 2012
    3
    0
    5
    Thanks ducky1979... found the .thumbs file and deleted but still having the problem. Let me know if anyone has any other ideas.... Thanks.
     
  23. ducky1979

    ducky1979 Android Expert
    98

    Dec 16, 2010
    910
    96
    98
    Male
    conductor
    Buxton, Derbyshire
    just to clarify it was the .THUMBNAILS folder wasnt it?
    if yes have you tried a reboot since you did it?
    its in the DCIM folder, should be the first folder.

    let me know.
     
  24. jefftemp2

    jefftemp2 Lurker
    5

    Jan 6, 2012
    3
    0
    5
    Yes, the .thumbnails folder within the DCIM folder in the SD card directory. I deleted it, rebooted the phone, and checked the folder - not there. Tried to open the camera, didn't work. Checked the folder - still not there. Opened the gallery app, it seemed to pull in photos attached to my email accounts. Checked the folder - .thumbnails is back. Tried to open camera, same issue. I've tried deleting the folder and rebooting a couple times. Also battery pulled. I also actually deleted the entire DCIM folder but that didn't help either. Wondering if I have a bad camera file or config file or something like that?
     
  25. ducky1979

    ducky1979 Android Expert
    98

    Dec 16, 2010
    910
    96
    98
    Male
    conductor
    Buxton, Derbyshire
    i dont know then sorry, it worked for me, but im rooted so i also wiped the phone and started from scratch aswell, so maybe you have something extra adding to it.
    sorry i cant be more help.
     
    jefftemp2 likes this.
Tags:

Share This Page

Loading...