1. Check out our companion app, Forums for Android! Download from Google Play

Support Frustrated connecting to the WiFi network

Discussion in 'Android Devices' started by abourne, Jul 1, 2010.

  1. abourne

    abourne Well-Known Member
    Thread Starter

    At the office, we have a high-speed reliable WiFi network.

    I don't have problems connecting to it with my macbook and iPod Touch.

    On my Android phone, I use the toggle switch to turn on/off WiFi to save battery power.

    My frustration is as follows:

    * When I use the WiFi setting to check the box to turn on WiFi, it shows that it's available with a strong connection.

    * It shows "Obtaining address....." for a long time period and often fails to actually connect.

    Status - Obtaining IP address from XXXXX Pulbic WiFi Access

    and it just sits there with the word "Obtaining..." forever it seems.

    Sometimes, or often, I can't even get it to connect.

    Does anyone else have this problem connecting to a strong WiFi network from their device?

    Suggestions on resolving this matter?



    Sometimes it eventually states "Unsucessful" before I try again, even though there's four bars and it's connecting on other devices (the WiFi is fine).


  2. h0odlam

    h0odlam Well-Known Member

    Jun 3, 2010
    try re-entering the ssid and wep
  3. abourne

    abourne Well-Known Member
    Thread Starter

    Please explain:

    * ssid

    * wep

    And the menu steps if applicable.
  4. chawski

    chawski Well-Known Member

    May 19, 2010
    when you attempt to connect, does it require you to put in a password? if it does, it will automatically bring you to the screen, no need to go into the menu. it should only prompt you to do this once, as long as you dont chose to forget the network.
  5. abourne

    abourne Well-Known Member
    Thread Starter


    This is an open network for my building, no password required.

    Again, works with no problem on the iPod Touch and Macbook, laptops, etc.
  6. treborcj

    treborcj Well-Known Member

    Dec 11, 2009
    It seems you are doing everything correctly. I have no problem with getting connected to anything I have tried. In fact, I leave WiFi on all the time. You may need to try a factory reset or maybe your wireless card is jacked.
  7. ronbien

    ronbien Well-Known Member

    Apr 23, 2010
    Does it ever connect? The Hero onlly talks 802.11-B or G. It does not do N. But if it connected even once, that is not it.
    Good Luck!
  8. pauloconnor81

    pauloconnor81 New Member

    Mar 2, 2011
    I had same problem on HTC Desire. Using a LInksys WRT300N router.
    Bottom line, the phone could not obtain ip address from DHCP Server. The router DHCP settings set to assign through to , plenty of free addresses but no joy.
    In the end I set static ip address on phone , with gateway, dns, subnet mask (obtained from typing ipconfig /all on a wireless laptop command prompt). Phone then connected immediately and worked fine.

    Before that, I tried:
    trying to specify /b, /g, /n , mixed
    changing channels
    changing security from WEP , WPA, no security,
    forgetting, reconnecting, firmware upgares...... made no difference.

    Downside with my solution, is that when away from home, I have to remember to remove my static IP , but its the only way I can get it to work.

    Vodafone UK could probably do with recruiting helpdesk people who have a clue and care !

Share This Page