1. Are you ready for the Galaxy S20? Here is everything we know so far!

Full Root Working and Tested on Kyocera Torque 1.007SP

Discussion in 'Android Devices' started by UPdownLoAD, Jul 10, 2013.

  1. UPdownLoAD

    UPdownLoAD Member
    Thread Starter

    Since there's no Torque forum on XDA, I wanted to make sure this gets shared.

    Here are the instructions on how to root the Torque on 1.007SP release.

    Credit goes to VicFreeze. He said he would post a more detailed write-up later, but this can be followed if you understand it (or can search lol):
    http://forum.xda-developers.com/showpost.php?p=43030311&postcount=46
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Unfortunately I didn't succeed with many applications. I tried Framaroot, Kingoroot, Kingroot, Motochopper and none worked. I tried many versions of Framaroot with the same result. Kingroot somehow managed to leave "KingUser" that I cannot uninstall. This phone is insane. I don't know what the engineers were thinking about when they just put 1GB of storage, I cannot even update the apps installed from the factory because of storage limitations. So I need to root this to move and uninstall some apps that I never use. I appreciate any pointers.

    My Kyocera Torque info:
    Android version: 4.1.2
    Software version: 3.0.0.0SP
    Hardware version: 010B
    Baseband version: 3.0.0.0SP
    Kernel version: 3.4.0-g4b40761
    build@Kyocera))
    #1 SMP PREEMPT Mon Aug 4 01:48:14
    JST 2014
    Build number: JZ054K

    Angel
     
  3. bcrichster

    bcrichster ROMinator
    Moderator

    I hear towelroot works well on JB 4.1.2 OS and there are MANY versions of Framaroot as well, and which version of KingRoot did you try? They are constantly updating & improving its capabilities..
     
  4. I tried with Framaroot versions 1.4.3, 1.6.0, 1.8.0 and 1.9.1. I don't remember which version of KingRoot, I guess it was the last one that I uninstall, but as I said it left KingUser on the system - I wonder if they managed to leave KingUser as a system app that cannot be un-installed, doesn't that mean that somehow they got root access? I just tried Towelroot, it says this phone is not supported.
     
    #4 angelito_rojitas, Dec 22, 2015
    Last edited: Dec 22, 2015
  5. bcrichster

    bcrichster ROMinator
    Moderator

    I sent you a link in PM... Download the whole folder and try all of them, hopefully you'll have better luck. As for KingRoot, you actually MAY HAVE ROOT already but some of the Root checkers look for an SU binary and some of the older KingRoot apps used a KU binary instead, so it reads as NOT ROOTED even tho you ARE Rooted anyways.. KingRoot fixed that issue with the newer versions but you may be able to reRoot with KingRoot and run the Super-SuMe.apk before the reboot to achieve permanent Root. Good luck and as always, be careful cuz I'm not responsible for any damages caused by your own hands. I'm giving you "keys" to use, what you do with them is on YOU.
     
  6. Tomorrow I will try your folder, thanks! Another interesting thing about KingRoot: after I pressed the "Start Root" button, it comes back with the failure message and it says to try the PC version. I downloaded that, but the installation procedure is all in Chinese, so I'm a bit afraid to press any button without knowing what they are, I wonder if these people also wrote an English version.
     
  7. I tried most of them, but aptoide didn't show me anything specific to rooting the device and I couldn't install SuperSU Me, I was getting the message "Failure [INSTALL_FAILED_OLDER_SDK]" .

    This part is edited from my past posting. I'm not sure whether the device is rooted or not. Kingroot says it can't root. After pingpong installed "SuperSU me", I can 'su' on the terminal emulator. Furthermore, I installed link2sd and it says that it can't place links on /system partition because is full. I ran 'df .' on /system and in effect is full (495M out of 495M). However I entered there 'touch foo' and the prompt came back, but the file "foo" doesn't appear to be there, perhaps because is full. I believe that if I could remove some system apps that I don't use nor I'm interested in, that would clear that partition so perhaps link2sd could do its job.

    I forgot to test for "rooted" or not by checking the type of prompt, when I type 'su' I don't get the "#" prompt, so I believe is not rooted.

    Thanks.
     
    #7 angelito_rojitas, Dec 23, 2015
    Last edited: Dec 23, 2015
    bcrichster likes this.

Kyocera Torque Forum

The Kyocera Torque release date was March 2013. Features and Specs include a 4.0" inch screen, 5MP camera, 1GB RAM, Snapdragon S4 Plus processor, and 2500mAh battery.

March 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...