1. Are you ready for the Galaxy S20? Here is everything we know so far!

Galaxo "no-sleep" but <-- Please help!

Discussion in 'Android Devices' started by maurinet, Jul 1, 2010.

  1. maurinet

    maurinet Well-Known Member
    Thread Starter

    This bug is really driving me crazy, I've read all around and can't find a way to fix it. I hope I can get some help here.

    I updated my Galaxy i7500 with Odin v3.98 to firmware and baseband I7500XEJC6 (used the 4 files: BOOTLOADER, PDA, PHONE & CSC)
    And then clean-installed Recovery 4.6.3 & Galaxo
    Installed DarkSense2.0_ADW-Sense.zip theme (fixed permissions, applied theme)

    So now I have:
    Firmware version: 1.6 - Galaxo V1.6.3.3
    Baseband version: I7500XEJC6
    Kernel 2.6.29-bfs302-drakaz-galaxo-light drakaz@PC #44
    Build number Donut.XEJC6

    I use only 2G network, have GPS disabled, Wireless Location disabled, Sharing with Google disabled, AutoSync off, 3G/EDGE/GPRS disabled through APNdroid, and Brightness set to 11%. Only WiFi on.

    Battery use stats show "Android System" using 98%.
    I charged the phone all night long, in the morning unplugged from charger, restarted and after about 4 hours the phone info shows on "Battery history - Other usage" "Running (51.2%), Screen on (19%)" <-- This confirms no-sleep bug! :'(

    I've pushed the services.odex hoping that it would fix it, but it did not.

    My battery lasts 12~16 hours (I've read that it could last up to 3 days or more).

    In case you were wondering, I've known for a while not to use the original Samsung pouch that came with the phone because it presses a button and prevents the phone from sleeping, so that's not it.

    Help will be greatly appreciated
    A bit more info:

    Running adb logcat with all connections off, including wifi, these are the last few lines, every minute or so, a new line appears at the end, similar to the one before:

    D/skia ( 127): purging 33K from font cache [4 entries]
    D/dalvikvm( 127): GC freed 26764 objects / 1276000 bytes in 260ms
    D/skia ( 1619): purging 49K from font cache [6 entries]
    D/dalvikvm( 1619): GC freed 539 objects / 90640 bytes in 88ms
    D/dalvikvm( 3026): GC freed 91 objects / 4520 bytes in 117ms
    D/dalvikvm( 2997): GC freed 4444 objects / 353648 bytes in 182ms
    D/dalvikvm( 452): GC freed 133 objects / 5600 bytes in 189ms
    D/dalvikvm( 452): GC freed 143 objects / 4760 bytes in 99ms
    D/dalvikvm( 452): GC freed 105 objects / 3576 bytes in 156ms
    D/dalvikvm( 452): GC freed 87 objects / 3008 bytes in 153ms
    D/dalvikvm( 127): GC freed 27126 objects / 1577320 bytes in 458ms

    When leaving wifi on, this is what I get, and a new line is added every 10 secs or so:

    I/dalvikvm( 2997): at dalvik.system.NativeStart.run(Native Method)
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2
    D/dalvikvm( 127): GC freed 26335 objects / 1351816 bytes in 230ms
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2
    D/dalvikvm( 452): GC freed 95 objects / 3232 bytes in 102ms
    D/dalvikvm( 2997): GC freed 2067 objects / 135952 bytes in 118ms
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2
    D/WifiService( 127): ACTION_BATTERY_CHANGED pluggedType: 2

    1. Download the Forums for Android™ app!


  2. mrqs

    mrqs Android Expert

    you have wifi on all the time?
    that alone will eat your battery out without any bug present

    btw, there's really no need to disable gps, it's only used when an app requests it - ie. having it enabled will use no more battery if you don't actually use it
  3. maurinet

    maurinet Well-Known Member
    Thread Starter

    I have wifi on when I'm at home and using the internet. It should make a difference, but not that much as I understand. Draining my battery in less than 24 hours? - Thanks
  4. inFECT

    inFECT Android Enthusiast

    Which Battery Stats are you using?
    The build in is no refference. Use the one from Galaxo+
    its called phone diag bla blub!
  5. maurinet

    maurinet Well-Known Member
    Thread Starter

    I'm using the "Galaxo+", "Spare Parts" and "*#*#6436#*#*" Battery history to view these stats. They all show the same, a big difference between "Running" and "Screen on".

    Also created a shortcut on the desktop to "Battery use", that's the one that shows "Android System" using 98% (other indicators are "Cell standby 4%", "Phone Idle 5%", "Voice calls 5%")
  6. inFECT

    inFECT Android Enthusiast

    Ah ok..

    Well, your logcat output is pretty normal. I suggest to install OS Monitor and have a look which process is using a lot CPU and/or is generating a lot "load"
    maurinet likes this.
  7. maurinet

    maurinet Well-Known Member
    Thread Starter

    I installed OS Monitor. "OSMonitor" is using 15~20% of CPU when it's on, the next one is "Android System" with 7~10% always on, "batt_level_wq" shows on and off with 7~10% (it goes back to 0% and then comes back up) and "Smart Monitor" also shows sometimes with 3~5% (but goes back to 0% immediately as well).

    Could it be any of these 2 apps that are showing on and off that are preventing the phone from sleeping? What do you think?

    What does your phone show in the comparison between "Running" and "Screen on"?

    Thanks for your input!
  8. inFECT

    inFECT Android Enthusiast

    Search for the option which shows also the system apps running.
    This is the interesting part. Since no installed app seems to keep your phone from sleeping it might be a system process.

    My Phone stats after 3days are at: 6% "running" on 4% "screen on"
  9. maurinet

    maurinet Well-Known Member
    Thread Starter

    All of the /system/bin/ apps are in 0%, only /system/bin/mediaserver turns gray and back to white on and off (also in 0% though).

    I found something interesting though, when I sort them by Memory (instead of load), I can see this:

    Android System 21M **
    Contacts Storage 18M
    OSMonitor 17M
    Lock 2.0 12M
    Gesture Search 10M
    Dialer 10M
    AnySoftKeyboard 9M
    Android System 8M **
    /system/bin/mediaserver 3M

    from here on, they're all in Kilobytes.
    **And as you can see, "Android System" appears twice :S

    Am I just crazy and I don't have this bug? How else can I tell?
  10. maurinet

    maurinet Well-Known Member
    Thread Starter

    So I used the phone yesterday with all the connections off (wifi, gps, 3g/edge/gprs, network location, google share, etc.) and I got a bit more juice out of the phone, it lasted for about 18 hours. It's still not even close to the 3 days that some users are reporting, and I'm all out of ideas :(

  11. inFECT

    inFECT Android Enthusiast

    afaik its a "bug" of os monitor showing the android keyboard as android system.. it was something like this.. If you check details of the process you will see it.

    btw: did you tried a reinstall of galaxo?
  12. maurinet

    maurinet Well-Known Member
    Thread Starter

    So I've actually been considering doing the whole thing from scratch, maybe something went wrong during the installation and that's the problem. The only thing is that right now I don't really feel like going through the whole process of installing all the apps and stuff, so I have a question: If I make a backup with Titanium of all my apps and stuff, and then I restore that backup to the new installation, will that bring the bug back? Or will it work ok? Or is it better for me to just install everything afresh?
  13. inFECT

    inFECT Android Enthusiast

    Since the no sleep bug is caused by the Android System, you should be fine with reinstalling the apps via titanium backup.

    I would make a fresh install. Check out the system for 1-2 days without new apps.

    If the no sleep bug disappeared, kick in the tit. backup and hope it still work everything ;-)
  14. Andronix

    Andronix Android Enthusiast

    i think lock 2.0 is to blame for no sleep.
  15. maurinet

    maurinet Well-Known Member
    Thread Starter

    Hey Andronix:
    I could believe that, but, could you elaborate a little bit? Have you had any no-sleep experiences with Lock 2.0 or something like that?

  16. inFECT

    inFECT Android Enthusiast

    Oups, i have not seen lock 2.0

    This is the worst programm ever coded ;-) Actually all lock replacements out there are piece of crap. I can only suggest to get rid of it.

    I tried them all on the Galaxy. They failed horrible. Its possible that lock2.0 is the reason for your sleeping issues because every hardware key will wake up the phone while pressed.
  17. maurinet

    maurinet Well-Known Member
    Thread Starter

    So I've been testing a bunch of Screen Lock applications (Lock 2.0, Screen Suite, nunlock) and they all seem to turn on the screen when you press buttons other than the "lock" button, which makes me infer that all these apps don't let the phone sleep.
    I got rid of all of them, trying the phone now without these apps and without any wireless connections, we'll see how it goes. I'll keep you posted.

    BTW, does anyone have a good Screen Lock app? I just don't like the default Android unlock screen, I also find the press-and-hold to unlock really annoying and sometimes the screen just goes off if you don't press it for long enough.

  18. Andronix

    Andronix Android Enthusiast

    good unlock screen app? gaosp :)
  19. maurinet

    maurinet Well-Known Member
    Thread Starter

    Ok, so after running tests for a number of days, these are the conclusions that I came to:

    0.- Background data devours battery.

    1.- Lock 2.0, LockBot, Screen Suite, nunLock and all the other Screen Lock applications can easily malfunction and prevent your phone from sleeping. To test this, turn the screen off (lock button), wait for about 1 minute and then press the exterior buttons of your phone (volume, camera, call, etc.) - NONE of these buttons should make the screen light up (except for the lock and the on/off buttons). If your screen lights up your phone isn't sleeping... Usually a phone restart fixes this, but if it doesn't, then you should uninstall the application.

    2.- Turning off ALL the connections [obviously] helps conserve battery. Now, instead of leaving the wifi on all the time, I turn it on and off as needed.

    3.- Screen brightness doesn't have such a big impact on battery life (now have it set at 50% and looks awesome!)

    4.- The battery life really depends on phone usage, if I use the phone a lot during the day (calls, sms, games, wifi, twitter, facebook, email, browsing, etc.) then the battery lasts for about 12 hours, on low usage (a few calls & sms, occasional twitter, etc.) the battery lasts close to 24 hours.

    5.- Get AppSwipe Task Switcher. This is a lot more than a task switcher, it is a task/services/Processes switcher/manager. There are many task managers our there, and they all do the same, they show you what apps are open and you can close them... but what about when they don't show you the apps that are still latent in your system (not running, but loaded on memory)? AppSwipe shows you Running Apps, Services and Processes, and you can choose to terminate whatever you want.

    ie.: I found that "network location" would always start with the phone, even if it was turned off,
    using AppSwipe I was able to kill it, the same applies to "Gesture Search", "Music" and
    "Google Talk Service".

    So, in conclusion, there isn't a no-sleep bug on Galaxo, it's just the phone usage and some faulty applications that can drain your battery. Now, I'm leaving Drakaz alone and letting him focus on GAOSP... Can't wait!!! ;)

    AppSwipe Task Switcher:

Share This Page