1. Check out our companion app, Forums for Android! Download from Google Play

Support Galaxy 551 not starting up

Discussion in 'Android Devices' started by hiiii, Nov 18, 2012.

  1. hiiii

    hiiii Guest
    Thread Starter

    Hi, this is my first post on this forum.
    I'm having a problem with my new Samsung Galaxy 551 GT-I5510M, which I bought a few weeks ago.

    So my friend came over to my house yesterday, and he was playing on some apps I downloaded, and I was watching him play on them. Then suddenly the screen went blank, and then the phone looked like it was restarting.The first screen said Samsung, then the next one said the model number, so I thought it wasn't anything serious. But then instead of the boot animation, it just showed a triangle with an exclamation mark and a green android robot beside it.

    None of the keys worked, I had to take the battery out to shut it down.
    Restarting it takes me to the same screen. First Samsung, then model number, and then the triangle with a green android robot.

    When I tried connecting it to my computer with first the phone on, then off, nothing happened. I have Kies installed, it worked perfectly before this.

    I should also mention that I have not rooted or hacked the phone, and all of the apps I have downloaded are from Google Play.

    Does anyone know how to fix this?


  2. hiiii

    hiiii Guest
    Thread Starter

    Does anyone have a solution? Did this happen to you?
    Tried online chatting and phone (through landline), they said they only had support for devices made in the US.
  3. karandpr

    karandpr Well-Known Member

    Feb 16, 2011
    It's a common problem with Samsung Phones .

    A.)Go to Samsung/carrier and ask them to reflash the software ...It's free under warranty and around 2$ without it .(that was 6 months ago ...)

    B.)Flash the software using Odin Software ...search for tutorial in the Root section ...get the firmware from sammobile.com ...

Share This Page