1. Are you ready for the Galaxy S20? Here is everything we know so far!

Galaxy Bricked. HELP!

Discussion in 'Android Apps & Games' started by cushphil, Nov 15, 2014.

  1. cushphil

    cushphil Newbie
    Thread Starter

    HI Guys. I have an SGH-I747 galaxy S3 stuck in boot logo tried rsa recovery but no good I have tried Odin with a stock firmware but it fails. SO I tried an older version of Odin which still failed. Am I using incorrect FW? when I put it in download mode it says SGH-I747M so so I need a FW with the M at the end? Any thought welcome. oh BTW when I purchased it apparently it was rooted but not sure with what? if that makes any diff. Cheers
     

    Advertisement

  2. WoohooGuy

    WoohooGuy Android Enthusiast

    I747MVLUFNH2 Android 4.4.2 KitKat Firmware For Galaxy S3 SGH-I747M (Canada) - How To Guide | Android Pulp | #1 Android Customization Resource

    3/4 of the way down the page you will find the links for the firmware and instructions, it would appear the M is for Canadian versions.

    Make sure you get the right firmware for the carrier the device was originally sold through.

    Anytime you perform flashing operations you need to make sure the device is fully charged, You are using a high quality USB cable, and only use a USB port built into a computer, never a USB hub.

    Make sure you right click and run Odin as administrator.

    Heed the warning about making sure only Auto Reboot and F reset time are checked, boxes have a habit of rechecking themselves in Odin so verify the boxes as the last step right before clicking flash.

    Good luck.

    Note added - If the carrier updated the device to KitKat 4.4.4 then expect to get a notice for Over The Air update. (OTA).
     
  3. cushphil

    cushphil Newbie
    Thread Starter

    Hey cheers for the help. I updated the phone with that file and all went just fine. I have one issue. My phone keeps dropping the ability to text about once a day and I have to remove the sim and battery and restart it after a minute to make it work again. I called my provider and they were no help and suggested that cause it was an import it might not be compatible with there network which it was before I flashed this new patch. Any ideas and thoughts welcome. Cheers.
     
Loading...

Share This Page

Loading...