1. Check out our companion app, Forums for Android! Download from Google Play

Support Galaxy freezing, touch screen not responding, 0 network bar n battery draiing

Discussion in 'Android Devices' started by adey, Sep 12, 2010.

  1. adey

    adey New Member
    Thread Starter

    Sep 12, 2010
    Hi all, Noobie here..

    sorry for posting in spica forum.. had no option as i tried various forums no help so i m counting my luck here...

    I bought my Samsung Galaxy 3 apollo three days ago. This morning out of blue moon it just wont respond to my touch. I was trying to answer the calls it wont register the touch. then I tried to unlock it by sliding the finger.. it wont work. I thought perhaps the screen got sticky etc.. I cleaned it with a soft tissue.yest same problem. after trying for over hundred times, it finally responded. I was pressing on the contacts button to go to my contacts, it wont take me there.. it will open up a quick search window. each n every time.. i rebooted many a times but it wont fix the issue. the fone hasnt had any update since i first turned it on. no software or application installed. just out of blue moon. All day no access to messages nothing.. sometimes it will get kind and allow me to excess missed calls..

    then I also noticed that in the network bars it was showing 0 bar. previously it always had different according to the network reception. my firends had full network coverage (same service provider). then I also noticed that the blodybattery was draining out.. I recharged it like early in the morning fully. hardly used to fone to call and it is almost empty now at night...

    and strangely phone is not freezing. it is working normally now.. all bizarre... I called up the service centre they had no idea and said if it is working well now then there is nothing to complaint.. as they wont be able to see my screen freezes and the quick search pop ups.

    Any wise person here can help me.. three days old fone..and this issue... definitely a taste spoiler

    whats going on folks.

    Carrier: Airtel
    Country / Language: India / English
    OS / Browser / build number (if applicable): Android 2.1 Update 1


  2. Beerkan

    Beerkan Well-Known Member

    Apr 14, 2010
    Try a factory reset.

    Factory Reset.

    You loose all data etc, but you can follow my Quick Backup Guide Here.

    Backup Guide

    Failing that, contact your provider.
  3. lokesh_1112

    lokesh_1112 Member

    Jun 28, 2011
    even after factory reset it does not works. i have a galaxy FIT and its having same problem it does not recognize/respond to touch most oftem sometimes only it respond and once it responde it works flawless but it does not respond maximum time and dont work even after many restarts/hard resets.i have tried factory reset 3-4 times but problem still persists..
    please help....

Share This Page